summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyril Chemparathy <cyril.chemparathy@xilinx.com>2016-11-22 13:34:02 -0800
committerNathan Rossi <nathan@nathanrossi.com>2016-11-23 14:39:11 +1000
commited409fb9b5fefef6a938501c1fcf6b54f753147a (patch)
treede32a6bd3191e476e6b66068a36e6ef6d8137310
parentfca601dd39fef58e2fb2014af1df2145f280e1cd (diff)
downloadmeta-xilinx-ed409fb9b5fefef6a938501c1fcf6b54f753147a.tar.gz
arm-trusted-firmware_git.bb: deploy sensible name
The bl31 name doesn't mean much, and we're unlikely to support other payload types on ZU+. We therefore use a more human name for the deployed images Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
index b83b4e29..9f29fc4b 100644
--- a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
+++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
@@ -45,13 +45,13 @@ OUTPUT_DIR = "${S}/build/${PLATFORM}/release"
45 45
46do_deploy() { 46do_deploy() {
47 install -d ${DEPLOYDIR} 47 install -d ${DEPLOYDIR}
48 install -m 0644 ${OUTPUT_DIR}/bl31/bl31.elf ${DEPLOYDIR}/bl31-${MACHINE}.elf 48 install -m 0644 ${OUTPUT_DIR}/bl31/bl31.elf ${DEPLOYDIR}/arm-trusted-firmware-${MACHINE}.elf
49 install -m 0644 ${OUTPUT_DIR}/bl31.bin ${DEPLOYDIR}/bl31-${MACHINE}.bin 49 install -m 0644 ${OUTPUT_DIR}/bl31.bin ${DEPLOYDIR}/arm-trusted-firmware-${MACHINE}.bin
50 50
51 # Get the entry point address from the elf. 51 # Get the entry point address from the elf.
52 BL31_BASE_ADDR=$(${READELF} -h ${OUTPUT_DIR}/bl31/bl31.elf | egrep -m 1 -i "entry point.*?0x" | sed -r 's/.*?(0x.*?)/\1/g') 52 BL31_BASE_ADDR=$(${READELF} -h ${OUTPUT_DIR}/bl31/bl31.elf | egrep -m 1 -i "entry point.*?0x" | sed -r 's/.*?(0x.*?)/\1/g')
53 mkimage -A arm64 -O linux -T kernel -C none \ 53 mkimage -A arm64 -O linux -T kernel -C none \
54 -a $BL31_BASE_ADDR -e $BL31_BASE_ADDR \ 54 -a $BL31_BASE_ADDR -e $BL31_BASE_ADDR \
55 -d ${OUTPUT_DIR}/bl31.bin ${DEPLOYDIR}/atf.ub 55 -d ${OUTPUT_DIR}/bl31.bin ${DEPLOYDIR}/arm-trusted-firmware.ub
56} 56}
57addtask deploy before do_build after do_compile 57addtask deploy before do_build after do_compile