summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2016-11-17 15:12:12 -0800
committerNathan Rossi <nathan@nathanrossi.com>2016-11-18 23:18:20 +1000
commit134dd6f9d8d9a8fd153dde6467a412651742d4a4 (patch)
tree3c1645575f60ec834a3fb77775fba23d80558fa9
parent6f4fe6d8cdd97cc5b55c40472140d70267fff5a6 (diff)
downloadmeta-xilinx-134dd6f9d8d9a8fd153dde6467a412651742d4a4.tar.gz
xserver-xf86-config: Add xorg.conf
Add X configuration for MPSoC Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf27
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend1
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf
new file mode 100644
index 00000000..9ef39462
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/zynqmp/xorg.conf
@@ -0,0 +1,27 @@
1Section "InputDevice"
2 Identifier "System Mouse"
3 Driver "mouse"
4 Option "Device" "/dev/input/mouse0"
5EndSection
6
7Section "InputDevice"
8 Identifier "System Keyboard"
9 Driver "kbd"
10 Option "Device" "/dev/input/event0"
11EndSection
12
13Section "Device"
14 Identifier "ZynqMP"
15 Driver "armsoc"
16 Option "DRI2" "true"
17 Option "DRI2_PAGE_FLIP" "false"
18 Option "DRI2_WAIT_VSYNC" "true"
19 Option "SWcursorLCD" "false"
20 Option "DEBUG" "false"
21EndSection
22
23Section "Screen"
24 Identifier "DefaultScreen"
25 Device "ZynqMP"
26 DefaultDepth 16
27EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
new file mode 100644
index 00000000..72d991c7
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend
@@ -0,0 +1 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"