summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubin Usman Sayyed <mubin.usman.sayyed@xilinx.com>2020-03-18 19:13:44 +0530
committerMark Hatle <mark.hatle@xilinx.com>2020-03-18 10:08:37 -0700
commite1650c1187cbcea8ffc7053a46ffd5f1c849721c (patch)
treef5b201c85051c798b094e05b50955f0a7538da9a
parent6cef85b32e2bc0fdb20dc23003d430434d426647 (diff)
downloadmeta-xilinx-e1650c1187cbcea8ffc7053a46ffd5f1c849721c.tar.gz
meta-xilinx-standalone: classes: esw: Update ESW_CFLAGS with spec file
This is being done to avoid using unwanted startup files from newlib. Alll esw ARM processor machines are using their own crt0 implementation, and microblaze based machines are using all startup files from newlib. Signed-off-by: Mubin Usman Sayyed <mubin.usman.sayyed@xilinx.com> Rebase patch to avoid machine specific overrides, make this arch specific instead. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
-rw-r--r--meta-xilinx-standalone/classes/esw.bbclass5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-xilinx-standalone/classes/esw.bbclass b/meta-xilinx-standalone/classes/esw.bbclass
index 50fc7128..b05a596d 100644
--- a/meta-xilinx-standalone/classes/esw.bbclass
+++ b/meta-xilinx-standalone/classes/esw.bbclass
@@ -15,6 +15,11 @@ S = "${WORKDIR}/git/"
15B = "${WORKDIR}/build/" 15B = "${WORKDIR}/build/"
16OECMAKE_SOURCEPATH = "${S}/${ESW_COMPONENT_SRC}" 16OECMAKE_SOURCEPATH = "${S}/${ESW_COMPONENT_SRC}"
17 17
18SPECFILE_PATH_arm = "${S}/scripts/specs/arm/Xilinx.spec"
19SPECFILE_PATH_aarch64 = "${S}/scripts/specs/arm/Xilinx.spec"
20SPECFILE_PATH_microblaze = "${S}/scripts/specs/microblaze/Xilinx.spec"
21
22ESW_CFLAGS += "-specs=${SPECFILE_PATH}"
18 23
19inherit ccmake 24inherit ccmake
20 25