summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAppana Durga Kedareswara rao <appana.durga.rao@xilinx.com>2020-04-03 13:21:07 +0530
committerMark Hatle <mark.hatle@xilinx.com>2020-04-03 07:27:56 -0700
commitc424bf4e7e1cbb27facc542befd4194d9d2a6da0 (patch)
tree3c008525140183833fb913b689e5c495745d4772
parentd9abb7adf6a23b5e64b88d90b02d46d0716ae358 (diff)
downloadmeta-xilinx-c424bf4e7e1cbb27facc542befd4194d9d2a6da0.tar.gz
meta-xilinx-standalone: recipes-applications: freertos-hello-world: Fix do_deploy elf variable name
Signed-off-by: Appana Durga Kedareswara rao <appana.durga.rao@xilinx.com> Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
-rw-r--r--meta-xilinx-standalone/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-xilinx-standalone/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb b/meta-xilinx-standalone/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb
index 7702be93..9b5bb110 100644
--- a/meta-xilinx-standalone/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb
+++ b/meta-xilinx-standalone/recipes-applications/freertos-hello-world/freertos-hello-world_git.bb
@@ -21,7 +21,7 @@ FREERTOS_HELLO_WORLD_BASE_NAME[vardepsexclude] = "DATETIME"
21do_deploy() { 21do_deploy() {
22 22
23 # We need to deploy the stripped elf, hence why not doing it from ${D} 23 # We need to deploy the stripped elf, hence why not doing it from ${D}
24 install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.elf ${DEPLOYDIR}/${HELLO_WORLD_BASE_NAME}.elf 24 install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.elf ${DEPLOYDIR}/${FREERTOS_HELLO_WORLD_BASE_NAME}.elf
25 ln -sf ${FREERTOS_HELLO_WORLD_BASE_NAME}.elf ${DEPLOYDIR}/${BPN}-${MACHINE}.elf 25 ln -sf ${FREERTOS_HELLO_WORLD_BASE_NAME}.elf ${DEPLOYDIR}/${BPN}-${MACHINE}.elf
26 ${OBJCOPY} -O binary ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.elf ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.bin 26 ${OBJCOPY} -O binary ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.elf ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.bin
27 install -m 0644 ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.bin ${DEPLOYDIR}/${FREERTOS_HELLO_WORLD_BASE_NAME}.bin 27 install -m 0644 ${WORKDIR}/package/${base_libdir}/firmware/freertos_hello_world.bin ${DEPLOYDIR}/${FREERTOS_HELLO_WORLD_BASE_NAME}.bin