diff options
author | Mark Hatle <mark.hatle@amd.com> | 2022-09-13 07:24:52 -0700 |
---|---|---|
committer | Mark Hatle <mark.hatle@amd.com> | 2022-09-13 07:31:52 -0700 |
commit | 26b88d24e231806588d926faab56ca6d5f1c3791 (patch) | |
tree | d64295a1571d41b77e3927def17c9f04801f59ac | |
parent | 1cd865c9c93fe48f92970676d44575bf8227a172 (diff) | |
download | meta-xilinx-26b88d24e231806588d926faab56ca6d5f1c3791.tar.gz |
qemu: Specifically enable SLIRP support
Starting with kirkstone, SLIRP support must now be explicitly enabled in
the qemu build. The default implementation supports the Qemu 6.2 configure
arguments, but in qemu-xilinx 6.1, the corresponding configuration is
slightly different.
--enable-slirp=internal (6.2+)
vs
--enable-slirp=git (6.1)
When qemu-xilinx is updated to the newer version, the PACKAGECONFIG[slirp]
should revert back to the system default.
Signed-off-by: Mark Hatle <mark.hatle@amd.com>
3 files changed, 4 insertions, 7 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb index f177872a..49faa73c 100644 --- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb +++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb | |||
@@ -4,7 +4,7 @@ PROVIDES = "qemu-system-native" | |||
4 | 4 | ||
5 | EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}" | 5 | EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}" |
6 | 6 | ||
7 | PACKAGECONFIG ??= "fdt alsa kvm pie" | 7 | PACKAGECONFIG ??= "fdt alsa kvm pie slirp" |
8 | 8 | ||
9 | PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" | 9 | PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" |
10 | 10 | ||
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb index f177872a..49faa73c 100644 --- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb +++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb | |||
@@ -4,7 +4,7 @@ PROVIDES = "qemu-system-native" | |||
4 | 4 | ||
5 | EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}" | 5 | EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}" |
6 | 6 | ||
7 | PACKAGECONFIG ??= "fdt alsa kvm pie" | 7 | PACKAGECONFIG ??= "fdt alsa kvm pie slirp" |
8 | 8 | ||
9 | PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" | 9 | PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" |
10 | 10 | ||
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc index 0dde8023..48b85f21 100644 --- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc +++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc | |||
@@ -28,19 +28,16 @@ S = "${WORKDIR}/git" | |||
28 | 28 | ||
29 | # Disable KVM completely | 29 | # Disable KVM completely |
30 | PACKAGECONFIG:remove = "kvm" | 30 | PACKAGECONFIG:remove = "kvm" |
31 | PACKAGECONFIG:append = " fdt sdl gcrypt pie" | 31 | PACKAGECONFIG:append = " fdt sdl gcrypt pie slirp" |
32 | 32 | ||
33 | 33 | ||
34 | PACKAGECONFIG[gcrypt] = "--enable-gcrypt,--disable-gcrypt,libgcrypt," | ||
35 | PACKAGECONFIG[sdl] = "--enable-sdl,--disable-sdl,libsdl2" | ||
36 | PACKAGECONFIG[pie] = "--enable-pie,--disable-pie,," | ||
37 | |||
38 | # Remove when version is in sync with core oe-core | 34 | # Remove when version is in sync with core oe-core |
39 | PACKAGECONFIG:remove:class-nativesdk= "pulsedio" | 35 | PACKAGECONFIG:remove:class-nativesdk= "pulsedio" |
40 | PACKAGECONFIG:remove:class-native = "pulsedio" | 36 | PACKAGECONFIG:remove:class-native = "pulsedio" |
41 | PACKAGECONFIG[alsa] = "--audio-drv-list=alsa,,alsa-lib" | 37 | PACKAGECONFIG[alsa] = "--audio-drv-list=alsa,,alsa-lib" |
42 | PACKAGECONFIG[pulsedio] = "--audio-drv-list=pa,,pulseaudio" | 38 | PACKAGECONFIG[pulsedio] = "--audio-drv-list=pa,,pulseaudio" |
43 | PACKAGECONFIG[selinux] = "" | 39 | PACKAGECONFIG[selinux] = "" |
40 | PACKAGECONFIG[slirp] = "--enable-slirp=git,--disable-slirp,," | ||
44 | 41 | ||
45 | DISABLE_STATIC:pn-${PN} = "" | 42 | DISABLE_STATIC:pn-${PN} = "" |
46 | 43 | ||