summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-04-02 08:24:22 -0700
committerMark Hatle <mark.hatle@xilinx.com>2021-04-08 12:43:48 -0700
commit280065cf68f148a32a8299a5b04946c944568bee (patch)
tree8761f6f482bbbf1ff6006f06892be884d9b40063
parentcd493f6796afb622be466e58a3f88fdf54f53c8b (diff)
downloadmeta-xilinx-280065cf68f148a32a8299a5b04946c944568bee.tar.gz
libgloss: Fix crt*.o files that are stripped, when they shouldn't be
Issue: CR-1062133 For some reason libgloss installs the crt*.o files with executable bit set, this causes the build system to strip these as executables. However, it makes it impossible to use the .o files to properly link applications later on. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
-rw-r--r--meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend b/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend
index 3dee0f06..e7f0a9a3 100644
--- a/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend
+++ b/meta-microblaze/recipes-core/newlib/libgloss_3.3.%.bbappend
@@ -4,3 +4,10 @@ do_configure_prepend_microblaze() {
4 # hack for microblaze, which needs xilinx.ld to literally do any linking (its hard coded in its LINK_SPEC) 4 # hack for microblaze, which needs xilinx.ld to literally do any linking (its hard coded in its LINK_SPEC)
5 export CC="${CC} -L${S}/libgloss/microblaze" 5 export CC="${CC} -L${S}/libgloss/microblaze"
6} 6}
7
8# Libgloss provides various .o files in libdir
9# These must NOT be stripped, but for some reason they are installed +x
10# which triggers them to be stripped.
11do_install_append_microblaze() {
12 chmod 0644 ${D}${libdir}/*.o
13}