summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan.rossi@xilinx.com>2012-11-01 13:35:11 +1000
committerNathan Rossi <nathan.rossi@xilinx.com>2012-11-01 13:35:11 +1000
commit75e79f55637e59ed3c1e1aee3a3582de95b63d90 (patch)
tree8c08e0db6d28acf88cdd7c68571a0e1a658c1f0b
parent2a6400a0d76e22fe706c8adddb1821ca56688ac0 (diff)
downloadmeta-xilinx-75e79f55637e59ed3c1e1aee3a3582de95b63d90.tar.gz
libffi: Added recipe to use internal libffi git repository
* Internal libffi repository supports microblaze/microblazeel Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
-rwxr-xr-xrecipes-gnome/libffi/libffi_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-gnome/libffi/libffi_git.bb b/recipes-gnome/libffi/libffi_git.bb
new file mode 100755
index 00000000..719a93f3
--- /dev/null
+++ b/recipes-gnome/libffi/libffi_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "A portable foreign function interface library"
2DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
3conventions. This allows a programmer to call any function specified by a call interface description at run \
4time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
5interface that allows code written in one language to call code written in another language. The `libffi' \
6library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
7A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=e54c573c49435ccbbd3f6dc9e49a065e"
11
12S = "${WORKDIR}/git"
13PR = "r0"
14
15BRANCH = "microblaze-support-rebase"
16SRC_URI = "git://developer.petalogix.com/petalogix/internal/git/private/dev/nrossi/libffi;protocol=ssh;branch=${BRANCH}"
17
18SRCREV="${AUTOREV}"
19
20EXTRA_OECONF += "--disable-builddir"
21
22inherit autotools
23
24FILES_${PN}-dev += "${libdir}/libffi-${PV}"
25
26BBCLASSEXTEND = "native nativesdk"
27
28autotools_do_configure() {
29 if [ -e ${S}/configure ]; then
30 oe_runconf
31 else
32 bbnote "nothing to configure"
33 fi
34}