summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch48
-rw-r--r--recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch136
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3.patch (renamed from recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch)0
-rw-r--r--recipes-networking/openvswitch/openvswitch.inc23
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb9
5 files changed, 17 insertions, 199 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch
deleted file mode 100644
index 98224b42..00000000
--- a/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch
+++ /dev/null
@@ -1,48 +0,0 @@
1From 569ac1066cd3046b8ac899153df9f07908d45145 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Fri, 21 Jun 2013 11:16:00 -0400
4Subject: [PATCH] openvswitch: add target perl handling
5
6Allow the build to specify a path for the perl instead of reusing
7the PERL variable which can lead to inconsistencies if we are cross
8compiling. The TARGET_PERL variable will be used for script
9substitutions to ensure the scripts will be able to properly execute
10if the target system has a different path for the perl.
11
12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
13---
14 Makefile.am | 1 +
15 configure.ac | 7 +++++++
16 utilities/ovs-parse-leaks.in | 2 +-
17 3 files changed, 9 insertions(+), 1 deletion(-)
18
19Index: openvswitch-2.0.0/Makefile.am
20===================================================================
21--- openvswitch-2.0.0.orig/Makefile.am
22+++ openvswitch-2.0.0/Makefile.am
23@@ -114,6 +114,7 @@
24 -e 's,[@]LOGDIR[@],$(LOGDIR),g' \
25 -e 's,[@]DBDIR[@],$(DBDIR),g' \
26 -e 's,[@]PERL[@],$(PERL),g' \
27+ -e 's,[@]TARGET_PERL[@],$(TARGET_PERL),g' \
28 -e 's,[@]PYTHON[@],$(PYTHON),g' \
29 -e 's,[@]TARGET_PYTHON[@],$(TARGET_PYTHON),g' \
30 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
31Index: openvswitch-2.0.0/configure.ac
32===================================================================
33--- openvswitch-2.0.0.orig/configure.ac
34+++ openvswitch-2.0.0/configure.ac
35@@ -115,6 +115,13 @@
36 AC_SUBST(KARCH)
37 OVS_CHECK_LINUX
38
39+if test "$TARGET_PERL"; then
40+ TARGET_PERL=$TARGET_PERL
41+else
42+ TARGET_PERL=$PERL
43+fi
44+AC_SUBST(TARGET_PERL)
45+
46 if test "$TARGET_PYTHON"; then
47 TARGET_PYTHON=$TARGET_PYTHON
48 else
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
deleted file mode 100644
index 97b352cb..00000000
--- a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
+++ /dev/null
@@ -1,136 +0,0 @@
1From e8a5d34885c5fdba7d951fb1bb85131cbafca432 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 19 Jun 2013 17:25:56 -0400
4Subject: [PATCH] openvswitch: add target python handling
5
6Allow the build to specify a path for the python instead of reusing
7the PYTHON variable which can lead to inconsistencies if we are cross
8compiling. The TARGET_PYTHON variable will be used for script
9substitutions to ensure the scripts will be able to properly execute
10if the target system has a different path for the python.
11
12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
13---
14 Makefile.am | 1 +
15 configure.ac | 7 +++++++
16 ovsdb/ovsdbmonitor/ovsdbmonitor.in | 2 +-
17 utilities/bugtool/ovs-bugtool.in | 2 +-
18 utilities/ovs-check-dead-ifs.in | 2 +-
19 utilities/ovs-l3ping.in | 2 +-
20 utilities/ovs-parse-backtrace.in | 2 +-
21 utilities/ovs-pcap.in | 2 +-
22 utilities/ovs-tcpundump.in | 2 +-
23 utilities/ovs-test.in | 2 +-
24 utilities/ovs-vlan-test.in | 2 +-
25 11 files changed, 17 insertions(+), 9 deletions(-)
26
27Index: openvswitch-2.1.2/Makefile.am
28===================================================================
29--- openvswitch-2.1.2.orig/Makefile.am
30+++ openvswitch-2.1.2/Makefile.am
31@@ -125,6 +125,7 @@
32 -e 's,[@]DBDIR[@],$(DBDIR),g' \
33 -e 's,[@]PERL[@],$(PERL),g' \
34 -e 's,[@]PYTHON[@],$(PYTHON),g' \
35+ -e 's,[@]TARGET_PYTHON[@],$(TARGET_PYTHON),g' \
36 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
37 -e 's,[@]VERSION[@],$(VERSION),g' \
38 -e 's,[@]localstatedir[@],$(localstatedir),g' \
39Index: openvswitch-2.1.2/configure.ac
40===================================================================
41--- openvswitch-2.1.2.orig/configure.ac
42+++ openvswitch-2.1.2/configure.ac
43@@ -118,6 +118,13 @@
44 AC_SUBST(KARCH)
45 OVS_CHECK_LINUX
46
47+if test "$TARGET_PYTHON"; then
48+ TARGET_PYTHON=$TARGET_PYTHON
49+else
50+ TARGET_PYTHON=$PYTHON
51+fi
52+AC_SUBST(TARGET_PYTHON)
53+
54 AC_CONFIG_FILES(Makefile)
55 AC_CONFIG_FILES(datapath/Makefile)
56 AC_CONFIG_FILES(datapath/linux/Kbuild)
57Index: openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in
58===================================================================
59--- openvswitch-2.1.2.orig/utilities/bugtool/ovs-bugtool.in
60+++ openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in
61@@ -1,4 +1,4 @@
62-#! @PYTHON@
63+#! @TARGET_PYTHON@
64
65 # This library is free software; you can redistribute it and/or
66 # modify it under the terms of version 2.1 of the GNU Lesser General Public
67Index: openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in
68===================================================================
69--- openvswitch-2.1.2.orig/utilities/ovs-check-dead-ifs.in
70+++ openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in
71@@ -1,4 +1,4 @@
72-#! @PYTHON@
73+#! @TARGET_PYTHON@
74
75 import os
76 import re
77Index: openvswitch-2.1.2/utilities/ovs-l3ping.in
78===================================================================
79--- openvswitch-2.1.2.orig/utilities/ovs-l3ping.in
80+++ openvswitch-2.1.2/utilities/ovs-l3ping.in
81@@ -1,4 +1,4 @@
82-#! @PYTHON@
83+#! @TARGET_PYTHON@
84 #
85 # Licensed under the Apache License, Version 2.0 (the "License");
86 # you may not use this file except in compliance with the License.
87Index: openvswitch-2.1.2/utilities/ovs-parse-backtrace.in
88===================================================================
89--- openvswitch-2.1.2.orig/utilities/ovs-parse-backtrace.in
90+++ openvswitch-2.1.2/utilities/ovs-parse-backtrace.in
91@@ -1,4 +1,4 @@
92-#! @PYTHON@
93+#! @TARGET_PYTHON@
94 #
95 # Copyright (c) 2012 Nicira, Inc.
96 #
97Index: openvswitch-2.1.2/utilities/ovs-pcap.in
98===================================================================
99--- openvswitch-2.1.2.orig/utilities/ovs-pcap.in
100+++ openvswitch-2.1.2/utilities/ovs-pcap.in
101@@ -1,4 +1,4 @@
102-#! @PYTHON@
103+#! @TARGET_PYTHON@
104 #
105 # Copyright (c) 2010 Nicira, Inc.
106 #
107Index: openvswitch-2.1.2/utilities/ovs-tcpundump.in
108===================================================================
109--- openvswitch-2.1.2.orig/utilities/ovs-tcpundump.in
110+++ openvswitch-2.1.2/utilities/ovs-tcpundump.in
111@@ -1,4 +1,4 @@
112-#! @PYTHON@
113+#! @TARGET_PYTHON@
114 #
115 # Copyright (c) 2010 Nicira, Inc.
116 #
117Index: openvswitch-2.1.2/utilities/ovs-test.in
118===================================================================
119--- openvswitch-2.1.2.orig/utilities/ovs-test.in
120+++ openvswitch-2.1.2/utilities/ovs-test.in
121@@ -1,4 +1,4 @@
122-#! @PYTHON@
123+#! @TARGET_PYTHON@
124 #
125 # Licensed under the Apache License, Version 2.0 (the "License");
126 # you may not use this file except in compliance with the License.
127Index: openvswitch-2.1.2/utilities/ovs-vlan-test.in
128===================================================================
129--- openvswitch-2.1.2.orig/utilities/ovs-vlan-test.in
130+++ openvswitch-2.1.2/utilities/ovs-vlan-test.in
131@@ -1,4 +1,4 @@
132-#! @PYTHON@
133+#! @TARGET_PYTHON@
134 #
135 # Copyright (c) 2010 Nicira, Inc.
136 #
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3.patch
index 7e740441..7e740441 100644
--- a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-8c0b419a0b9ac0141d6973dcc80306dfc6a83d31.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3.patch
diff --git a/recipes-networking/openvswitch/openvswitch.inc b/recipes-networking/openvswitch/openvswitch.inc
index 3c70703a..ab1f8feb 100644
--- a/recipes-networking/openvswitch/openvswitch.inc
+++ b/recipes-networking/openvswitch/openvswitch.inc
@@ -31,13 +31,12 @@ SRC_URI = "\
31 file://openvswitch-switch-setup \ 31 file://openvswitch-switch-setup \
32 file://openvswitch-testcontroller \ 32 file://openvswitch-testcontroller \
33 file://openvswitch-testcontroller-setup \ 33 file://openvswitch-testcontroller-setup \
34 file://openvswitch-add-target-python-handling.patch \
35 file://openvswitch-add-target-perl-handling.patch \
36 " 34 "
37 35
38EXTRA_OECONF += "\ 36EXTRA_OECONF += "\
39 TARGET_PYTHON=${bindir}/python \ 37 PYTHON=${bindir}/python \
40 TARGET_PERL=${bindir}/perl \ 38 PYTHON3=${bindir}/python3 \
39 PERL=${bindir}/perl \
41 " 40 "
42CONFIGUREOPT_DEPTRACK = "" 41CONFIGUREOPT_DEPTRACK = ""
43 42
@@ -61,8 +60,9 @@ FILES_${PN}-brcompat = "${sbindir}/ovs-brcompatd"
61FILES_${PN}-switch = "\ 60FILES_${PN}-switch = "\
62 ${sysconfdir}/init.d/openvswitch-switch \ 61 ${sysconfdir}/init.d/openvswitch-switch \
63 ${sysconfdir}/default/openvswitch-switch \ 62 ${sysconfdir}/default/openvswitch-switch \
63 ${systemd_unitdir}/system/ovs-vswitchd.service \
64 ${systemd_unitdir}/system/openvswitch.service \ 64 ${systemd_unitdir}/system/openvswitch.service \
65 ${systemd_unitdir}/system/openvswitch-nonetwork.service \ 65 ${systemd_unitdir}/system/ovsdb-server.service \
66 " 66 "
67 67
68# silence a warning 68# silence a warning
@@ -74,8 +74,9 @@ inherit autotools update-rc.d systemd python-dir
74 74
75SYSTEMD_PACKAGES = "${PN}-switch" 75SYSTEMD_PACKAGES = "${PN}-switch"
76SYSTEMD_SERVICE_${PN}-switch = " \ 76SYSTEMD_SERVICE_${PN}-switch = " \
77 openvswitch-nonetwork.service \ 77 ovsdb-server.service \
78 openvswitch-switch.service \ 78 ovs-vswitchd.service \
79 openvswitch.service \
79" 80"
80 81
81INITSCRIPT_PACKAGES = "${PN}-switch ${PN}-testcontroller" 82INITSCRIPT_PACKAGES = "${PN}-switch ${PN}-testcontroller"
@@ -97,10 +98,12 @@ do_install_append() {
97 true || rm -fr ${D}/${datadir}/${PN}/pki 98 true || rm -fr ${D}/${datadir}/${PN}/pki
98 99
99 install -d ${D}/${systemd_unitdir}/system/ 100 install -d ${D}/${systemd_unitdir}/system/
101 install -m 644 ${S}/rhel/usr_lib_systemd_system_ovs-vswitchd.service \
102 ${D}/${systemd_unitdir}/system/ovs-vswitchd.service
100 install -m 644 ${S}/rhel/usr_lib_systemd_system_openvswitch.service \ 103 install -m 644 ${S}/rhel/usr_lib_systemd_system_openvswitch.service \
101 ${D}/${systemd_unitdir}/system/openvswitch-switch.service 104 ${D}/${systemd_unitdir}/system/openvswitch.service
102 install -m 644 ${S}/rhel/usr_lib_systemd_system_openvswitch-nonetwork.service \ 105 install -m 644 ${S}/rhel/usr_lib_systemd_system_ovsdb-server.service \
103 ${D}/${systemd_unitdir}/system/openvswitch-nonetwork.service 106 ${D}/${systemd_unitdir}/system/ovsdb-server.service
104 107
105 oe_runmake modules_install INSTALL_MOD_PATH=${D} 108 oe_runmake modules_install INSTALL_MOD_PATH=${D}
106 install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages 109 install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 1c6252a9..55e3a9a2 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -12,14 +12,13 @@ RDEPENDS_${PN}-ptest += "\
12 " 12 "
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15PV = "2.5.0+${SRCREV}" 15PV = "2.6.1+${SRCREV}"
16 16
17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" 17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
18 18
19SRCREV = "8c0b419a0b9ac0141d6973dcc80306dfc6a83d31" 19SRCREV = "f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3"
20SRC_URI += "\ 20SRC_URI += "\
21 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.5 \ 21 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.6 \
22 file://openvswitch-add-more-target-python-substitutions.patch \
23 file://openvswitch-add-ptest-${SRCREV}.patch \ 22 file://openvswitch-add-ptest-${SRCREV}.patch \
24 file://run-ptest \ 23 file://run-ptest \
25 file://disable_m4_check.patch \ 24 file://disable_m4_check.patch \
@@ -27,7 +26,7 @@ SRC_URI += "\
27 file://openvswitch-ptest-Fix-python-path.patch \ 26 file://openvswitch-ptest-Fix-python-path.patch \
28 " 27 "
29 28
30LIC_FILES_CHKSUM = "file://COPYING;md5=247d8817aece26b21a8cd6791b3ea994" 29LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35"
31 30
32PACKAGECONFIG ?= "" 31PACKAGECONFIG ?= ""
33PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}/opt/dpdk/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk," 32PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}/opt/dpdk/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,"