summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch')
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch12
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/kernel_module.patch29
-rw-r--r--recipes-networking/openvswitch/openvswitch.inc1
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb10
4 files changed, 9 insertions, 43 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch
index 711a1487..ce1f6501 100644
--- a/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch
+++ b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch
@@ -9,11 +9,11 @@ Signed-off-by: Amy Fong <amy.fong@windriver.com>
9 Makefile.am | 2 +- 9 Makefile.am | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-) 10 1 file changed, 1 insertion(+), 1 deletion(-)
11 11
12diff --git a/Makefile.am b/Makefile.am 12Index: git/Makefile.am
13index ff7d70a..2fc1f13 100644 13===================================================================
14--- a/Makefile.am 14--- git.orig/Makefile.am
15+++ b/Makefile.am 15+++ git/Makefile.am
16@@ -187,7 +187,7 @@ CLEAN_LOCAL += clean-pycov 16@@ -194,7 +194,7 @@
17 17
18 # If we're checked out from a Git repository, make sure that every 18 # If we're checked out from a Git repository, make sure that every
19 # file that is in Git is distributed. 19 # file that is in Git is distributed.
@@ -21,4 +21,4 @@ index ff7d70a..2fc1f13 100644
21+# ALL_LOCAL += dist-hook-git 21+# ALL_LOCAL += dist-hook-git
22 dist-hook-git: distfiles 22 dist-hook-git: distfiles
23 @if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \ 23 @if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \
24 (cd datapath && $(MAKE) distfiles); \ 24 (cd $(srcdir) && git ls-files) | grep -v '\.gitignore$$' | \
diff --git a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch
deleted file mode 100644
index 5e5a38d9..00000000
--- a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 9b7fb1346702d59af67435487254ef35940bc16a Mon Sep 17 00:00:00 2001
2From: "Hongzhi.Song" <hongzhi.song@windriver.com>
3Date: Wed, 23 Jan 2019 03:41:30 -0500
4Subject: [PATCH] datapatch/linux: Specify install path for kernel module
5
6Signed-off-by: Amy Fong <amy.fong@windriver.com>
7Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
8---
9 datapath/linux/Makefile.main.in | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in
13index 328bbfb..6dcc8d0 100644
14--- a/datapath/linux/Makefile.main.in
15+++ b/datapath/linux/Makefile.main.in
16@@ -71,8 +71,8 @@ default:
17 $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules
18
19 modules_install:
20- $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install
21- /sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h`
22+ $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH}
23+ #/sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h`
24 endif
25
26 # Much of the kernel build system in this file is derived from Intel's
27--
282.8.1
29
diff --git a/recipes-networking/openvswitch/openvswitch.inc b/recipes-networking/openvswitch/openvswitch.inc
index e6c9091a..767a41e6 100644
--- a/recipes-networking/openvswitch/openvswitch.inc
+++ b/recipes-networking/openvswitch/openvswitch.inc
@@ -132,7 +132,6 @@ do_install:append() {
132 install -d ${D}/usr/share/openvswitch/scripts/ 132 install -d ${D}/usr/share/openvswitch/scripts/
133 install -m 755 ${S}/rhel/usr_share_openvswitch_scripts_ovs-systemd-reload ${D}/usr/share/openvswitch/scripts/ovs-systemd-reload 133 install -m 755 ${S}/rhel/usr_share_openvswitch_scripts_ovs-systemd-reload ${D}/usr/share/openvswitch/scripts/ovs-systemd-reload
134 134
135 oe_runmake modules_install INSTALL_MOD_PATH=${D}${root_prefix}
136 install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages 135 install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages
137 cp -r ${S}/python/ovstest/ ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages/ 136 cp -r ${S}/python/ovstest/ ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages/
138} 137}
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index f5d85f3f..925444e0 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -14,17 +14,16 @@ RDEPENDS:${PN}-ptest += "\
14 " 14 "
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17PV = "2.17.1+${SRCPV}" 17PV = "3.0.3+${SRCPV}"
18CVE_VERSION = "2.17.1" 18CVE_VERSION = "2.17.1"
19 19
20FILESEXTRAPATHS:append := "${THISDIR}/${PN}-git:" 20FILESEXTRAPATHS:append := "${THISDIR}/${PN}-git:"
21 21
22SRCREV = "41bb202fb37f184b0a8820a029c62d03c118614e" 22SRCREV = "7b5c4240c1ed5f38e476cf08819869dc14f55e8a"
23SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-2.17 \ 23SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-3.0 \
24 file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \ 24 file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \
25 file://run-ptest \ 25 file://run-ptest \
26 file://disable_m4_check.patch \ 26 file://disable_m4_check.patch \
27 file://kernel_module.patch \
28 file://systemd-update-tool-paths.patch \ 27 file://systemd-update-tool-paths.patch \
29 file://systemd-create-runtime-dirs.patch \ 28 file://systemd-create-runtime-dirs.patch \
30 " 29 "
@@ -52,6 +51,3 @@ do_install_ptest() {
52 oe_runmake test-install 51 oe_runmake test-install
53} 52}
54 53
55do_install:append() {
56 oe_runmake modules_install INSTALL_MOD_PATH=${D}${root_prefix}
57}