summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch')
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch
new file mode 100644
index 00000000..76e312ca
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-1667bb34988358aaf1c92d0d21fad4b1c8698780.patch
@@ -0,0 +1,69 @@
1Add test-install rule to support ptest execution
2
3Signed-off-by: Radu Patriu <radu.patriu@enea.com>
4
5---
6 Makefile.am | 2 ++
7 test.mk | 49 +++++++++++++++++++++++++++++++++++++++++++++++++
8 2 files changed, 51 insertions(+)
9
10--- a/Makefile.am
11+++ b/Makefile.am
12@@ -369,3 +369,5 @@
13 include vtep/automake.mk
14 include datapath-windows/automake.mk
15 include datapath-windows/include/automake.mk
16+include test.mk
17+
18--- /dev/null
19+++ b/test.mk
20@@ -0,0 +1,49 @@
21+TEST_DEST ?= ${prefix}/lib/openvswitch
22+TEST_ROOT ?= ${prefix}/lib/openvswitch
23+TEST_DEPEND =
24+
25+if HAVE_OPENSSL
26+TEST_DEPEND += $(TESTPKI_FILES)
27+endif
28+
29+test-install: $(TEST_DEPEND)
30+ @list='$(noinst_PROGRAMS) $(EXTRA_DIST) $(dist_check_SCRIPTS) $(TEST_DEPEND) tests/atlocal tests/atconfig' ;\
31+ install -d $(TEST_DEST)/tests ;\
32+ install -d $(TEST_DEST)/python ;\
33+ install -d $(TEST_DEST)/python/ovs ;\
34+ install -d $(TEST_DEST)/python/ovs/db ;\
35+ install -d $(TEST_DEST)/python/ovs/unixctl ;\
36+ install -d $(TEST_DEST)/vswitchd ;\
37+ install vswitchd/vswitch.ovsschema $(TEST_DEST)/vswitchd ;\
38+ install -d $(TEST_DEST)/debian ;\
39+ install debian/ovs-monitor-ipsec $(TEST_DEST)/debian ;\
40+ install -d $(TEST_DEST)/build-aux ;\
41+ install build-aux/check-structs $(TEST_DEST)/build-aux ;\
42+ install -d $(TEST_DEST)/xenserver ;\
43+ install xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync $(TEST_DEST)/xenserver ;\
44+ install xenserver/opt_xensource_libexec_interface-reconfigure $(TEST_DEST)/xenserver ;\
45+ install xenserver/opt_xensource_libexec_InterfaceReconfigure.py $(TEST_DEST)/xenserver ;\
46+ install xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py $(TEST_DEST)/xenserver ;\
47+ install xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py $(TEST_DEST)/xenserver ;\
48+ install -d $(TEST_DEST)/vtep ;\
49+ install vtep/vtep.ovsschema $(TEST_DEST)/vtep ;\
50+ for p in $$list ; do \
51+ echo $$p ;\
52+ p=$${p#./} ;\
53+ pre=$${p#tests\/} ;\
54+ if test $$pre != $$p ; then \
55+ echo installing $$p to $(TEST_DEST)/tests/$$pre ;\
56+ install $$p $(TEST_DEST)/tests/$$pre ;\
57+ continue ;\
58+ fi ;\
59+ pre=$${p#python\/ovs\/} ;\
60+ if test $$pre != $$p ; then \
61+ echo installing $$p to $(TEST_DEST)/python/ovs/$$pre ;\
62+ install $$p $(TEST_DEST)/python/ovs/$$pre ;\
63+ continue ;\
64+ fi; \
65+ done ;\
66+ sed -i 's|abs_builddir=.*|abs_builddir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig
67+ sed -i 's|abs_srcdir=.*|abs_srcdir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig
68+ sed -i 's|abs_top_srcdir=.*|abs_top_srcdir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig
69+ sed -i 's|abs_top_builddir=.*|abs_top_builddir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig