diff options
Diffstat (limited to 'recipes-extended')
6 files changed, 34 insertions, 69 deletions
diff --git a/recipes-extended/kvmtool/files/0001-Avoid-pointers-for-address-of-packed-members.patch b/recipes-extended/kvmtool/files/0001-Avoid-pointers-for-address-of-packed-members.patch deleted file mode 100644 index 863e86a8..00000000 --- a/recipes-extended/kvmtool/files/0001-Avoid-pointers-for-address-of-packed-members.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From 2e22df7c24dadf5e16004cd832cabca76a699d4d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 21 Mar 2017 23:32:39 -0700 | ||
4 | Subject: [PATCH] Avoid pointers for address of packed members | ||
5 | |||
6 | Fixes Clang warning due to -Waddress-of-packed-member | ||
7 | |||
8 | virtio/blk.c:161:37: error: taking address of packed member 'geometry' of class or structure 'virtio_blk_config' may result in an unaligned pointer value [-Werror,-Waddress-of-packed-member] | ||
9 | struct virtio_blk_geometry *geo = &conf->geometry; | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | virtio/blk.c | 3 +-- | ||
14 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/virtio/blk.c b/virtio/blk.c | ||
17 | index c485e4f..1f7365d 100644 | ||
18 | --- a/virtio/blk.c | ||
19 | +++ b/virtio/blk.c | ||
20 | @@ -158,7 +158,6 @@ static void set_guest_features(struct kvm *kvm, void *dev, u32 features) | ||
21 | { | ||
22 | struct blk_dev *bdev = dev; | ||
23 | struct virtio_blk_config *conf = &bdev->blk_config; | ||
24 | - struct virtio_blk_geometry *geo = &conf->geometry; | ||
25 | |||
26 | bdev->features = features; | ||
27 | |||
28 | @@ -167,7 +166,7 @@ static void set_guest_features(struct kvm *kvm, void *dev, u32 features) | ||
29 | conf->seg_max = virtio_host_to_guest_u32(&bdev->vdev, conf->seg_max); | ||
30 | |||
31 | /* Geometry */ | ||
32 | - geo->cylinders = virtio_host_to_guest_u16(&bdev->vdev, geo->cylinders); | ||
33 | + conf->geometry.cylinders = virtio_host_to_guest_u16(&bdev->vdev, conf->geometry.cylinders); | ||
34 | |||
35 | conf->blk_size = virtio_host_to_guest_u32(&bdev->vdev, conf->blk_size); | ||
36 | conf->min_io_size = virtio_host_to_guest_u16(&bdev->vdev, conf->min_io_size); | ||
37 | -- | ||
38 | 2.12.0 | ||
39 | |||
diff --git a/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch b/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch index 63911fc2..4582285b 100644 --- a/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch +++ b/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch | |||
@@ -1,20 +1,21 @@ | |||
1 | From bcd954ffdb9383030e02d356b51e09e4e2a7105a Mon Sep 17 00:00:00 2001 | 1 | From 6b864b05b7aea74f375502250e99f54564cfe829 Mon Sep 17 00:00:00 2001 |
2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> | 2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> |
3 | Date: Sun, 5 Nov 2017 12:39:52 +0100 | 3 | Date: Sun, 5 Nov 2017 12:39:52 +0100 |
4 | Subject: [PATCH 1/2] kvmtool: 9p: fixed compilation error | 4 | Subject: [PATCH] kvmtool: 9p: fixed compilation error |
5 | 5 | ||
6 | makedev is defined in sys/sysmacros.h | 6 | makedev is defined in sys/sysmacros.h |
7 | 7 | ||
8 | Signed-off-by: Dariusz Pelowski <dariusz.pelowski@gmail.com> | 8 | Signed-off-by: Dariusz Pelowski <dariusz.pelowski@gmail.com> |
9 | |||
9 | --- | 10 | --- |
10 | virtio/9p.c | 1 + | 11 | virtio/9p.c | 1 + |
11 | 1 file changed, 1 insertion(+) | 12 | 1 file changed, 1 insertion(+) |
12 | 13 | ||
13 | diff --git a/virtio/9p.c b/virtio/9p.c | 14 | diff --git a/virtio/9p.c b/virtio/9p.c |
14 | index 6acbfdd..1dee2c2 100644 | 15 | index b78f2b3..838c5c4 100644 |
15 | --- a/virtio/9p.c | 16 | --- a/virtio/9p.c |
16 | +++ b/virtio/9p.c | 17 | +++ b/virtio/9p.c |
17 | @@ -15,6 +15,7 @@ | 18 | @@ -16,6 +16,7 @@ |
18 | #include <string.h> | 19 | #include <string.h> |
19 | #include <errno.h> | 20 | #include <errno.h> |
20 | #include <sys/vfs.h> | 21 | #include <sys/vfs.h> |
@@ -22,6 +23,3 @@ index 6acbfdd..1dee2c2 100644 | |||
22 | 23 | ||
23 | #include <linux/virtio_ring.h> | 24 | #include <linux/virtio_ring.h> |
24 | #include <linux/virtio_9p.h> | 25 | #include <linux/virtio_9p.h> |
25 | -- | ||
26 | 2.15.0 | ||
27 | |||
diff --git a/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch b/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch index 262531ca..dbb2bebe 100644 --- a/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch +++ b/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch | |||
@@ -1,18 +1,19 @@ | |||
1 | From 977a4d41012d1814f5a5330cacc2e4944de387cc Mon Sep 17 00:00:00 2001 | 1 | From 80eb205fd165072724a6e6db1dff8ab0bf2aa667 Mon Sep 17 00:00:00 2001 |
2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> | 2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> |
3 | Date: Sun, 5 Nov 2017 12:39:21 +0100 | 3 | Date: Sun, 5 Nov 2017 12:39:21 +0100 |
4 | Subject: [PATCH 2/2] kvmtool: add EXTRA_CFLAGS variable | 4 | Subject: [PATCH] kvmtool: add EXTRA_CFLAGS variable |
5 | 5 | ||
6 | to avoid CFLAGS overriding introduce new EXTRA_CFLAGS variable | 6 | to avoid CFLAGS overriding introduce new EXTRA_CFLAGS variable |
7 | for setting via command argument | 7 | for setting via command argument |
8 | 8 | ||
9 | Signed-off-by: Dariusz Pelowski <dariusz.pelowski@gmail.com> | 9 | Signed-off-by: Dariusz Pelowski <dariusz.pelowski@gmail.com> |
10 | |||
10 | --- | 11 | --- |
11 | Makefile | 2 ++ | 12 | Makefile | 2 ++ |
12 | 1 file changed, 2 insertions(+) | 13 | 1 file changed, 2 insertions(+) |
13 | 14 | ||
14 | diff --git a/Makefile b/Makefile | 15 | diff --git a/Makefile b/Makefile |
15 | index 64a0a16..bca1b26 100644 | 16 | index 3787df2..ece3d2a 100644 |
16 | --- a/Makefile | 17 | --- a/Makefile |
17 | +++ b/Makefile | 18 | +++ b/Makefile |
18 | @@ -2,6 +2,8 @@ | 19 | @@ -2,6 +2,8 @@ |
@@ -22,8 +23,5 @@ index 64a0a16..bca1b26 100644 | |||
22 | +CFLAGS += $(EXTRA_CFLAGS) | 23 | +CFLAGS += $(EXTRA_CFLAGS) |
23 | + | 24 | + |
24 | ifeq ($(strip $(V)),) | 25 | ifeq ($(strip $(V)),) |
25 | E = @echo | 26 | ifeq ($(findstring s,$(filter-out --%,$(MAKEFLAGS))),) |
26 | Q = @ | 27 | E = @echo |
27 | -- | ||
28 | 2.15.0 | ||
29 | |||
diff --git a/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch b/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch index 4d2f2555..7b1b7f6f 100644 --- a/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch +++ b/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch | |||
@@ -1,24 +1,23 @@ | |||
1 | From 377a09c16003eaa40f7f337127b10728ee0ade35 Mon Sep 17 00:00:00 2001 | 1 | From 532043e6937b78b12d89d0c6001f0e1853143247 Mon Sep 17 00:00:00 2001 |
2 | From: Cevat Bostancioglu <bostancioglucevat@gmail.com> | 2 | From: Cevat Bostancioglu <bostancioglucevat@gmail.com> |
3 | Date: Wed, 19 Jun 2019 20:36:56 +0300 | 3 | Date: Wed, 19 Jun 2019 20:36:56 +0300 |
4 | Subject: [PATCH] WERROR override disabled. | 4 | Subject: [PATCH] WERROR override disabled. |
5 | 5 | ||
6 | WERROR override causes gcc sizeof-pointer-memaccess, format-truncation errors. | 6 | WERROR override causes gcc sizeof-pointer-memaccess, format-truncation errors. |
7 | |||
7 | --- | 8 | --- |
8 | Makefile | 1 + | 9 | Makefile | 1 + |
9 | 1 file changed, 1 insertion(+) | 10 | 1 file changed, 1 insertion(+) |
10 | 11 | ||
11 | diff --git a/Makefile b/Makefile | 12 | diff --git a/Makefile b/Makefile |
12 | index 030ff4e..fc5e177 100644 | 13 | index ece3d2a..da6c1f0 100644 |
13 | --- a/Makefile | 14 | --- a/Makefile |
14 | +++ b/Makefile | 15 | +++ b/Makefile |
15 | @@ -2,6 +2,7 @@ | 16 | @@ -4,6 +4,7 @@ |
16 | # Define WERROR=0 to disable -Werror. | 17 | |
17 | # | 18 | CFLAGS += $(EXTRA_CFLAGS) |
18 | 19 | ||
19 | +WERROR = 0 | 20 | +WERROR = 0 |
20 | ifeq ($(strip $(V)),) | 21 | ifeq ($(strip $(V)),) |
21 | E = @echo | 22 | ifeq ($(findstring s,$(filter-out --%,$(MAKEFLAGS))),) |
22 | Q = @ | 23 | E = @echo |
23 | -- | ||
24 | 2.7.4 | ||
diff --git a/recipes-extended/kvmtool/files/external-crosscompiler.patch b/recipes-extended/kvmtool/files/external-crosscompiler.patch index 75cef3b1..ab030c73 100644 --- a/recipes-extended/kvmtool/files/external-crosscompiler.patch +++ b/recipes-extended/kvmtool/files/external-crosscompiler.patch | |||
@@ -1,14 +1,23 @@ | |||
1 | From b89ba4256cb6074aee74ea5386bc5ca8e75d4653 Mon Sep 17 00:00:00 2001 | ||
2 | From: Stefan Agner <stefan@agner.ch> | ||
3 | Date: Tue, 6 Sep 2016 11:51:40 -0700 | ||
4 | Subject: [PATCH] kvmtool: add lightweight hypervisor native Linux KVM tool | ||
5 | |||
1 | Upstream-Status: Inappropriate [embedded specific] | 6 | Upstream-Status: Inappropriate [embedded specific] |
2 | 7 | ||
3 | This allows OpenEmbedded to pass in cross compiler configuration using | 8 | This allows OpenEmbedded to pass in cross compiler configuration using |
4 | the default envirnment variables. It is required so that kvmtool can | 9 | the default envirnment variables. It is required so that kvmtool can |
5 | be linked against the cross-compiled libfdt library. | 10 | be linked against the cross-compiled libfdt library. |
6 | 11 | ||
12 | --- | ||
13 | Makefile | 8 +------- | ||
14 | 1 file changed, 1 insertion(+), 7 deletions(-) | ||
15 | |||
7 | diff --git a/Makefile b/Makefile | 16 | diff --git a/Makefile b/Makefile |
8 | index 1f0196f..8bfb068 100644 | 17 | index 35bb118..3787df2 100644 |
9 | --- a/Makefile | 18 | --- a/Makefile |
10 | +++ b/Makefile | 19 | +++ b/Makefile |
11 | @@ -14,11 +14,6 @@ export E Q | 20 | @@ -18,12 +18,6 @@ export E Q |
12 | include config/utilities.mak | 21 | include config/utilities.mak |
13 | include config/feature-tests.mak | 22 | include config/feature-tests.mak |
14 | 23 | ||
@@ -16,11 +25,12 @@ index 1f0196f..8bfb068 100644 | |||
16 | -CFLAGS := | 25 | -CFLAGS := |
17 | -LD := $(CROSS_COMPILE)ld | 26 | -LD := $(CROSS_COMPILE)ld |
18 | -LDFLAGS := | 27 | -LDFLAGS := |
28 | -OBJCOPY := $(CROSS_COMPILE)objcopy | ||
19 | - | 29 | - |
20 | FIND := find | 30 | FIND := find |
21 | CSCOPE := cscope | 31 | CSCOPE := cscope |
22 | TAGS := ctags | 32 | TAGS := ctags |
23 | @@ -297,7 +292,7 @@ $(warning No static libc found. Skipping guest init) | 33 | @@ -319,7 +313,7 @@ $(warning No static libc found. Skipping guest init) |
24 | endif | 34 | endif |
25 | 35 | ||
26 | ifeq (y,$(ARCH_WANT_LIBFDT)) | 36 | ifeq (y,$(ARCH_WANT_LIBFDT)) |
diff --git a/recipes-extended/kvmtool/kvmtool.bb b/recipes-extended/kvmtool/kvmtool.bb index 90ad8a1f..822d97b9 100644 --- a/recipes-extended/kvmtool/kvmtool.bb +++ b/recipes-extended/kvmtool/kvmtool.bb | |||
@@ -11,14 +11,13 @@ inherit kernel-arch | |||
11 | 11 | ||
12 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \ | 12 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git \ |
13 | file://external-crosscompiler.patch \ | 13 | file://external-crosscompiler.patch \ |
14 | file://0001-Avoid-pointers-for-address-of-packed-members.patch \ | ||
15 | file://0001-kvmtool-9p-fixed-compilation-error.patch \ | 14 | file://0001-kvmtool-9p-fixed-compilation-error.patch \ |
16 | file://0002-kvmtool-add-EXTRA_CFLAGS-variable.patch \ | 15 | file://0002-kvmtool-add-EXTRA_CFLAGS-variable.patch \ |
17 | file://0003-kvmtool-Werror-disabled.patch \ | 16 | file://0003-kvmtool-Werror-disabled.patch \ |
18 | " | 17 | " |
19 | 18 | ||
20 | SRCREV = "0e1882a49f81cb15d328ef83a78849c0ea26eecc" | 19 | SRCREV = "90b2d3adadf218dfc6bdfdfcefe269843360223c" |
21 | PV = "4.14.0+git${SRCPV}" | 20 | PV = "5.10.0+git${SRCPV}" |
22 | 21 | ||
23 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
24 | 23 | ||