summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt/libvirt_1.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/libvirt/libvirt_1.0.3.bb')
-rw-r--r--recipes-extended/libvirt/libvirt_1.0.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.0.3.bb b/recipes-extended/libvirt/libvirt_1.0.3.bb
index 479ce7e1..768ccc8d 100644
--- a/recipes-extended/libvirt/libvirt_1.0.3.bb
+++ b/recipes-extended/libvirt/libvirt_1.0.3.bb
@@ -150,4 +150,25 @@ do_install_append() {
150 # This will wind up in the libvirtd package, but will NOT be invoked by default. 150 # This will wind up in the libvirtd package, but will NOT be invoked by default.
151 # 151 #
152 mv ${D}/${libexecdir}/libvirt-guests.sh ${D}/${sysconfdir}/init.d 152 mv ${D}/${libexecdir}/libvirt-guests.sh ${D}/${sysconfdir}/init.d
153
154 # The /var/run/libvirt directories created by the Makefile
155 # are wiped out in volatile, we need to create these at boot.
156 rm -rf ${D}${localstatedir}/run
157 install -d ${D}${sysconfdir}/default/volatiles
158 echo "d root root 0755 ${localstatedir}/run/libvirt none" \
159 > ${D}${sysconfdir}/default/volatiles/99_libvirt
160 echo "d root root 0755 ${localstatedir}/run/libvirt/lockd none" \
161 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
162 echo "d root root 0755 ${localstatedir}/run/libvirt/lxc none" \
163 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
164 echo "d root root 0755 ${localstatedir}/run/libvirt/network none" \
165 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
166 echo "d root root 0755 ${localstatedir}/run/libvirt/qemu none" \
167 >> ${D}${sysconfdir}/default/volatiles/99_libvirt
168}
169
170pkg_postinst_libvirt() {
171 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then
172 /etc/init.d/populate-volatile.sh update
173 fi
153} 174}