summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt/libvirt
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/libvirt/libvirt')
-rw-r--r--recipes-extended/libvirt/libvirt/0001-messon.build-remove-build-path-information-to-avoid-.patch25
-rw-r--r--recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch21
-rw-r--r--recipes-extended/libvirt/libvirt/0001-qemu-segmentation-fault-in-virtqemud-executing-qemuD.patch52
3 files changed, 16 insertions, 82 deletions
diff --git a/recipes-extended/libvirt/libvirt/0001-messon.build-remove-build-path-information-to-avoid-.patch b/recipes-extended/libvirt/libvirt/0001-messon.build-remove-build-path-information-to-avoid-.patch
index 1e09cd68..d9bcef0b 100644
--- a/recipes-extended/libvirt/libvirt/0001-messon.build-remove-build-path-information-to-avoid-.patch
+++ b/recipes-extended/libvirt/libvirt/0001-messon.build-remove-build-path-information-to-avoid-.patch
@@ -25,34 +25,31 @@ Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com>
25 meson.build | 10 +++++----- 25 meson.build | 10 +++++-----
26 1 file changed, 5 insertions(+), 5 deletions(-) 26 1 file changed, 5 insertions(+), 5 deletions(-)
27 27
28diff --git a/meson.build b/meson.build 28Index: libvirt-9.2.0/meson.build
29index 9016c04..fb78d44 100644 29===================================================================
30--- a/meson.build 30--- libvirt-9.2.0.orig/meson.build
31+++ b/meson.build 31+++ libvirt-9.2.0/meson.build
32@@ -26,8 +26,8 @@ endif 32@@ -26,8 +26,8 @@
33 conf = configuration_data() 33 conf = configuration_data()
34 34
35 conf.set('_GNU_SOURCE', 1) 35 conf.set('_GNU_SOURCE', 1)
36-conf.set_quoted('abs_top_builddir', meson.build_root()) 36-conf.set_quoted('abs_top_builddir', meson.project_build_root())
37-conf.set_quoted('abs_top_srcdir', meson.source_root()) 37-conf.set_quoted('abs_top_srcdir', meson.project_source_root())
38+conf.set_quoted('abs_top_builddir', ' ') 38+conf.set_quoted('abs_top_builddir', ' ')
39+conf.set_quoted('abs_top_srcdir', ' ') 39+conf.set_quoted('abs_top_srcdir', ' ')
40 conf.set_quoted('PACKAGE', meson.project_name()) 40 conf.set_quoted('PACKAGE', meson.project_name())
41 conf.set_quoted('PACKAGE_NAME', meson.project_name()) 41 conf.set_quoted('PACKAGE_NAME', meson.project_name())
42 conf.set_quoted('PACKAGE_VERSION', meson.project_version()) 42 conf.set_quoted('PACKAGE_VERSION', meson.project_version())
43@@ -1830,9 +1830,9 @@ if conf.has('WITH_LIBVIRTD') 43@@ -1770,9 +1770,9 @@
44 use_storage = true 44 use_storage = true
45 45
46 conf.set('WITH_STORAGE_FS', 1) 46 conf.set('WITH_STORAGE_FS', 1)
47- conf.set_quoted('MOUNT', mount_prog.path()) 47- conf.set_quoted('MOUNT', mount_prog.full_path())
48- conf.set_quoted('UMOUNT', umount_prog.path()) 48- conf.set_quoted('UMOUNT', umount_prog.full_path())
49- conf.set_quoted('MKFS', mkfs_prog.path()) 49- conf.set_quoted('MKFS', mkfs_prog.full_path())
50+ conf.set_quoted('MOUNT', '/usr/bin/mount') 50+ conf.set_quoted('MOUNT', '/usr/bin/mount')
51+ conf.set_quoted('UMOUNT', '/usr/bin/umount') 51+ conf.set_quoted('UMOUNT', '/usr/bin/umount')
52+ conf.set_quoted('MKFS', '/usr/sbin/mkfs') 52+ conf.set_quoted('MKFS', '/usr/sbin/mkfs')
53 53
54 showmount_prog = find_program('showmount', required: false, dirs: libvirt_sbin_path) 54 showmount_prog = find_program('showmount', required: false, dirs: libvirt_sbin_path)
55 showmount_path = '' 55 showmount_path = ''
56--
572.17.1
58
diff --git a/recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch b/recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch
index 5a909b49..defbd7ee 100644
--- a/recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch
+++ b/recipes-extended/libvirt/libvirt/0001-prevent-gendispatch.pl-generating-build-path-in-code.patch
@@ -22,11 +22,11 @@ Signed-off-by: Xiangyu Chen <xiangyu.chen@windriver.com>
22 src/rpc/gendispatch.pl | 6 +++--- 22 src/rpc/gendispatch.pl | 6 +++---
23 1 file changed, 3 insertions(+), 3 deletions(-) 23 1 file changed, 3 insertions(+), 3 deletions(-)
24 24
25diff --git a/src/rpc/gendispatch.pl b/src/rpc/gendispatch.pl 25Index: libvirt-9.2.0/src/rpc/gendispatch.pl
26index 9f5bf0e..c73a9dd 100755 26===================================================================
27--- a/src/rpc/gendispatch.pl 27--- libvirt-9.2.0.orig/src/rpc/gendispatch.pl
28+++ b/src/rpc/gendispatch.pl 28+++ libvirt-9.2.0/src/rpc/gendispatch.pl
29@@ -449,19 +449,19 @@ sub hyper_to_long 29@@ -449,12 +449,12 @@
30 30
31 if ($mode eq "aclsym") { 31 if ($mode eq "aclsym") {
32 print <<__EOF__; 32 print <<__EOF__;
@@ -34,14 +34,6 @@ index 9f5bf0e..c73a9dd 100755
34+# Automatically generated by gendispatch.pl. 34+# Automatically generated by gendispatch.pl.
35 # Do not edit this file. Any changes you make will be lost. 35 # Do not edit this file. Any changes you make will be lost.
36 __EOF__ 36 __EOF__
37 } elsif ($mode eq "aclapi") {
38 print <<__EOF__;
39 <!--
40- - Automatically generated from $protocol by gendispatch.pl.
41+ - Automatically generated by gendispatch.pl.
42 - Do not edit this file. Any changes you make will be lost.
43 -->
44 __EOF__
45 } else { 37 } else {
46 print <<__EOF__; 38 print <<__EOF__;
47-/* Automatically generated from $protocol by gendispatch.pl. 39-/* Automatically generated from $protocol by gendispatch.pl.
@@ -49,6 +41,3 @@ index 9f5bf0e..c73a9dd 100755
49 * Do not edit this file. Any changes you make will be lost. 41 * Do not edit this file. Any changes you make will be lost.
50 */ 42 */
51 __EOF__ 43 __EOF__
52--
532.33.1
54
diff --git a/recipes-extended/libvirt/libvirt/0001-qemu-segmentation-fault-in-virtqemud-executing-qemuD.patch b/recipes-extended/libvirt/libvirt/0001-qemu-segmentation-fault-in-virtqemud-executing-qemuD.patch
deleted file mode 100644
index 85870e09..00000000
--- a/recipes-extended/libvirt/libvirt/0001-qemu-segmentation-fault-in-virtqemud-executing-qemuD.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From 823a62ec8aac4fb75e6e281164f3eb56ae47597c Mon Sep 17 00:00:00 2001
2From: Boris Fiuczynski <fiuczy@linux.ibm.com>
3Date: Tue, 1 Mar 2022 18:47:59 +0100
4Subject: [PATCH] qemu: segmentation fault in virtqemud executing
5 qemuDomainUndefineFlags
6
7Commit 5adfb3472342741c443ac91dee0abb18b5a3d038 causes a segmentation fault.
8
9Stack trace of thread 664419:
10 #0 0x000003ff62ec553c in qemuDomainUndefineFlags (dom=0x3ff6c002810, flags=<optimized out>) at ../src/qemu/qemu_driver.c:6618
11 #1 0x000003ff876a7e5c in virDomainUndefineFlags (domain=domain@entry=0x3ff6c002810, flags=<optimized out>) at ../src/libvirt-domain.c:6519
12 #2 0x000002aa2b64a808 in remoteDispatchDomainUndefineFlags (server=0x2aa2c3d7880, msg=0x2aa2c3d2770, args=<optimized out>, rerr=0x3ff8287b950, client=<optimized out>)
13 at src/remote/remote_daemon_dispatch_stubs.h:13080
14 #3 remoteDispatchDomainUndefineFlagsHelper (server=0x2aa2c3d7880, client=<optimized out>, msg=0x2aa2c3d2770, rerr=0x3ff8287b950, args=<optimized out>, ret=0x0)
15 at src/remote/remote_daemon_dispatch_stubs.h:13059
16 #4 0x000003ff8758bbf4 in virNetServerProgramDispatchCall (msg=0x2aa2c3d2770, client=0x2aa2c3e3050, server=0x2aa2c3d7880, prog=0x2aa2c3d8010)
17 at ../src/rpc/virnetserverprogram.c:428
18 #5 virNetServerProgramDispatch (prog=0x2aa2c3d8010, server=server@entry=0x2aa2c3d7880, client=0x2aa2c3e3050, msg=0x2aa2c3d2770) at ../src/rpc/virnetserverprogram.c:302
19 #6 0x000003ff8758c260 in virNetServerProcessMsg (msg=<optimized out>, prog=<optimized out>, client=<optimized out>, srv=0x2aa2c3d7880) at ../src/rpc/virnetserver.c:140
20 #7 virNetServerHandleJob (jobOpaque=0x2aa2c3e2d30, opaque=0x2aa2c3d7880) at ../src/rpc/virnetserver.c:160
21 #8 0x000003ff874c49aa in virThreadPoolWorker (opaque=<optimized out>) at ../src/util/virthreadpool.c:164
22 #9 0x000003ff874c3f62 in virThreadHelper (data=<optimized out>) at ../src/util/virthread.c:256
23 #10 0x000003ff86c1cf8c in start_thread () from /lib64/libc.so.6
24 #11 0x000003ff86c9650e in thread_start () from /lib64/libc.so.6
25
26Signed-off-by: Boris Fiuczynski <fiuczy@linux.ibm.com>
27Reviewed-by: Jim Fehlig <jfehlig@suse.com>
28Reviewed-by: Michal Privoznik <mprivozn@redhat.com>
29
30Upstream-Status: Backport [823a62ec8aac4fb75e6e281164f3eb56ae47597c]
31
32Signed-off-by: He Zhe <zhe.he@windriver.com>
33---
34 src/qemu/qemu_driver.c | 2 +-
35 1 file changed, 1 insertion(+), 1 deletion(-)
36
37diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c
38index bcd9bdb436..8337eed510 100644
39--- a/src/qemu/qemu_driver.c
40+++ b/src/qemu/qemu_driver.c
41@@ -6615,7 +6615,7 @@ qemuDomainUndefineFlags(virDomainPtr dom,
42 }
43 }
44
45- if (vm->def->os.loader->nvram) {
46+ if (vm->def->os.loader && vm->def->os.loader->nvram) {
47 nvram_path = g_strdup(vm->def->os.loader->nvram);
48 } else if (vm->def->os.firmware == VIR_DOMAIN_OS_DEF_FIRMWARE_EFI) {
49 qemuDomainNVRAMPathFormat(cfg, vm->def, &nvram_path);
50--
512.25.1
52