summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libibverbs/libibverbs_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/libibverbs/libibverbs_1.2.1.bb')
-rw-r--r--recipes-extended/libibverbs/libibverbs_1.2.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-extended/libibverbs/libibverbs_1.2.1.bb b/recipes-extended/libibverbs/libibverbs_1.2.1.bb
new file mode 100644
index 00000000..90c424ec
--- /dev/null
+++ b/recipes-extended/libibverbs/libibverbs_1.2.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Support InfiniBand verbs"
2DESCRIPTION = "Libibverbs is a library that allows userspace processes to use InfiniBand/RDMA 'verbs' directly."
3HOMEPAGE = "http://www.openfabrics.org/downloads/verbs/"
4SECTION = "libs/devel"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7c557f27dd795ba77cc419dddc656b51"
8
9# Official repo is at git://git.kernel.org/pub/scm/libs/infiniband/libibverbs.git
10SRC_URI = "https://www.openfabrics.org/downloads/verbs/${BPN}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "1544ebb89d861ce84057ab43dfcd22a0"
13SRC_URI[sha256sum] = "c352a7f24e9a9d30ea74faa35d1b721d78d770506a0c03732e3132b7c85ac330"
14
15inherit autotools
16
17DEPENDS = "libnl pkgconfig-native"
18PACKAGES += "${PN}-utils"
19FILES:${PN} = "${sysconfdir} ${libdir}/*.so.*"
20FILES:${PN}-utils = "${bindir}"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind,"
24
25do_install:append() {
26 mkdir -p ${D}${sysconfdir}/libibverbs.d
27 rm -f ${D}${libdir}/libibverbs.la
28}
29
30PROVIDES = "virtual/libibverbs"
31RPROVIDES:${PN} = "virtual-libibverbs"
32
33COMPATIBLE_HOST:mipsarch = "none"
34COMPATIBLE_HOST:arm = "none"