summaryrefslogtreecommitdiffstats
path: root/recipes-extended/images/container-base.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/images/container-base.bb')
-rw-r--r--recipes-extended/images/container-base.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-extended/images/container-base.bb b/recipes-extended/images/container-base.bb
new file mode 100644
index 00000000..3e636cad
--- /dev/null
+++ b/recipes-extended/images/container-base.bb
@@ -0,0 +1,28 @@
1#
2# Based on examples from Scott Murray (Building Container Images with
3# OpenEmbedded and the Yocto Project) ELCe 2018
4#
5SUMMARY = "Basic container image"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9IMAGE_FSTYPES = "container oci"
10inherit image
11inherit image-oci
12
13IMAGE_FEATURES = ""
14IMAGE_LINGUAS = ""
15NO_RECOMMENDATIONS = "1"
16
17IMAGE_INSTALL = " \
18 base-files \
19 base-passwd \
20 netbase \
21"
22
23# Workaround /var/volatile for now
24ROOTFS_POSTPROCESS_COMMAND += "rootfs_fixup_var_volatile ; "
25rootfs_fixup_var_volatile () {
26 install -m 1777 -d ${IMAGE_ROOTFS}/${localstatedir}/volatile/tmp
27 install -m 755 -d ${IMAGE_ROOTFS}/${localstatedir}/volatile/log
28}