diff options
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/go/go-capability_git.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/go/go-cli_git.bb | 30 | ||||
-rw-r--r-- | recipes-devtools/go/go-context_git.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/go/go-dbus_git.bb | 30 | ||||
-rw-r--r-- | recipes-devtools/go/go-fsnotify_git.bb | 30 | ||||
-rw-r--r-- | recipes-devtools/go/go-libtrust_git.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/go/go-logrus_git.bb | 30 | ||||
-rw-r--r-- | recipes-devtools/go/go-mux_git.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/go/go-net_hg.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/go/go-patricia_git.bb | 30 | ||||
-rw-r--r-- | recipes-devtools/go/go-pty_git.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/go/go-sqlite_hg.bb | 29 | ||||
-rw-r--r-- | recipes-devtools/go/go-systemd_git.bb | 30 |
13 files changed, 383 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-capability_git.bb b/recipes-devtools/go/go-capability_git.bb new file mode 100644 index 00000000..6f5b833a --- /dev/null +++ b/recipes-devtools/go/go-capability_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "Utilities for manipulating POSIX capabilities in Go." | ||
2 | HOMEPAGE = "https://github.com/syndtr/gocapability" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD-2-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a7304f5073e7be4ba7bffabbf9f2bbca" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "gocapability" | ||
9 | |||
10 | PKG_NAME = "github.com/syndtr/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "3c85049eaeb429febe7788d9c7aac42322a377fe" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
20 | } | ||
21 | |||
22 | SYSROOT_PREPROCESS_FUNCS += "go_mux_sysroot_preprocess" | ||
23 | |||
24 | go_mux_sysroot_preprocess () { | ||
25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-cli_git.bb b/recipes-devtools/go/go-cli_git.bb new file mode 100644 index 00000000..ef37357b --- /dev/null +++ b/recipes-devtools/go/go-cli_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "A small package for building command line apps in Go" | ||
2 | HOMEPAGE = "https://github.com/codegangsta/cli" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ed9b539ed65d73926f30ff1f1587dc44" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "cli" | ||
9 | |||
10 | PKG_NAME = "github.com/codegangsta/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "27ecc97192df1bf053a22b04463f2b51b8b8373e" | ||
14 | PV = "1.1.0+git${SRCREV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
20 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
21 | } | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "go_cli_sysroot_preprocess" | ||
24 | |||
25 | go_cli_sysroot_preprocess () { | ||
26 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
27 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-context_git.bb b/recipes-devtools/go/go-context_git.bb new file mode 100644 index 00000000..a4b832e1 --- /dev/null +++ b/recipes-devtools/go/go-context_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "A golang registry for global request variables." | ||
2 | HOMEPAGE = "https://github.com/gorilla/context" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c50f6bd9c1e15ed0bad3bea18e3c1b7f" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "context" | ||
9 | |||
10 | PKG_NAME = "github.com/gorilla/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "14f550f51af52180c2eefed15e5fd18d63c0a64a" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
20 | } | ||
21 | |||
22 | SYSROOT_PREPROCESS_FUNCS += "go_context_sysroot_preprocess" | ||
23 | |||
24 | go_context_sysroot_preprocess () { | ||
25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-dbus_git.bb b/recipes-devtools/go/go-dbus_git.bb new file mode 100644 index 00000000..8edbd1ea --- /dev/null +++ b/recipes-devtools/go/go-dbus_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "Native Go bindings for D-Bus" | ||
2 | HOMEPAGE = "https://github.com/godbus/dbus" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD-2-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b5ac622301483800715d770434e27e5b" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "dbus" | ||
9 | |||
10 | PKG_NAME = "github.com/godbus/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "cb98efbb933d8389ab549a060e880ea3c375d213" | ||
14 | PV = "1+git${SRCREV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
20 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
21 | } | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "go_dbus_sysroot_preprocess" | ||
24 | |||
25 | go_dbus_sysroot_preprocess () { | ||
26 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
27 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-fsnotify_git.bb b/recipes-devtools/go/go-fsnotify_git.bb new file mode 100644 index 00000000..cb4a9741 --- /dev/null +++ b/recipes-devtools/go/go-fsnotify_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "A golang registry for global request variables." | ||
2 | HOMEPAGE = "https://github.com/go-fsnotify/fsnotify" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c38914c9a7ab03bb2b96d4baaee10769" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "fsnotify" | ||
9 | |||
10 | PKG_NAME = "github.com/go-fsnotify/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "ca50e738d35a862c379baf8fffbc3bfd080b3cff" | ||
14 | PV = "1.0.4+git${SRCREV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
20 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
21 | } | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "go_fsnotify_sysroot_preprocess" | ||
24 | |||
25 | go_fsnotify_sysroot_preprocess () { | ||
26 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
27 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-libtrust_git.bb b/recipes-devtools/go/go-libtrust_git.bb new file mode 100644 index 00000000..d84cc348 --- /dev/null +++ b/recipes-devtools/go/go-libtrust_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "Primitives for identity and authorization" | ||
2 | HOMEPAGE = "https://github.com/docker/libtrust" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "libtrust" | ||
9 | |||
10 | PKG_NAME = "github.com/docker/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "230dfd18c2326f1e9d08238710e67a1040187d07" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
20 | } | ||
21 | |||
22 | SYSROOT_PREPROCESS_FUNCS += "go_libtrust_sysroot_preprocess" | ||
23 | |||
24 | go_libtrust_sysroot_preprocess () { | ||
25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-logrus_git.bb b/recipes-devtools/go/go-logrus_git.bb new file mode 100644 index 00000000..d1ae6e10 --- /dev/null +++ b/recipes-devtools/go/go-logrus_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "A golang registry for global request variables." | ||
2 | HOMEPAGE = "https://github.com/Sirupsen/logrus" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8dadfef729c08ec4e631c4f6fc5d43a0" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "logrus" | ||
9 | |||
10 | PKG_NAME = "github.com/Sirupsen/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "6ebb4e7b3c24b9fef150d7693e728cb1ebadf1f5" | ||
14 | PV = "0.6.0+git${SRCREV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
20 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
21 | } | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "go_logrus_sysroot_preprocess" | ||
24 | |||
25 | go_logrus_sysroot_preprocess () { | ||
26 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
27 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-mux_git.bb b/recipes-devtools/go/go-mux_git.bb new file mode 100644 index 00000000..ddd9559b --- /dev/null +++ b/recipes-devtools/go/go-mux_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "A powerful URL router and dispatcher for golang." | ||
2 | HOMEPAGE = "https://github.com/gorilla/mux" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c50f6bd9c1e15ed0bad3bea18e3c1b7f" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "mux" | ||
9 | |||
10 | PKG_NAME = "github.com/gorilla/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "136d54f81f00414c45c3c68dd47e98cc97519c5e" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
20 | } | ||
21 | |||
22 | SYSROOT_PREPROCESS_FUNCS += "go_mux_sysroot_preprocess" | ||
23 | |||
24 | go_mux_sysroot_preprocess () { | ||
25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-net_hg.bb b/recipes-devtools/go/go-net_hg.bb new file mode 100644 index 00000000..f4c85994 --- /dev/null +++ b/recipes-devtools/go/go-net_hg.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "A golang registry for global request variables." | ||
2 | HOMEPAGE = "https://code.google.com/p/go.net" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "go.net" | ||
9 | |||
10 | PKG_NAME = "code.google.com/p/${SRCNAME}" | ||
11 | SRC_URI = "hg://code.google.com/p;module=go.net" | ||
12 | |||
13 | SRCREV = "84a4013f96e01fdd14b65d260a78b543e3702ee1" | ||
14 | |||
15 | S = "${WORKDIR}/${SRCNAME}" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
20 | } | ||
21 | |||
22 | SYSROOT_PREPROCESS_FUNCS += "go_net_sysroot_preprocess" | ||
23 | |||
24 | go_net_sysroot_preprocess () { | ||
25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-patricia_git.bb b/recipes-devtools/go/go-patricia_git.bb new file mode 100644 index 00000000..687677f7 --- /dev/null +++ b/recipes-devtools/go/go-patricia_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "A generic patricia trie (also called radix tree) implemented in Go (Golang)" | ||
2 | HOMEPAGE = "https://github.com/gorilla/context" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9949b99212edd6b1e24ce702376c3baf" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "go-patricia" | ||
9 | |||
10 | PKG_NAME = "github.com/tchap/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "f64d0a63cd3363481c898faa9339de04d12213f9" | ||
14 | PV = "1.0.1+git${SRCPV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
20 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
21 | } | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "go_patricia_sysroot_preprocess" | ||
24 | |||
25 | go_patricia_sysroot_preprocess () { | ||
26 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
27 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-pty_git.bb b/recipes-devtools/go/go-pty_git.bb new file mode 100644 index 00000000..82385408 --- /dev/null +++ b/recipes-devtools/go/go-pty_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "PTY interface for Go" | ||
2 | HOMEPAGE = "https://github.com/kr/pty" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://License;md5=93958070863d769117fa33b129020050" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "pty" | ||
9 | |||
10 | PKG_NAME = "github.com/kr/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "05017fcccf23c823bfdea560dcc958a136e54fb7" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
20 | } | ||
21 | |||
22 | SYSROOT_PREPROCESS_FUNCS += "go_pty_sysroot_preprocess" | ||
23 | |||
24 | go_pty_sysroot_preprocess () { | ||
25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-sqlite_hg.bb b/recipes-devtools/go/go-sqlite_hg.bb new file mode 100644 index 00000000..8953b85a --- /dev/null +++ b/recipes-devtools/go/go-sqlite_hg.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "Trivial sqlite3 binding for Go" | ||
2 | HOMEPAGE = "https://code.google.com/p/gosqlite" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "gosqlite" | ||
9 | |||
10 | PKG_NAME = "code.google.com/p/${SRCNAME}" | ||
11 | SRC_URI = "hg://code.google.com/p;module=gosqlite" | ||
12 | |||
13 | SRCREV = "74691fb6f83716190870cde1b658538dd4b18eb0" | ||
14 | |||
15 | S = "${WORKDIR}/${SRCNAME}" | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
20 | } | ||
21 | |||
22 | SYSROOT_PREPROCESS_FUNCS += "go_gosqlite_sysroot_preprocess" | ||
23 | |||
24 | go_gosqlite_sysroot_preprocess () { | ||
25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
27 | } | ||
28 | |||
29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||
diff --git a/recipes-devtools/go/go-systemd_git.bb b/recipes-devtools/go/go-systemd_git.bb new file mode 100644 index 00000000..0a5ec249 --- /dev/null +++ b/recipes-devtools/go/go-systemd_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "Go bindings to systemd socket activation, journal, D-Bus, and unit files" | ||
2 | HOMEPAGE = "https://github.com/coreos/go-systemd" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=19cbd64715b51267a47bf3750cc6a8a5" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "systemd" | ||
9 | |||
10 | PKG_NAME = "github.com/coreos/go-${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "f743bc15d6bddd23662280b4ad20f7c874cdd5ad" | ||
14 | PV = "2+git${SRCREV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
20 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
21 | } | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "go_systemd_sysroot_preprocess" | ||
24 | |||
25 | go_systemd_sysroot_preprocess () { | ||
26 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
27 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||