diff options
Diffstat (limited to 'recipes-containers')
3 files changed, 70 insertions, 22 deletions
diff --git a/recipes-containers/criu/files/0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch b/recipes-containers/criu/files/0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch new file mode 100644 index 00000000..b6fbf017 --- /dev/null +++ b/recipes-containers/criu/files/0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From 81bc5928cdc1b432656eb6590967306d8cf3ac9d Mon Sep 17 00:00:00 2001 | ||
2 | From: Jianchuan Wang <jianchuan.wang@windriver.com> | ||
3 | Date: Tue, 4 Aug 2015 10:22:21 +0800 | ||
4 | Subject: [PATCH] protobuf-c: Remove the rules which depend on the native | ||
5 | command | ||
6 | |||
7 | Those rules are not for cross-compile since the command protoc-c/cxx-generate-packed-data | ||
8 | need be executed to generate some local files in the compiling processing. | ||
9 | |||
10 | Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> | ||
11 | --- | ||
12 | Makefile.am | 13 +++++++------ | ||
13 | 1 file changed, 7 insertions(+), 6 deletions(-) | ||
14 | |||
15 | diff --git a/Makefile.am b/Makefile.am | ||
16 | index 310aa09..0602e96 100644 | ||
17 | --- a/Makefile.am | ||
18 | +++ b/Makefile.am | ||
19 | @@ -148,17 +148,18 @@ t_generated_code2_cxx_generate_packed_data_CXXFLAGS = \ | ||
20 | t_generated_code2_cxx_generate_packed_data_LDADD = \ | ||
21 | $(protobuf_LIBS) | ||
22 | |||
23 | -t/test.pb-c.c t/test.pb-c.h: $(top_builddir)/protoc-c/protoc-c$(EXEEXT) $(top_srcdir)/t/test.proto | ||
24 | - $(AM_V_GEN)$(top_builddir)/protoc-c/protoc-c$(EXEEXT) -I$(top_srcdir) --c_out=$(top_builddir) $(top_srcdir)/t/test.proto | ||
25 | +t/test.pb-c.c t/test.pb-c.h: $(top_srcdir)/t/test.proto | ||
26 | + $(AM_V_GEN)protoc-c -I$(top_srcdir) --c_out=$(top_builddir) $(top_srcdir)/t/test.proto | ||
27 | |||
28 | -t/test-full.pb-c.c t/test-full.pb-c.h: $(top_builddir)/protoc-c/protoc-c$(EXEEXT) $(top_srcdir)/t/test-full.proto | ||
29 | - $(AM_V_GEN)$(top_builddir)/protoc-c/protoc-c$(EXEEXT) -I$(top_srcdir) --c_out=$(top_builddir) $(top_srcdir)/t/test-full.proto | ||
30 | +t/test-full.pb-c.c t/test-full.pb-c.h: $(top_srcdir)/t/test-full.proto | ||
31 | + $(AM_V_GEN)protoc-c -I$(top_srcdir) --c_out=$(top_builddir) $(top_srcdir)/t/test-full.proto | ||
32 | |||
33 | t/test-full.pb.cc t/test-full.pb.h: @PROTOC@ $(top_srcdir)/t/test-full.proto | ||
34 | $(AM_V_GEN)@PROTOC@ -I$(top_srcdir) --cpp_out=$(top_builddir) $(top_srcdir)/t/test-full.proto | ||
35 | |||
36 | -t/generated-code2/test-full-cxx-output.inc: t/generated-code2/cxx-generate-packed-data$(EXEEXT) | ||
37 | - $(AM_V_GEN)$(top_builddir)/t/generated-code2/cxx-generate-packed-data$(EXEEXT) > $(top_builddir)/t/generated-code2/test-full-cxx-output.inc | ||
38 | +t/generated-code2/test-full-cxx-output.inc: | ||
39 | + mkdir -p $(top_builddir)/t/generated-code2 | ||
40 | + $(AM_V_GEN)cxx-generate-packed-data > $(top_builddir)/t/generated-code2/test-full-cxx-output.inc | ||
41 | |||
42 | BUILT_SOURCES += \ | ||
43 | t/test.pb-c.c t/test.pb-c.h \ | ||
44 | -- | ||
45 | 1.9.1 | ||
46 | |||
diff --git a/recipes-containers/criu/protobuf-c_0.15.bb b/recipes-containers/criu/protobuf-c_0.15.bb deleted file mode 100644 index 5d65c69a..00000000 --- a/recipes-containers/criu/protobuf-c_0.15.bb +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | SUMMARY = "protobuf-c" | ||
2 | DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C" | ||
3 | HOMEPAGE = "http://code.google.com/p/protobuf-c/" | ||
4 | SECTION = "console/tools" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://src/google/protobuf-c/protobuf-c.c;endline=33;md5=333140fae7cf8a38dc5f980ddb63704b" | ||
8 | |||
9 | PR = "r0" | ||
10 | |||
11 | COMPATIBLE_HOST = "(x86_64|arm).*-linux" | ||
12 | |||
13 | DEPENDS = "protobuf" | ||
14 | |||
15 | SRC_URI[md5sum] = "73ff0c8df50d2eee75269ad8f8c07dc8" | ||
16 | SRC_URI[sha256sum] = "8fcb538e13a5431c46168fc8f2e6ad2574e2db9b684c0c72b066e24f010a0036" | ||
17 | SRC_URI = "http://protobuf-c.googlecode.com/files/protobuf-c-${PV}.tar.gz \ | ||
18 | file://disable_tests.patch" | ||
19 | |||
20 | inherit autotools | ||
21 | |||
22 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/recipes-containers/criu/protobuf-c_1.1.1.bb b/recipes-containers/criu/protobuf-c_1.1.1.bb new file mode 100644 index 00000000..8c2d2b73 --- /dev/null +++ b/recipes-containers/criu/protobuf-c_1.1.1.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "protobuf-c" | ||
2 | DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C" | ||
3 | HOMEPAGE = "http://code.google.com/p/protobuf-c/" | ||
4 | SECTION = "console/tools" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://protobuf-c/protobuf-c.c;endline=28;md5=0feb44cc63eacef97219b0174967492f" | ||
8 | |||
9 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" | ||
10 | |||
11 | DEPENDS = "protobuf protobuf-c-native" | ||
12 | |||
13 | SRC_URI[md5sum] = "41d437677ea16f9d3611d98841c4af3b" | ||
14 | SRC_URI[sha256sum] = "09c5bb187b7a8e86bc0ff860f7df86370be9e8661cdb99c1072dcdab0763562c" | ||
15 | SRC_URI = "https://github.com/protobuf-c/protobuf-c/releases/download/v1.1.1/protobuf-c-1.1.1.tar.gz " | ||
16 | SRC_URI_append_class-target ="file://0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch" | ||
17 | |||
18 | inherit autotools | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
21 | |||
22 | do_install_append_class-native() { | ||
23 | install -m 755 ${B}/t/generated-code2/cxx-generate-packed-data ${D}/${bindir} | ||
24 | } | ||