summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_git.bb6
-rw-r--r--recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch17
2 files changed, 10 insertions, 13 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb
index 7755f7db..2c691b59 100644
--- a/recipes-containers/containerd/containerd-opencontainers_git.bb
+++ b/recipes-containers/containerd/containerd-opencontainers_git.bb
@@ -1,5 +1,5 @@
1SRCREV = "0190e5f3900227fc739afbc8f4a03df968dc337b" 1SRCREV = "e6b3f5632f50dbc4e9cb6288d911bf4f5e95b18e"
2SRC_URI = "git://github.com/containerd/containerd;nobranch=1 \ 2SRC_URI = "git://github.com/containerd/containerd;branch=release/1.2 \
3 file://0001-build-use-oe-provided-GO-and-flags.patch \ 3 file://0001-build-use-oe-provided-GO-and-flags.patch \
4 " 4 "
5 5
@@ -7,7 +7,7 @@ include containerd.inc
7 7
8LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=1269f40c0d099c21a871163984590d89" 8LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=1269f40c0d099c21a871163984590d89"
9 9
10CONTAINERD_VERSION = "v1.2.0" 10CONTAINERD_VERSION = "v1.2.4"
11 11
12PROVIDES += "virtual/containerd" 12PROVIDES += "virtual/containerd"
13RPROVIDES_${PN} = "virtual/containerd" 13RPROVIDES_${PN} = "virtual/containerd"
diff --git a/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch b/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch
index c2433f14..d4d5973e 100644
--- a/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch
+++ b/recipes-containers/containerd/files/0001-build-use-oe-provided-GO-and-flags.patch
@@ -12,16 +12,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
12 Makefile | 8 ++++---- 12 Makefile | 8 ++++----
13 1 file changed, 4 insertions(+), 4 deletions(-) 13 1 file changed, 4 insertions(+), 4 deletions(-)
14 14
15diff --git a/src/import/Makefile b/src/import/Makefile 15Index: git/src/import/Makefile
16index 8e680133..fd7d2813 100644 16===================================================================
17--- a/src/import/Makefile 17--- git.orig/src/import/Makefile
18+++ b/src/import/Makefile 18+++ git/src/import/Makefile
19@@ -179,19 +179,19 @@ FORCE: 19@@ -166,19 +166,19 @@
20 # Build a binary from a cmd. 20 # Build a binary from a cmd.
21 bin/%: cmd/% FORCE 21 bin/%: cmd/% FORCE
22 @echo "$(WHALE) $@${BINARY_SUFFIX}" 22 @echo "$(WHALE) $@${BINARY_SUFFIX}"
23- @go build ${DEBUG_GO_GCFLAGS} ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< 23- @go build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$<
24+ @$(GO) build ${GO_BUILD_FLAGS} ${DEBUG_GO_GCFLAGS} ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< 24+ @$(GO) build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$<
25 25
26 bin/containerd-shim: cmd/containerd-shim FORCE # set !cgo and omit pie for a static shim build: https://github.com/golang/go/issues/17789#issuecomment-258542220 26 bin/containerd-shim: cmd/containerd-shim FORCE # set !cgo and omit pie for a static shim build: https://github.com/golang/go/issues/17789#issuecomment-258542220
27 @echo "$(WHALE) bin/containerd-shim" 27 @echo "$(WHALE) bin/containerd-shim"
@@ -40,6 +40,3 @@ index 8e680133..fd7d2813 100644
40 40
41 binaries: $(BINARIES) ## build binaries 41 binaries: $(BINARIES) ## build binaries
42 @echo "$(WHALE) $@" 42 @echo "$(WHALE) $@"
43--
442.19.1
45