summaryrefslogtreecommitdiffstats
path: root/recipes-containers/skopeo/skopeo_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/skopeo/skopeo_git.bb')
-rw-r--r--recipes-containers/skopeo/skopeo_git.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb
index 2c292463..6c95bf3e 100644
--- a/recipes-containers/skopeo/skopeo_git.bb
+++ b/recipes-containers/skopeo/skopeo_git.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=7e611105d3e369954840a6668c4385
5 5
6DEPENDS = " \ 6DEPENDS = " \
7 gpgme \ 7 gpgme \
8 multipath-tools \ 8 libdevmapper \
9 lvm2 \
9 btrfs-tools \ 10 btrfs-tools \
10 glib-2.0 \ 11 glib-2.0 \
11 ostree \ 12 ostree \
@@ -80,4 +81,16 @@ do_install() {
80 install ${WORKDIR}/registries.conf ${D}/${sysconfdir}/containers/registries.conf 81 install ${WORKDIR}/registries.conf ${D}/${sysconfdir}/containers/registries.conf
81} 82}
82 83
84do_install_append_class-native() {
85 create_cmdline_wrapper ${D}/${sbindir}/skopeo \
86 --policy ${sysconfdir}/containers/policy.json
87}
88
89do_install_append_class-nativesdk() {
90 create_cmdline_wrapper ${D}/${sbindir}/skopeo \
91 --policy ${sysconfdir}/containers/policy.json
92}
93
83INSANE_SKIP_${PN} += "ldflags" 94INSANE_SKIP_${PN} += "ldflags"
95
96BBCLASSEXTEND = "native nativesdk"