summaryrefslogtreecommitdiffstats
path: root/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch')
-rw-r--r--recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
index bb4af36b..9e5a8313 100644
--- a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
+++ b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
@@ -17,12 +17,12 @@ Index: git/src/import/Makefile
17=================================================================== 17===================================================================
18--- git.orig/src/import/Makefile 18--- git.orig/src/import/Makefile
19+++ git/src/import/Makefile 19+++ git/src/import/Makefile
20@@ -20,7 +20,7 @@ 20@@ -24,7 +24,7 @@
21 endif 21 GO_BUILDMODE := "-buildmode=pie"
22 endif 22 endif
23 endif 23 endif
24-GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ 24-GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) \
25+GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ 25+GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) \
26 -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" 26 $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
27 GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ 27 -ldflags "$(LDFLAGS_COMMON) $(EXTRA_LDFLAGS)"
28 -ldflags "-extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" 28