summaryrefslogtreecommitdiffstats
path: root/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch')
-rw-r--r--recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch25
1 files changed, 15 insertions, 10 deletions
diff --git a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
index 0090a589..c855d7b5 100644
--- a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
+++ b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
@@ -1,19 +1,21 @@
1From d2c47a973f354ffd505bb4e809c59e57b543726d Mon Sep 17 00:00:00 2001 1From 0fe50d2ca4517f5e3070585040f35ace413acd44 Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com> 2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 6 Aug 2019 19:01:45 +0800 3Date: Tue, 24 Aug 2021 11:38:23 -0400
4Subject: [PATCH] Makefile: respect GOBUILDFLAGS for runc and remove recvtty 4Subject: [PATCH] Makefile: respect GOBUILDFLAGS for runc and remove recvtty
5 from static 5 from static
6 6
7Signed-off-by: Chen Qi <Qi.Chen@windriver.com> 7Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
8[bva: refreshed for release 1.0.2]
9Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
8--- 10---
9 Makefile | 3 +-- 11 Makefile | 3 +--
10 1 file changed, 1 insertion(+), 2 deletions(-) 12 1 file changed, 1 insertion(+), 2 deletions(-)
11 13
12Index: git/src/import/Makefile 14diff --git a/src/import/Makefile b/src/import/Makefile
13=================================================================== 15index efbddf0d..4b174c80 100644
14--- git.orig/src/import/Makefile 16--- a/src/import/Makefile
15+++ git/src/import/Makefile 17+++ b/src/import/Makefile
16@@ -25,7 +25,7 @@ 18@@ -24,7 +24,7 @@ ifeq ($(shell $(GO) env GOOS),linux)
17 endif 19 endif
18 endif 20 endif
19 endif 21 endif
@@ -21,8 +23,8 @@ Index: git/src/import/Makefile
21+GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ 23+GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
22 -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" 24 -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
23 GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ 25 GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
24 -ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" 26 -ldflags "-extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
25@@ -42,7 +42,6 @@ 27@@ -41,7 +41,6 @@ recvtty:
26 28
27 static: 29 static:
28 $(GO_BUILD_STATIC) -o runc . 30 $(GO_BUILD_STATIC) -o runc .
@@ -30,3 +32,6 @@ Index: git/src/import/Makefile
30 32
31 release: 33 release:
32 script/release.sh -r release/$(VERSION) -v $(VERSION) 34 script/release.sh -r release/$(VERSION) -v $(VERSION)
35--
362.19.1
37