summaryrefslogtreecommitdiffstats
path: root/recipes-containers/riddler/riddler_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/riddler/riddler_git.bb')
-rw-r--r--recipes-containers/riddler/riddler_git.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-containers/riddler/riddler_git.bb b/recipes-containers/riddler/riddler_git.bb
index ae6c5ec9..9f7fe6b4 100644
--- a/recipes-containers/riddler/riddler_git.bb
+++ b/recipes-containers/riddler/riddler_git.bb
@@ -1,11 +1,12 @@
1HOMEPAGE = "https://github.com/jfrazelle/riddler" 1HOMEPAGE = "https://github.com/jfrazelle/riddler"
2SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec." 2SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" 4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1"
5 5
6SRC_URI = "git://github.com/jfrazelle/riddler;branch=master" 6SRC_URI = "git://github.com/jfrazelle/riddler;branch=master"
7SRCREV = "23befa0b232877b5b502b828e24161d801bd67f6" 7SRCREV = "23befa0b232877b5b502b828e24161d801bd67f6"
8PV = "0.1.0+git${SRCPV}" 8PV = "0.1.0+git${SRCPV}"
9GO_IMPORT = "import"
9 10
10S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
11 12
@@ -26,10 +27,10 @@ do_compile() {
26 # 27 #
27 # We also need to link in the ipallocator directory as that is not under 28 # We also need to link in the ipallocator directory as that is not under
28 # a src directory. 29 # a src directory.
29 ln -sfn . "${S}/vendor/src" 30 ln -sfn . "${S}/src/import/vendor/src"
30 mkdir -p "${S}/vendor/src/github.com/jessfraz/riddler" 31 mkdir -p "${S}/src/import/vendor/src/github.com/jessfraz/riddler"
31 ln -sfn "${S}/parse" "${S}/vendor/src/github.com/jessfraz/riddler/parse" 32 ln -sfn "${S}/src/import/parse" "${S}/src/import/vendor/src/github.com/jessfraz/riddler/parse"
32 export GOPATH="${S}/vendor" 33 export GOPATH="${S}/src/import/vendor"
33 34
34 # Pass the needed cflags/ldflags so that cgo 35 # Pass the needed cflags/ldflags so that cgo
35 # can find the needed headers files and libraries 36 # can find the needed headers files and libraries
@@ -38,11 +39,12 @@ do_compile() {
38 export LDFLAGS="" 39 export LDFLAGS=""
39 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 40 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
40 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 41 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
42 cd ${S}/src/import
41 43
42 oe_runmake static 44 oe_runmake static
43} 45}
44 46
45do_install() { 47do_install() {
46 install -d ${D}/${sbindir} 48 install -d ${D}/${sbindir}
47 install ${S}/riddler ${D}/${sbindir}/riddler 49 install ${S}/src/import/riddler ${D}/${sbindir}/riddler
48} 50}