summaryrefslogtreecommitdiffstats
path: root/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb')
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index d73edfe7..0d9c6e65 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -1,14 +1,13 @@
1HOMEPAGE = "https://github.com/opencontainers/runtime-tools" 1HOMEPAGE = "https://github.com/opencontainers/runtime-tools"
2SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification" 2SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c" 4LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=b355a61a394a504dacde901c958f662c"
5 5
6SRC_URI = "git://github.com/opencontainers/runtime-tools.git" 6SRC_URI = "git://github.com/opencontainers/runtime-tools.git"
7 7
8SRCREV = "15ec1df3f6607f4223ab3915547c184cf60a30dd" 8SRCREV = "15ec1df3f6607f4223ab3915547c184cf60a30dd"
9PV = "0.0.1+git${SRCPV}" 9PV = "0.0.1+git${SRCPV}"
10 10GO_IMPORT = "import"
11S = "${WORKDIR}/git"
12 11
13INSANE_SKIP_${PN} += "ldflags" 12INSANE_SKIP_${PN} += "ldflags"
14 13
@@ -18,7 +17,7 @@ inherit go
18do_compile() { 17do_compile() {
19 export GOARCH="${TARGET_GOARCH}" 18 export GOARCH="${TARGET_GOARCH}"
20 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go" 19 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
21 export GOPATH="${S}:${S}/vendor" 20 export GOPATH="${S}/src/import:${S}/src/import/vendor"
22 21
23 # Pass the needed cflags/ldflags so that cgo 22 # Pass the needed cflags/ldflags so that cgo
24 # can find the needed headers files and libraries 23 # can find the needed headers files and libraries
@@ -29,17 +28,18 @@ do_compile() {
29 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 28 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
30 29
31 # link fixups for compilation 30 # link fixups for compilation
32 rm -f ${S}/vendor/src 31 rm -f ${S}/src/import/vendor/src
33 ln -sf ./ ${S}/vendor/src 32 ln -sf ./ ${S}/src/import/vendor/src
34 mkdir -p ${S}/vendor/github.com/opencontainers/runtime-tools 33 mkdir -p ${S}/src/import/vendor/github.com/opencontainers/runtime-tools
35 ln -sf ../../../../generate ${S}/vendor/github.com/opencontainers/runtime-tools/generate 34 ln -sf ../../../../generate ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/generate
36 ln -sf ../../../../validate ${S}/vendor/github.com/opencontainers/runtime-tools/validate 35 ln -sf ../../../../validate ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/validate
37 ln -sf ../../../../cmd ${S}/vendor/github.com/opencontainers/runtime-tools/cmd 36 ln -sf ../../../../cmd ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/cmd
37 cd ${S}/src/import
38 38
39 oe_runmake 39 oe_runmake
40} 40}
41 41
42do_install() { 42do_install() {
43 install -d ${D}/${sbindir} 43 install -d ${D}/${sbindir}
44 install ${S}/oci-runtime-tool ${D}/${sbindir}/oci-runtime-tool 44 install ${S}/src/import/oci-runtime-tool ${D}/${sbindir}/oci-runtime-tool
45} 45}