summaryrefslogtreecommitdiffstats
path: root/recipes-containers/oci-image-tools/oci-image-tools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/oci-image-tools/oci-image-tools_git.bb')
-rw-r--r--recipes-containers/oci-image-tools/oci-image-tools_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
index 8d48eba3..30179608 100644
--- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb
+++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
@@ -18,8 +18,7 @@ SRC_URI = "git://github.com/opencontainers/image-tools.git \
18 18
19SRCREV = "4abe1a166f9be97e8e71b1bb4d7599cc29323011" 19SRCREV = "4abe1a166f9be97e8e71b1bb4d7599cc29323011"
20PV = "0.2.0-dev+git${SRCPV}" 20PV = "0.2.0-dev+git${SRCPV}"
21 21GO_IMPORT = "import"
22S = "${WORKDIR}/git"
23 22
24inherit goarch 23inherit goarch
25inherit go 24inherit go
@@ -38,11 +37,11 @@ do_compile() {
38 # 37 #
39 # We also need to link in the ipallocator directory as that is not under 38 # We also need to link in the ipallocator directory as that is not under
40 # a src directory. 39 # a src directory.
41 ln -sfn . "${S}/vendor/src" 40 ln -sfn . "${S}/src/import/vendor/src"
42 mkdir -p "${S}/vendor/src/github.com/opencontainers/image-tools/" 41 mkdir -p "${S}/src/import/vendor/src/github.com/opencontainers/image-tools/"
43 ln -sfn "${S}/image" "${S}/vendor/src/github.com/opencontainers/image-tools/image" 42 ln -sfn "${S}/src/import/image" "${S}/src/import/vendor/src/github.com/opencontainers/image-tools/image"
44 ln -sfn "${S}/version" "${S}/vendor/src/github.com/opencontainers/image-tools/version" 43 ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/opencontainers/image-tools/version"
45 export GOPATH="${S}/vendor" 44 export GOPATH="${S}/src/import/vendor"
46 45
47 # Pass the needed cflags/ldflags so that cgo 46 # Pass the needed cflags/ldflags so that cgo
48 # can find the needed headers files and libraries 47 # can find the needed headers files and libraries
@@ -51,13 +50,14 @@ do_compile() {
51 export LDFLAGS="" 50 export LDFLAGS=""
52 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 51 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
53 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 52 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
53 cd ${S}/src/import
54 54
55 oe_runmake tool 55 oe_runmake tool
56} 56}
57 57
58do_install() { 58do_install() {
59 install -d ${D}/${sbindir} 59 install -d ${D}/${sbindir}
60 install ${S}/oci-image-tool ${D}/${sbindir}/ 60 install ${S}/src/import/oci-image-tool ${D}/${sbindir}/
61} 61}
62 62
63INSANE_SKIP_${PN} += "ldflags" 63INSANE_SKIP_${PN} += "ldflags"