summaryrefslogtreecommitdiffstats
path: root/recipes-containers/nerdctl/nerdctl_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/nerdctl/nerdctl_git.bb')
-rw-r--r--recipes-containers/nerdctl/nerdctl_git.bb13
1 files changed, 2 insertions, 11 deletions
diff --git a/recipes-containers/nerdctl/nerdctl_git.bb b/recipes-containers/nerdctl/nerdctl_git.bb
index 8fe5e7d4..ca4d3c62 100644
--- a/recipes-containers/nerdctl/nerdctl_git.bb
+++ b/recipes-containers/nerdctl/nerdctl_git.bb
@@ -11,7 +11,7 @@ DEPENDS = " \
11 11
12# Specify the first two important SRCREVs as the format 12# Specify the first two important SRCREVs as the format
13SRCREV_FORMAT="nerdcli_cgroups" 13SRCREV_FORMAT="nerdcli_cgroups"
14SRCREV_nerdcli = "e084a2df4a8861eb5f0b0d32df0643ef24b81093" 14SRCREV_nerdcli = "1525035ce9aec89a796f6f15c7537db2448f88b9"
15 15
16SRC_URI = "git://github.com/containerd/nerdctl.git;name=nerdcli;branch=main;protocol=https" 16SRC_URI = "git://github.com/containerd/nerdctl.git;name=nerdcli;branch=main;protocol=https"
17 17
@@ -31,7 +31,7 @@ GO_IMPORT = "import"
31 31
32# S = "${WORKDIR}/git" 32# S = "${WORKDIR}/git"
33 33
34PV = "v0.22.2" 34PV = "v1.3.0"
35 35
36NERDCTL_PKG = "github.com/containerd/nerdctl" 36NERDCTL_PKG = "github.com/containerd/nerdctl"
37 37
@@ -66,15 +66,6 @@ do_compile() {
66 66
67 export GOFLAGS="-mod=vendor -trimpath" 67 export GOFLAGS="-mod=vendor -trimpath"
68 68
69 # this moves all the fetches into the proper vendor structure
70 # expected for build
71 for s in ${sites}; do
72 site_dest=$(echo $s | cut -d: -f1)
73 site_source=$(echo $s | cut -d: -f2)
74 mkdir -p vendor.copy/$site_dest
75 [ -n "$(ls -A vendor.copy/$site_dest/*.go 2> /dev/null)" ] && { echo "[INFO] vendor.fetch/$site_source -> $site_dest: go copy skipped (files present)" ; true ; } || { echo "[INFO] $site_dest: copying .go files" ; rsync -a --exclude='vendor/' --exclude='.git/' vendor.fetch/$site_source/ vendor.copy/$site_dest ; }
76 done
77
78 # our copied .go files are to be used for the build 69 # our copied .go files are to be used for the build
79 ln -sf vendor.copy vendor 70 ln -sf vendor.copy vendor
80 # inform go that we know what we are doing 71 # inform go that we know what we are doing