summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxcfs/lxcfs_5.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/lxcfs/lxcfs_5.0.4.bb')
-rw-r--r--recipes-containers/lxcfs/lxcfs_5.0.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-containers/lxcfs/lxcfs_5.0.4.bb b/recipes-containers/lxcfs/lxcfs_5.0.4.bb
new file mode 100644
index 00000000..73ed97a7
--- /dev/null
+++ b/recipes-containers/lxcfs/lxcfs_5.0.4.bb
@@ -0,0 +1,25 @@
1SUMMARY = "LXCFS is a userspace filesystem created to avoid kernel limitations"
2LICENSE = "LGPL-2.1-or-later"
3
4inherit meson pkgconfig systemd
5
6SRC_URI = " \
7 https://linuxcontainers.org/downloads/lxcfs/lxcfs-${PV}.tar.gz \
8 file://0001-bindings-fix-build-with-newer-linux-libc-headers.patch \
9 file://0001-meson.build-force-pid-open-send_signal-detection.patch \
10"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=29ae50a788f33f663405488bc61eecb1"
13SRC_URI[md5sum] = "00a6632e094d0a2f2308c8365ac91912"
14SRC_URI[sha256sum] = "c2b361edc881d5ca8fa2cd3260a4999b8f87afce8d937be2160e5cf0b482c52f"
15
16DEPENDS += "fuse python3-jinja2-native help2man-native systemd"
17RDEPENDS:${PN} += "fuse"
18
19FILES:${PN} += "${datadir}/lxc/config/common.conf.d/*"
20
21# help2man doesn't work, so we disable docs
22EXTRA_OEMESON += "-Dinit-script=${VIRTUAL-RUNTIME_init_manager} -Ddocs=false"
23
24SYSTEMD_PACKAGES = "${PN}"
25SYSTEMD_SERVICE:${PN} = "lxcfs.service"