summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/lxc')
-rw-r--r--recipes-containers/lxc/lxc_4.0.9.bb52
1 files changed, 26 insertions, 26 deletions
diff --git a/recipes-containers/lxc/lxc_4.0.9.bb b/recipes-containers/lxc/lxc_4.0.9.bb
index 79072915..0ef81a5a 100644
--- a/recipes-containers/lxc/lxc_4.0.9.bb
+++ b/recipes-containers/lxc/lxc_4.0.9.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c
6" 6"
7 7
8DEPENDS = "libxml2 libcap" 8DEPENDS = "libxml2 libcap"
9RDEPENDS_${PN} = " \ 9RDEPENDS:${PN} = " \
10 rsync \ 10 rsync \
11 curl \ 11 curl \
12 gzip \ 12 gzip \
@@ -30,11 +30,11 @@ RDEPENDS_${PN} = " \
30 util-linux-getopt \ 30 util-linux-getopt \
31" 31"
32 32
33RDEPENDS_${PN}_append_libc-glibc = " glibc-utils" 33RDEPENDS:${PN}:append:libc-glibc = " glibc-utils"
34 34
35RDEPENDS_${PN}-ptest += "file make gmp nettle gnutls bash libgcc" 35RDEPENDS:${PN}-ptest += "file make gmp nettle gnutls bash libgcc"
36 36
37RDEPENDS_${PN}-networking += "iptables" 37RDEPENDS:${PN}-networking += "iptables"
38 38
39SRC_URI = "http://linuxcontainers.org/downloads/${BPN}/${BPN}-${PV}.tar.gz \ 39SRC_URI = "http://linuxcontainers.org/downloads/${BPN}/${BPN}-${PV}.tar.gz \
40 file://lxc-1.0.0-disable-udhcp-from-busybox-template.patch \ 40 file://lxc-1.0.0-disable-udhcp-from-busybox-template.patch \
@@ -90,31 +90,31 @@ export STAGING_LIBDIR
90inherit autotools pkgconfig ptest update-rc.d systemd python3native 90inherit autotools pkgconfig ptest update-rc.d systemd python3native
91 91
92SYSTEMD_PACKAGES = "${PN} ${PN}-networking" 92SYSTEMD_PACKAGES = "${PN} ${PN}-networking"
93SYSTEMD_SERVICE_${PN} = "lxc.service" 93SYSTEMD_SERVICE:${PN} = "lxc.service"
94SYSTEMD_AUTO_ENABLE_${PN} = "disable" 94SYSTEMD_AUTO_ENABLE:${PN} = "disable"
95SYSTEMD_SERVICE_${PN}-networking = "lxc-net.service" 95SYSTEMD_SERVICE:${PN}-networking = "lxc-net.service"
96SYSTEMD_AUTO_ENABLE_${PN}-networking = "enable" 96SYSTEMD_AUTO_ENABLE:${PN}-networking = "enable"
97 97
98INITSCRIPT_PACKAGES = "${PN} ${PN}-networking" 98INITSCRIPT_PACKAGES = "${PN} ${PN}-networking"
99INITSCRIPT_NAME_${PN} = "lxc-containers" 99INITSCRIPT_NAME:${PN} = "lxc-containers"
100INITSCRIPT_PARAMS_${PN} = "defaults" 100INITSCRIPT_PARAMS:${PN} = "defaults"
101INITSCRIPT_NAME_${PN}-networking = "lxc-net" 101INITSCRIPT_NAME:${PN}-networking = "lxc-net"
102INITSCRIPT_PARAMS_${PN}-networking = "defaults" 102INITSCRIPT_PARAMS:${PN}-networking = "defaults"
103 103
104FILES_${PN}-doc = "${mandir} ${infodir}" 104FILES:${PN}-doc = "${mandir} ${infodir}"
105# For LXC the docdir only contains example configuration files and should be included in the lxc package 105# For LXC the docdir only contains example configuration files and should be included in the lxc package
106FILES_${PN} += "${docdir}" 106FILES:${PN} += "${docdir}"
107FILES_${PN} += "${libdir}/python3*" 107FILES:${PN} += "${libdir}/python3*"
108FILES_${PN} += "${datadir}/bash-completion" 108FILES:${PN} += "${datadir}/bash-completion"
109FILES_${PN}-dbg += "${libexecdir}/lxc/.debug" 109FILES:${PN}-dbg += "${libexecdir}/lxc/.debug"
110FILES_${PN}-dbg += "${libexecdir}/lxc/hooks/.debug" 110FILES:${PN}-dbg += "${libexecdir}/lxc/hooks/.debug"
111PACKAGES =+ "${PN}-templates ${PN}-networking ${PN}-lua" 111PACKAGES =+ "${PN}-templates ${PN}-networking ${PN}-lua"
112FILES_lua-${PN} = "${datadir}/lua ${libdir}/lua" 112FILES:lua-${PN} = "${datadir}/lua ${libdir}/lua"
113FILES_lua-${PN}-dbg += "${libdir}/lua/lxc/.debug" 113FILES:lua-${PN}-dbg += "${libdir}/lua/lxc/.debug"
114FILES_${PN}-templates += "${datadir}/lxc/templates" 114FILES:${PN}-templates += "${datadir}/lxc/templates"
115RDEPENDS_${PN}-templates += "bash" 115RDEPENDS:${PN}-templates += "bash"
116 116
117FILES_${PN}-networking += " \ 117FILES:${PN}-networking += " \
118 ${sysconfdir}/init.d/lxc-net \ 118 ${sysconfdir}/init.d/lxc-net \
119 ${sysconfdir}/default/lxc-net \ 119 ${sysconfdir}/default/lxc-net \
120" 120"
@@ -125,7 +125,7 @@ CACHED_CONFIGUREVARS += " \
125 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \ 125 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
126" 126"
127 127
128do_install_append() { 128do_install:append() {
129 # The /var/cache/lxc directory created by the Makefile 129 # The /var/cache/lxc directory created by the Makefile
130 # is wiped out in volatile, we need to create this at boot. 130 # is wiped out in volatile, we need to create this at boot.
131 rm -rf ${D}${localstatedir}/cache 131 rm -rf ${D}${localstatedir}/cache
@@ -165,13 +165,13 @@ do_install_ptest() {
165 mv ${D}/usr/bin/lxc-test-* ${D}/${PTEST_PATH}/tests/. 165 mv ${D}/usr/bin/lxc-test-* ${D}/${PTEST_PATH}/tests/.
166} 166}
167 167
168pkg_postinst_${PN}() { 168pkg_postinst:${PN}() {
169 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then 169 if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then
170 /etc/init.d/populate-volatile.sh update 170 /etc/init.d/populate-volatile.sh update
171 fi 171 fi
172} 172}
173 173
174pkg_postinst_${PN}-networking() { 174pkg_postinst:${PN}-networking() {
175if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 175if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
176cat >> $D/etc/network/interfaces << EOF 176cat >> $D/etc/network/interfaces << EOF
177 177