summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch')
-rw-r--r--recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
index c623b260..d4f84e30 100644
--- a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
+++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
@@ -22,9 +22,9 @@ Index: git/libnetwork/Makefile
22- go build -tags experimental -o "bin/dnet" ./cmd/dnet 22- go build -tags experimental -o "bin/dnet" ./cmd/dnet
23- go build -o "bin/docker-proxy" ./cmd/proxy 23- go build -o "bin/docker-proxy" ./cmd/proxy
24- CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic 24- CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic
25+ $(GO) build -tags experimental -o "bin/dnet" ./cmd/dnet 25+ $(GO) build -trimpath -tags experimental -o "bin/dnet" ./cmd/dnet
26+ $(GO) build -o "bin/proxy" ./cmd/proxy 26+ $(GO) build -trimpath -o "bin/proxy" ./cmd/proxy
27+ CGO_ENABLED=0 $(GO) build -o "bin/diagnosticClient" ./cmd/diagnostic 27+ CGO_ENABLED=0 $(GO) build -trimpath -o "bin/diagnosticClient" ./cmd/diagnostic
28 CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go 28 CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go
29 29
30 build-images: 30 build-images:
@@ -34,8 +34,8 @@ Index: git/libnetwork/Makefile
34 @echo "🐳 $@" 34 @echo "🐳 $@"
35- go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 35- go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
36- go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 36- go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
37+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 37+ @$(GO) build -trimpath -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
38+ @$(GO) build -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 38+ @$(GO) build -trimpath -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
39 39
40 # Rebuild protocol buffers. 40 # Rebuild protocol buffers.
41 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt. 41 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt.