summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-compose
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker-compose')
-rw-r--r--recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch13
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb (renamed from recipes-containers/docker-compose/python3-docker-compose_1.25.5.bb)7
2 files changed, 14 insertions, 6 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
index 6e5ca3d6..f517d05a 100644
--- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
+++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
@@ -11,14 +11,14 @@ Upstream-Status: Inappropriate [OE Specific]
11Signed-off-by: Chen Qi <Qi.Chen@windriver.com> 11Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
12Signed-off-by: Ming Liu <liu.ming50@gmail.com> 12Signed-off-by: Ming Liu <liu.ming50@gmail.com>
13--- 13---
14 setup.py | 22 +++++++++++----------- 14 setup.py | 26 +++++++++++++-------------
15 1 file changed, 11 insertions(+), 11 deletions(-) 15 1 file changed, 13 insertions(+), 13 deletions(-)
16 16
17diff --git a/setup.py b/setup.py 17diff --git a/setup.py b/setup.py
18index 110441dc..eef28254 100644 18index 110441dc..eef28254 100644
19--- a/setup.py 19--- a/setup.py
20+++ b/setup.py 20+++ b/setup.py
21@@ -30,16 +30,16 @@ def find_version(*file_paths): 21@@ -30,18 +30,18 @@ def find_version(*file_paths):
22 22
23 23
24 install_requires = [ 24 install_requires = [
@@ -28,29 +28,34 @@ index 110441dc..eef28254 100644
28- 'requests >= 2.20.0, < 3', 28- 'requests >= 2.20.0, < 3',
29- 'texttable >= 0.9.0, < 2', 29- 'texttable >= 0.9.0, < 2',
30- 'websocket-client >= 0.32.0, < 1', 30- 'websocket-client >= 0.32.0, < 1',
31- 'distro >= 1.5.0, < 2',
31- 'docker[ssh] >= 3.7.0, < 5', 32- 'docker[ssh] >= 3.7.0, < 5',
32- 'dockerpty >= 0.4.1, < 1', 33- 'dockerpty >= 0.4.1, < 1',
33- 'six >= 1.3.0, < 2', 34- 'six >= 1.3.0, < 2',
34- 'jsonschema >= 2.5.1, < 4', 35- 'jsonschema >= 2.5.1, < 4',
36- 'python-dotenv >= 0.13.0, < 1',
35+ 'cached-property >= 1.2.0', 37+ 'cached-property >= 1.2.0',
36+ 'docopt >= 0.6.1', 38+ 'docopt >= 0.6.1',
37+ 'PyYAML >= 3.10', 39+ 'PyYAML >= 3.10',
38+ 'requests >= 2.20.0', 40+ 'requests >= 2.20.0',
39+ 'texttable >= 0.9.0', 41+ 'texttable >= 0.9.0',
40+ 'websocket-client >= 0.32.0', 42+ 'websocket-client >= 0.32.0',
43+ 'distro >= 1.5.0',
41+ 'docker[ssh] >= 3.7.0', 44+ 'docker[ssh] >= 3.7.0',
42+ 'dockerpty >= 0.4.1', 45+ 'dockerpty >= 0.4.1',
43+ 'six >= 1.3.0', 46+ 'six >= 1.3.0',
44+ 'jsonschema >= 2.5.1', 47+ 'jsonschema >= 2.5.1',
48+ 'python-dotenv >= 0.13.0',
45 ] 49 ]
46 50
47 51
48@@ -58,7 +58,7 @@ extras_require = { 52@@ -61,7 +61,7 @@ extras_require = {
49 ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0', 53 ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0',
50 'ipaddress >= 1.0.16, < 2'], 54 'ipaddress >= 1.0.16, < 2'],
51 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], 55 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
52- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], 56- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
53+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'], 57+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
58 'tests': tests_require,
54 } 59 }
55 60
56 61
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.25.5.bb b/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb
index dece5daa..37c62e85 100644
--- a/recipes-containers/docker-compose/python3-docker-compose_1.25.5.bb
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.26.0.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5 5
6inherit pypi setuptools3 6inherit pypi setuptools3
7 7
8SRC_URI[md5sum] = "a6f296957148e4c61b28fb324c27c966" 8SRC_URI[md5sum] = "f7d54de5db1f17322c09db8157bd160f"
9SRC_URI[sha256sum] = "7a2eb6d8173fdf408e505e6f7d497ac0b777388719542be9e49a0efd477a50c6" 9SRC_URI[sha256sum] = "7e836102d139aca667d6af53f0f4d942c9459ec24d6dd4f0203d74359b0fd311"
10 10
11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \ 11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \
12 file://0001-setup.py-import-fastentrypoints.patch \ 12 file://0001-setup.py-import-fastentrypoints.patch \
@@ -19,10 +19,12 @@ RDEPENDS_${PN} = "\
19 ${PYTHON_PN}-certifi \ 19 ${PYTHON_PN}-certifi \
20 ${PYTHON_PN}-chardet \ 20 ${PYTHON_PN}-chardet \
21 ${PYTHON_PN}-colorama \ 21 ${PYTHON_PN}-colorama \
22 ${PYTHON_PN}-distro \
22 ${PYTHON_PN}-docker \ 23 ${PYTHON_PN}-docker \
23 ${PYTHON_PN}-docker-pycreds \ 24 ${PYTHON_PN}-docker-pycreds \
24 ${PYTHON_PN}-dockerpty \ 25 ${PYTHON_PN}-dockerpty \
25 ${PYTHON_PN}-docopt \ 26 ${PYTHON_PN}-docopt \
27 ${PYTHON_PN}-dotenv \
26 ${PYTHON_PN}-fcntl \ 28 ${PYTHON_PN}-fcntl \
27 ${PYTHON_PN}-idna \ 29 ${PYTHON_PN}-idna \
28 ${PYTHON_PN}-jsonschema \ 30 ${PYTHON_PN}-jsonschema \
@@ -34,5 +36,6 @@ RDEPENDS_${PN} = "\
34 ${PYTHON_PN}-terminal \ 36 ${PYTHON_PN}-terminal \
35 ${PYTHON_PN}-texttable \ 37 ${PYTHON_PN}-texttable \
36 ${PYTHON_PN}-urllib3 \ 38 ${PYTHON_PN}-urllib3 \
39 ${PYTHON_PN}-wcwidth \
37 ${PYTHON_PN}-websocket-client \ 40 ${PYTHON_PN}-websocket-client \
38" 41"