summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb')
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb b/recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb
new file mode 100644
index 00000000..1096d31d
--- /dev/null
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.27.4.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Multi-container orchestration for Docker"
2HOMEPAGE = "https://www.docker.com/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "6c25d3b92596dc529edc337cc837eae1"
9SRC_URI[sha256sum] = "5a5690f24c27d4b43dcbe6b3fae91ba680713208e99ee863352b3bae37bcaa83"
10
11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \
12 file://0001-setup.py-import-fastentrypoints.patch \
13 "
14
15DEPENDS += "${PYTHON_PN}-fastentrypoints-native"
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-cached-property \
19 ${PYTHON_PN}-certifi \
20 ${PYTHON_PN}-chardet \
21 ${PYTHON_PN}-colorama \
22 ${PYTHON_PN}-distro \
23 ${PYTHON_PN}-docker \
24 ${PYTHON_PN}-docker-pycreds \
25 ${PYTHON_PN}-dockerpty \
26 ${PYTHON_PN}-docopt \
27 ${PYTHON_PN}-dotenv \
28 ${PYTHON_PN}-fcntl \
29 ${PYTHON_PN}-idna \
30 ${PYTHON_PN}-jsonschema \
31 ${PYTHON_PN}-misc \
32 ${PYTHON_PN}-paramiko \
33 ${PYTHON_PN}-pyyaml \
34 ${PYTHON_PN}-requests \
35 ${PYTHON_PN}-six \
36 ${PYTHON_PN}-terminal \
37 ${PYTHON_PN}-texttable \
38 ${PYTHON_PN}-urllib3 \
39 ${PYTHON_PN}-wcwidth \
40 ${PYTHON_PN}-websocket-client \
41"