summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch')
-rw-r--r--recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch13
1 files changed, 9 insertions, 4 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
index 6e5ca3d6..f517d05a 100644
--- a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
+++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch
@@ -11,14 +11,14 @@ Upstream-Status: Inappropriate [OE Specific]
11Signed-off-by: Chen Qi <Qi.Chen@windriver.com> 11Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
12Signed-off-by: Ming Liu <liu.ming50@gmail.com> 12Signed-off-by: Ming Liu <liu.ming50@gmail.com>
13--- 13---
14 setup.py | 22 +++++++++++----------- 14 setup.py | 26 +++++++++++++-------------
15 1 file changed, 11 insertions(+), 11 deletions(-) 15 1 file changed, 13 insertions(+), 13 deletions(-)
16 16
17diff --git a/setup.py b/setup.py 17diff --git a/setup.py b/setup.py
18index 110441dc..eef28254 100644 18index 110441dc..eef28254 100644
19--- a/setup.py 19--- a/setup.py
20+++ b/setup.py 20+++ b/setup.py
21@@ -30,16 +30,16 @@ def find_version(*file_paths): 21@@ -30,18 +30,18 @@ def find_version(*file_paths):
22 22
23 23
24 install_requires = [ 24 install_requires = [
@@ -28,29 +28,34 @@ index 110441dc..eef28254 100644
28- 'requests >= 2.20.0, < 3', 28- 'requests >= 2.20.0, < 3',
29- 'texttable >= 0.9.0, < 2', 29- 'texttable >= 0.9.0, < 2',
30- 'websocket-client >= 0.32.0, < 1', 30- 'websocket-client >= 0.32.0, < 1',
31- 'distro >= 1.5.0, < 2',
31- 'docker[ssh] >= 3.7.0, < 5', 32- 'docker[ssh] >= 3.7.0, < 5',
32- 'dockerpty >= 0.4.1, < 1', 33- 'dockerpty >= 0.4.1, < 1',
33- 'six >= 1.3.0, < 2', 34- 'six >= 1.3.0, < 2',
34- 'jsonschema >= 2.5.1, < 4', 35- 'jsonschema >= 2.5.1, < 4',
36- 'python-dotenv >= 0.13.0, < 1',
35+ 'cached-property >= 1.2.0', 37+ 'cached-property >= 1.2.0',
36+ 'docopt >= 0.6.1', 38+ 'docopt >= 0.6.1',
37+ 'PyYAML >= 3.10', 39+ 'PyYAML >= 3.10',
38+ 'requests >= 2.20.0', 40+ 'requests >= 2.20.0',
39+ 'texttable >= 0.9.0', 41+ 'texttable >= 0.9.0',
40+ 'websocket-client >= 0.32.0', 42+ 'websocket-client >= 0.32.0',
43+ 'distro >= 1.5.0',
41+ 'docker[ssh] >= 3.7.0', 44+ 'docker[ssh] >= 3.7.0',
42+ 'dockerpty >= 0.4.1', 45+ 'dockerpty >= 0.4.1',
43+ 'six >= 1.3.0', 46+ 'six >= 1.3.0',
44+ 'jsonschema >= 2.5.1', 47+ 'jsonschema >= 2.5.1',
48+ 'python-dotenv >= 0.13.0',
45 ] 49 ]
46 50
47 51
48@@ -58,7 +58,7 @@ extras_require = { 52@@ -61,7 +61,7 @@ extras_require = {
49 ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0', 53 ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0',
50 'ipaddress >= 1.0.16, < 2'], 54 'ipaddress >= 1.0.16, < 2'],
51 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'], 55 ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
52- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], 56- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
53+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'], 57+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
58 'tests': tests_require,
54 } 59 }
55 60
56 61