summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch')
-rw-r--r--recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
index d1f136c4..838cbdc9 100644
--- a/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
+++ b/recipes-containers/criu/files/0001-criu-Fix-toolchain-hardcode.patch
@@ -33,7 +33,7 @@ diff --git a/scripts/nmk/scripts/include.mk b/scripts/nmk/scripts/include.mk
33index 04ccb3a..0d63bc7 100644 33index 04ccb3a..0d63bc7 100644
34--- a/scripts/nmk/scripts/include.mk 34--- a/scripts/nmk/scripts/include.mk
35+++ b/scripts/nmk/scripts/include.mk 35+++ b/scripts/nmk/scripts/include.mk
36@@ -20,7 +20,7 @@ SUBARCH := $(shell uname -m | sed \ 36@@ -22,7 +22,7 @@ SUBARCH := $(shell uname -m | sed \
37 -e s/aarch64.*/aarch64/) 37 -e s/aarch64.*/aarch64/)
38 38
39 ARCH ?= $(SUBARCH) 39 ARCH ?= $(SUBARCH)
@@ -46,7 +46,7 @@ diff --git a/scripts/nmk/scripts/tools.mk b/scripts/nmk/scripts/tools.mk
46index 56dba84..1698821 100644 46index 56dba84..1698821 100644
47--- a/scripts/nmk/scripts/tools.mk 47--- a/scripts/nmk/scripts/tools.mk
48+++ b/scripts/nmk/scripts/tools.mk 48+++ b/scripts/nmk/scripts/tools.mk
49@@ -2,30 +2,30 @@ ifndef ____nmk_defined__tools 49@@ -2,31 +2,31 @@ ifndef ____nmk_defined__tools
50 50
51 # 51 #
52 # System tools shorthands 52 # System tools shorthands
@@ -68,9 +68,7 @@ index 56dba84..1698821 100644
68-MKDIR := mkdir -p 68-MKDIR := mkdir -p
69-AWK := awk 69-AWK := awk
70-PERL := perl 70-PERL := perl
71-PYTHON := python 71-FULL_PYTHON := $(shell which python2 2>/dev/null || which python3 2>/dev/null)
72-FIND := find
73-SH := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
74+CC ?= $(CROSS_COMPILE)$(HOSTCC) 72+CC ?= $(CROSS_COMPILE)$(HOSTCC)
75+CPP ?= $(CC) -E 73+CPP ?= $(CC) -E
76+AS ?= $(CROSS_COMPILE)as 74+AS ?= $(CROSS_COMPILE)as
@@ -83,7 +81,10 @@ index 56dba84..1698821 100644
83+MKDIR ?= mkdir -p 81+MKDIR ?= mkdir -p
84+AWK ?= awk 82+AWK ?= awk
85+PERL ?= perl 83+PERL ?= perl
86+PYTHON ?= python 84+FULL_PYTHON ?= $(shell which python2 2>/dev/null || which python3 2>/dev/null)
85 PYTHON ?= $(shell basename $(FULL_PYTHON))
86-FIND := find
87-SH := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
87+FIND ?= find 88+FIND ?= find
88+SH ?= $(shell if [ -x "$$BASH" ]; then echo $$BASH; \ 89+SH ?= $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
89 else if [ -x /bin/bash ]; then echo /bin/bash; \ 90 else if [ -x /bin/bash ]; then echo /bin/bash; \