summaryrefslogtreecommitdiffstats
path: root/recipes-containers/criu/criu_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/criu/criu_git.bb')
-rw-r--r--recipes-containers/criu/criu_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb
new file mode 100644
index 00000000..878827f8
--- /dev/null
+++ b/recipes-containers/criu/criu_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "CRIU"
2DESCRIPTION = "Checkpoint/Restore In Userspace, or CRIU, is a software tool for Linux operating system. Using this tool, you can freeze a running application (or part of it) and checkpoint it to a hard drive as a collection of files. You can then use the files to restore and run the application from the point it was frozen at. The distinctive feature of the CRIU project is that it is mainly implemented in user space"
3HOMEPAGE = "http://criu.org"
4SECTION = "console/tools"
5LICENSE = "GPLv2"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=12920dfe6b35a0758155f0e62878b366"
8
9SRCREV = "d81c9a4618db2f618bdb8e207b7f0fec631c7142"
10PR = "r0"
11PV = "0.2+git${SRCPV}"
12
13SRC_URI = "git://git.criu.org/crtools.git;protocol=git \
14 file://0001-Fixed-hardcoding.patch"
15
16DEPENDS += "protobuf-c-native protobuf-c"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OEMAKE += "ARCH=${TARGET_ARCH} WERROR=0"
21
22do_compile () {
23 oe_runmake
24}
25
26do_install () {
27 mkdir -p ${D}/${bindir}
28 install -m 755 ${S}/crtools ${D}/${bindir}/crtools
29} \ No newline at end of file