summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend')
-rw-r--r--dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend b/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend
new file mode 100644
index 00000000..2a511160
--- /dev/null
+++ b/dynamic-layers/raspberrypi/recipes-bsp/rpi-u-boot-scr/rpi-u-boot-scr.bbappend
@@ -0,0 +1,17 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3RPI_DOM0_MEM ??= "256M"
4RPI_DEBUG_XEN_ARGS ??= "sync_console bootscrub=0"
5
6SRC_URI += "file://boot.cmd.xen.in"
7
8# If the distro is Xen enabled, override the default boot.cmd.in with the
9# alternative boot.cmd.xen.in from this layer, with variables subsitution here
10do_compile_append() {
11 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'xen', 'yes', 'no', d)}" = "yes" ]; then
12 sed -e 's/@@RPI_DOM0_MEM@@/${RPI_DOM0_MEM}/' \
13 -e 's/@@RPI_DEBUG_XEN_ARGS@@/${RPI_DEBUG_XEN_ARGS}/' \
14 "${WORKDIR}/boot.cmd.xen.in" > "${WORKDIR}/boot.cmd"
15 mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
16 fi
17}