summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb38
-rw-r--r--recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch14
2 files changed, 27 insertions, 25 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index 6be8d6fe..822c57ff 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -1,4 +1,4 @@
1HOMEPAGE = "https://github.com/kubernetes-incubator/cri-o" 1HOMEPAGE = "https://github.com/kubernetes-sigs/cri-o"
2SUMMARY = "Open Container Initiative-based implementation of Kubernetes Container Runtime Interface" 2SUMMARY = "Open Container Initiative-based implementation of Kubernetes Container Runtime Interface"
3DESCRIPTION = "cri-o is meant to provide an integration path between OCI conformant \ 3DESCRIPTION = "cri-o is meant to provide an integration path between OCI conformant \
4runtimes and the kubelet. Specifically, it implements the Kubelet Container Runtime \ 4runtimes and the kubelet. Specifically, it implements the Kubelet Container Runtime \
@@ -14,9 +14,9 @@ At a high level, we expect the scope of cri-o to be restricted to the following
14 - Resource isolation as required by the CRI \ 14 - Resource isolation as required by the CRI \
15 " 15 "
16 16
17SRCREV_cri-o = "65faae67828fb3eb3eac05b582aae9f9d1dea51c" 17SRCREV_cri-o = "774a29ecf6855f2dff266dc2aa2fe81d7d964465"
18SRC_URI = "\ 18SRC_URI = "\
19 git://github.com/kubernetes-incubator/cri-o.git;nobranch=1;name=cri-o \ 19 git://github.com/kubernetes-sigs/cri-o.git;nobranch=1;name=cri-o \
20 file://0001-Makefile-force-symlinks.patch \ 20 file://0001-Makefile-force-symlinks.patch \
21 file://crio.conf \ 21 file://crio.conf \
22 " 22 "
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c2
27 27
28GO_IMPORT = "import" 28GO_IMPORT = "import"
29 29
30PV = "1.0.0-rc3-dev+git${SRCREV_cri-o}" 30PV = "1.12.0+git${SRCREV_cri-o}"
31 31
32DEPENDS = " \ 32DEPENDS = " \
33 glib-2.0 \ 33 glib-2.0 \
@@ -69,15 +69,18 @@ do_compile() {
69 rm -f ${S}/src/import/vendor/src 69 rm -f ${S}/src/import/vendor/src
70 ln -sf ./ ${S}/src/import/vendor/src 70 ln -sf ./ ${S}/src/import/vendor/src
71 71
72 mkdir -p ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o 72 mkdir -p ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o
73 ln -sf ../../../../cmd ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/cmd 73 ln -sf ../../../../cmd ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/cmd
74 ln -sf ../../../../test ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/test 74 ln -sf ../../../../test ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/test
75 ln -sf ../../../../oci ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/oci 75 ln -sf ../../../../oci ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/oci
76 ln -sf ../../../../server ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/server 76 ln -sf ../../../../server ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/server
77 ln -sf ../../../../pkg ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/pkg 77 ln -sf ../../../../pkg ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/pkg
78 ln -sf ../../../../libpod ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/libpod 78 ln -sf ../../../../libpod ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/libpod
79 ln -sf ../../../../libkpod ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/libkpod 79 ln -sf ../../../../libkpod ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/libkpod
80 ln -sf ../../../../utils ${S}/src/import/vendor/github.com/kubernetes-incubator/cri-o/utils 80 ln -sf ../../../../utils ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/utils
81 ln -sf ../../../../types ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/types
82 ln -sf ../../../../version ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/version
83 ln -sf ../../../../lib ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/lib
81 84
82 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 85 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
83 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" 86 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
@@ -111,12 +114,11 @@ do_install() {
111 install -d ${D}/${sysconfdir}/crio/config/ 114 install -d ${D}/${sysconfdir}/crio/config/
112 install -m 755 -D ${S}/src/import/test/testdata/* ${D}/${sysconfdir}/crio/config/ 115 install -m 755 -D ${S}/src/import/test/testdata/* ${D}/${sysconfdir}/crio/config/
113 116
114 install ${S}/src/import/crio ${D}/${localbindir} 117 install ${S}/src/import/bin/crio ${D}/${localbindir}
115 install ${S}/src/import/crioctl ${D}/${localbindir} 118 install ${S}/src/import/bin/crio-config ${D}/${localbindir}
116 install ${S}/src/import/kpod ${D}/${localbindir}
117 119
118 install ${S}/src/import/conmon/conmon ${D}/${libexecdir}/crio 120 install ${S}/src/import/bin/conmon ${D}/${localbindir}/crio
119 install ${S}/src/import/pause/pause ${D}/${libexecdir}/crio 121 install ${S}/src/import/bin/pause ${D}/${localbindir}/crio
120 122
121 install -m 0644 ${S}/src/import/contrib/systemd/crio.service ${D}${systemd_unitdir}/system/ 123 install -m 0644 ${S}/src/import/contrib/systemd/crio.service ${D}${systemd_unitdir}/system/
122 install -m 0644 ${S}/src/import/contrib/systemd/crio-shutdown.service ${D}${systemd_unitdir}/system/ 124 install -m 0644 ${S}/src/import/contrib/systemd/crio-shutdown.service ${D}${systemd_unitdir}/system/
diff --git a/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch b/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch
index 320eac86..0b106e41 100644
--- a/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch
+++ b/recipes-containers/cri-o/files/0001-Makefile-force-symlinks.patch
@@ -1,6 +1,6 @@
1From a4433978bf324525b4c260b0e9615ae27271fe55 Mon Sep 17 00:00:00 2001 1From 53371afbf0f20a1651ee6f2406cd2be056a31066 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com> 2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Wed, 20 Sep 2017 12:05:40 -0400 3Date: Thu, 1 Nov 2018 11:17:05 -0400
4Subject: [PATCH] Makefile: force symlinks 4Subject: [PATCH] Makefile: force symlinks
5 5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> 6Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
@@ -9,18 +9,18 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
9 1 file changed, 1 insertion(+), 1 deletion(-) 9 1 file changed, 1 insertion(+), 1 deletion(-)
10 10
11diff --git a/src/import/Makefile b/src/import/Makefile 11diff --git a/src/import/Makefile b/src/import/Makefile
12index e3e5050bb7f6..4ad3fb7ff0a9 100644 12index cf37bec..68c8eeb 100644
13--- a/src/import/Makefile 13--- a/src/import/Makefile
14+++ b/src/import/Makefile 14+++ b/src/import/Makefile
15@@ -53,7 +53,7 @@ help: 15@@ -66,7 +66,7 @@ help:
16 .gopathok: 16 .gopathok:
17 ifeq ("$(wildcard $(GOPKGDIR))","") 17 ifeq ("$(wildcard $(GOPKGDIR))","")
18 mkdir -p "$(GOPKGBASEDIR)" 18 mkdir -p "$(GOPKGBASEDIR)"
19- ln -s "$(CURDIR)" "$(GOPKGBASEDIR)" 19- ln -s "$(CURDIR)" "$(GOPKGDIR)"
20+ ln -sf "$(CURDIR)" "$(GOPKGBASEDIR)" 20+ ln -sf "$(CURDIR)" "$(GOPKGDIR)"
21 endif 21 endif
22 touch "$(GOPATH)/.gopathok" 22 touch "$(GOPATH)/.gopathok"
23 23
24-- 24--
252.4.0.53.g8440f74 252.7.4
26 26