summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/xen/files/0001-Config.mk-drop-Wdeclaration-after-statement.patch42
-rw-r--r--recipes-extended/xen/xen-tools_4.18.bb3
2 files changed, 1 insertions, 44 deletions
diff --git a/recipes-extended/xen/files/0001-Config.mk-drop-Wdeclaration-after-statement.patch b/recipes-extended/xen/files/0001-Config.mk-drop-Wdeclaration-after-statement.patch
deleted file mode 100644
index dcfffb06..00000000
--- a/recipes-extended/xen/files/0001-Config.mk-drop-Wdeclaration-after-statement.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 70e8b986fe78f5fbd1dfdef4f02ea9b50c7158db Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex@linutronix.de>
3Date: Tue, 28 Nov 2023 18:34:17 +0100
4Subject: [PATCH] Config.mk: drop -Wdeclaration-after-statement
5
6Such constructs are fully allowed by C99:
7https://gcc.gnu.org/onlinedocs/gcc-12.2.0/gcc/Mixed-Labels-and-Declarations.html#Mixed-Labels-and-Declarations
8
9If the flag is present, then building against python 3.12 will fail thusly:
10
11| In file included from /srv/storage/alex/yocto/build-virt/tmp/work/core2-64-poky-linux/xen-tools/4.17+stable/recipe-sysroot/usr/include/python3.12/Python.h:44,
12| from xen/lowlevel/xc/xc.c:8:
13| /srv/storage/alex/yocto/build-virt/tmp/work/core2-64-poky-linux/xen-tools/4.17+stable/recipe-sysroot/usr/include/python3.12/object.h: In function 'Py_SIZE':
14| /srv/storage/alex/yocto/build-virt/tmp/work/core2-64-poky-linux/xen-tools/4.17+stable/recipe-sysroot/usr/include/python3.12/object.h:233:5: error: ISO C90 forbids mixed declarations and code [-Werror=declaration-after-statement]
15| 233 | PyVarObject *var_ob = _PyVarObject_CAST(ob);
16| | ^~~~~~~~~~~
17| In file included from /srv/storage/alex/yocto/build-virt/tmp/work/core2-64-poky-linux/xen-tools/4.17+stable/recipe-sysroot/usr/include/python3.12/Python.h:53:
18| /srv/storage/alex/yocto/build-virt/tmp/work/core2-64-poky-linux/xen-tools/4.17+stable/recipe-sysroot/usr/include/python3.12/cpython/longintrepr.h: In function '_PyLong_CompactValue':
19| /srv/storage/alex/yocto/build-virt/tmp/work/core2-64-poky-linux/xen-tools/4.17+stable/recipe-sysroot/usr/include/python3.12/cpython/longintrepr.h:121:5: error: ISO C90 forbids mixed declarations and code [-Werror=declaration-after-statement]
20| 121 | Py_ssize_t sign = 1 - (op->long_value.lv_tag & _PyLong_SIGN_MASK);
21| | ^~~~~~~~~~
22| cc1: all warnings being treated as errors
23
24Upstream-Status: Submitted [by email to xen-devel@lists.xenproject.org and maintainers printed by get_maintainer.pl]
25Signed-off-by: Alexander Kanavin <alex@linutronix.de>
26---
27 Config.mk | 2 --
28 1 file changed, 2 deletions(-)
29
30diff --git a/Config.mk b/Config.mk
31index 8bc2bcd5f6..09d5e8ebde 100644
32--- a/Config.mk
33+++ b/Config.mk
34@@ -173,8 +173,6 @@ CFLAGS += -std=gnu99
35
36 CFLAGS += -Wall -Wstrict-prototypes
37
38-$(call cc-option-add,HOSTCFLAGS,HOSTCC,-Wdeclaration-after-statement)
39-$(call cc-option-add,CFLAGS,CC,-Wdeclaration-after-statement)
40 $(call cc-option-add,CFLAGS,CC,-Wno-unused-but-set-variable)
41 $(call cc-option-add,CFLAGS,CC,-Wno-unused-local-typedefs)
42
diff --git a/recipes-extended/xen/xen-tools_4.18.bb b/recipes-extended/xen/xen-tools_4.18.bb
index 9920c358..5dbe180a 100644
--- a/recipes-extended/xen/xen-tools_4.18.bb
+++ b/recipes-extended/xen/xen-tools_4.18.bb
@@ -1,5 +1,5 @@
1# tag: RELEASE-4.18.0 1# tag: RELEASE-4.18.0
2SRCREV ?= "d75f1e9b74314cea91ce435730d4e3539ecca77d" 2SRCREV ?= "4da8ca9cb9cfdb92c9dd09d5270ae16a3b2dbc89"
3 3
4XEN_REL ?= "4.18" 4XEN_REL ?= "4.18"
5XEN_BRANCH ?= "stable-4.18" 5XEN_BRANCH ?= "stable-4.18"
@@ -7,7 +7,6 @@ XEN_BRANCH ?= "stable-4.18"
7SRC_URI = " \ 7SRC_URI = " \
8 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ 8 git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \
9 file://0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch \ 9 file://0001-python-pygrub-pass-DISTUTILS-xen-4.18.patch \
10 file://0001-Config.mk-drop-Wdeclaration-after-statement.patch \
11 " 10 "
12 11
13LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" 12LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9"