diff options
4 files changed, 16 insertions, 19 deletions
diff --git a/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch b/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch index 90a7b79f..8c6644a3 100644 --- a/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch +++ b/recipes-containers/kubernetes/kubernetes/0001-build-golang.sh-convert-remaining-go-calls-to-use.patch | |||
@@ -8,10 +8,10 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
8 | hack/lib/golang.sh | 8 ++++---- | 8 | hack/lib/golang.sh | 8 ++++---- |
9 | 1 file changed, 4 insertions(+), 4 deletions(-) | 9 | 1 file changed, 4 insertions(+), 4 deletions(-) |
10 | 10 | ||
11 | Index: kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f/src/import/hack/lib/golang.sh | 11 | Index: kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f/hack/lib/golang.sh |
12 | =================================================================== | 12 | =================================================================== |
13 | --- kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f.orig/src/import/hack/lib/golang.sh | 13 | --- kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f.orig/hack/lib/golang.sh |
14 | +++ kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f/src/import/hack/lib/golang.sh | 14 | +++ kubernetes-v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f/hack/lib/golang.sh |
15 | @@ -652,7 +652,7 @@ | 15 | @@ -652,7 +652,7 @@ |
16 | kube::golang::create_coverage_dummy_test "${package}" | 16 | kube::golang::create_coverage_dummy_test "${package}" |
17 | kube::util::trap_add "kube::golang::delete_coverage_dummy_test \"${package}\"" EXIT | 17 | kube::util::trap_add "kube::golang::delete_coverage_dummy_test \"${package}\"" EXIT |
diff --git a/recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch b/recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch index 659e3013..2758fb39 100644 --- a/recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch +++ b/recipes-containers/kubernetes/kubernetes/0001-cross-don-t-build-tests-by-default.patch | |||
@@ -15,10 +15,10 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> | |||
15 | hack/make-rules/cross.sh | 4 ++-- | 15 | hack/make-rules/cross.sh | 4 ++-- |
16 | 1 file changed, 2 insertions(+), 2 deletions(-) | 16 | 1 file changed, 2 insertions(+), 2 deletions(-) |
17 | 17 | ||
18 | diff --git a/src/import/hack/make-rules/cross.sh b/hack/make-rules/cross.sh | 18 | diff --git a/hack/make-rules/cross.sh b/hack/make-rules/cross.sh |
19 | index 8e1e938..0898c5c 100755 | 19 | index 8e1e938..0898c5c 100755 |
20 | --- a/src/import/hack/make-rules/cross.sh | 20 | --- a/hack/make-rules/cross.sh |
21 | +++ b/src/import/hack/make-rules/cross.sh | 21 | +++ b/hack/make-rules/cross.sh |
22 | @@ -33,6 +33,6 @@ make all WHAT="${KUBE_NODE_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_NODE_PLATFO | 22 | @@ -33,6 +33,6 @@ make all WHAT="${KUBE_NODE_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_NODE_PLATFO |
23 | 23 | ||
24 | make all WHAT="${KUBE_CLIENT_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_CLIENT_PLATFORMS[*]}" | 24 | make all WHAT="${KUBE_CLIENT_TARGETS[*]}" KUBE_BUILD_PLATFORMS="${KUBE_CLIENT_PLATFORMS[*]}" |
diff --git a/recipes-containers/kubernetes/kubernetes/0001-hack-lib-golang.sh-use-CC-from-environment.patch b/recipes-containers/kubernetes/kubernetes/0001-hack-lib-golang.sh-use-CC-from-environment.patch index 3a22a2ef..1c4555a3 100644 --- a/recipes-containers/kubernetes/kubernetes/0001-hack-lib-golang.sh-use-CC-from-environment.patch +++ b/recipes-containers/kubernetes/kubernetes/0001-hack-lib-golang.sh-use-CC-from-environment.patch | |||
@@ -11,10 +11,10 @@ Signed-off-by: Koen Kooi <koen.kooi@linaro.org> | |||
11 | hack/lib/golang.sh | 4 ---- | 11 | hack/lib/golang.sh | 4 ---- |
12 | 1 file changed, 4 deletions(-) | 12 | 1 file changed, 4 deletions(-) |
13 | 13 | ||
14 | Index: kubernetes-v1.21.1+git45da3fc33872083fb225c1a8c4d03e530d6f7630/src/import/hack/lib/golang.sh | 14 | Index: kubernetes-v1.21.1+git45da3fc33872083fb225c1a8c4d03e530d6f7630/hack/lib/golang.sh |
15 | =================================================================== | 15 | =================================================================== |
16 | --- kubernetes-v1.21.1+git45da3fc33872083fb225c1a8c4d03e530d6f7630.orig/src/import/hack/lib/golang.sh | 16 | --- kubernetes-v1.21.1+git45da3fc33872083fb225c1a8c4d03e530d6f7630.orig/hack/lib/golang.sh |
17 | +++ kubernetes-v1.21.1+git45da3fc33872083fb225c1a8c4d03e530d6f7630/src/import/hack/lib/golang.sh | 17 | +++ kubernetes-v1.21.1+git45da3fc33872083fb225c1a8c4d03e530d6f7630/hack/lib/golang.sh |
18 | @@ -414,19 +414,15 @@ | 18 | @@ -414,19 +414,15 @@ |
19 | ;; | 19 | ;; |
20 | "linux/arm") | 20 | "linux/arm") |
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb index e9460d46..3289a641 100644 --- a/recipes-containers/kubernetes/kubernetes_git.bb +++ b/recipes-containers/kubernetes/kubernetes_git.bb | |||
@@ -11,7 +11,7 @@ SRCREV_kubernetes-release = "7c1aa83dac555de6f05500911467b70aca4949f0" | |||
11 | PE = "1" | 11 | PE = "1" |
12 | 12 | ||
13 | BBCLASSEXTEND = "devupstream:target" | 13 | BBCLASSEXTEND = "devupstream:target" |
14 | LIC_FILES_CHKSUM:class-devupstream = "file://src/import/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 14 | LIC_FILES_CHKSUM:class-devupstream = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
15 | DEFAULT_PREFERENCE:class-devupstream = "-1" | 15 | DEFAULT_PREFERENCE:class-devupstream = "-1" |
16 | SRC_URI:classedevupstream = "git://github.com/kubernetes/kubernetes.git;branch=master;name=kubernetes;protocol=https \ | 16 | SRC_URI:classedevupstream = "git://github.com/kubernetes/kubernetes.git;branch=master;name=kubernetes;protocol=https \ |
17 | git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https \ | 17 | git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https \ |
@@ -22,7 +22,7 @@ PV:class-devupstream = "v1.23-alpha+git${SRCPV}" | |||
22 | 22 | ||
23 | SRCREV_FORMAT ?= "kubernetes_release" | 23 | SRCREV_FORMAT ?= "kubernetes_release" |
24 | 24 | ||
25 | SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.24;name=kubernetes;protocol=https \ | 25 | SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.24;name=kubernetes;protocol=https;destsuffix=git/src/github.com/kubernetes/kubernetes \ |
26 | git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https" | 26 | git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https" |
27 | 27 | ||
28 | SRC_URI:append = " \ | 28 | SRC_URI:append = " \ |
@@ -40,9 +40,10 @@ DEPENDS += "rsync-native \ | |||
40 | " | 40 | " |
41 | 41 | ||
42 | LICENSE = "Apache-2.0" | 42 | LICENSE = "Apache-2.0" |
43 | LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | 43 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
44 | 44 | ||
45 | GO_IMPORT = "import" | 45 | GO_IMPORT = "import" |
46 | S = "${WORKDIR}/git/src/github.com/kubernetes/kubernetes" | ||
46 | 47 | ||
47 | inherit systemd | 48 | inherit systemd |
48 | inherit go | 49 | inherit go |
@@ -52,12 +53,8 @@ inherit cni_networking | |||
52 | COMPATIBLE_HOST = '(x86_64.*|arm.*|aarch64.*)-linux' | 53 | COMPATIBLE_HOST = '(x86_64.*|arm.*|aarch64.*)-linux' |
53 | 54 | ||
54 | do_compile() { | 55 | do_compile() { |
55 | # link fixups for compilation | 56 | export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go:${WORKDIR}/git/" |
56 | rm -f ${S}/src/import/vendor/src | 57 | cd ${S} |
57 | ln -sf ./ ${S}/src/import/vendor/src | ||
58 | |||
59 | export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" | ||
60 | cd ${S}/src/import | ||
61 | 58 | ||
62 | # Build the host tools first, using the host compiler | 59 | # Build the host tools first, using the host compiler |
63 | export GOARCH="${BUILD_GOARCH}" | 60 | export GOARCH="${BUILD_GOARCH}" |
@@ -97,7 +94,7 @@ do_install() { | |||
97 | 94 | ||
98 | install -d ${D}${sysconfdir}/kubernetes/manifests/ | 95 | install -d ${D}${sysconfdir}/kubernetes/manifests/ |
99 | 96 | ||
100 | install -m 755 -D ${S}/src/import/_output/local/bin/${TARGET_GOOS}/${TARGET_GOARCH}/* ${D}/${bindir} | 97 | install -m 755 -D ${S}/_output/local/bin/${TARGET_GOOS}/${TARGET_GOARCH}/* ${D}/${bindir} |
101 | 98 | ||
102 | install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubelet/lib/systemd/system/kubelet.service ${D}${systemd_unitdir}/system/ | 99 | install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubelet/lib/systemd/system/kubelet.service ${D}${systemd_unitdir}/system/ |
103 | install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubeadm/10-kubeadm.conf ${D}${systemd_unitdir}/system/kubelet.service.d/ | 100 | install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubeadm/10-kubeadm.conf ${D}${systemd_unitdir}/system/kubelet.service.d/ |