summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker-compose/files/0001-setup.py-import-fastentrypoints.patch28
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb6
2 files changed, 33 insertions, 1 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-import-fastentrypoints.patch b/recipes-containers/docker-compose/files/0001-setup.py-import-fastentrypoints.patch
new file mode 100644
index 00000000..df613e84
--- /dev/null
+++ b/recipes-containers/docker-compose/files/0001-setup.py-import-fastentrypoints.patch
@@ -0,0 +1,28 @@
1From f3a22f0f14a4b3313e6405dfb6c97df949493a34 Mon Sep 17 00:00:00 2001
2From: Ming Liu <liu.ming50@gmail.com>
3Date: Thu, 30 Jan 2020 17:22:19 +0100
4Subject: [PATCH] setup.py: import fastentrypoints
5
6Upstream-Status: Inappropriate [OE specific configuration]
7
8Signed-off-by: Ming Liu <liu.ming50@gmail.com>
9---
10 setup.py | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/setup.py b/setup.py
14index ad57969..3cccffc 100644
15--- a/setup.py
16+++ b/setup.py
17@@ -12,7 +12,7 @@ import sys
18 import pkg_resources
19 from setuptools import find_packages
20 from setuptools import setup
21-
22+import fastentrypoints
23
24 def read(*parts):
25 path = os.path.join(os.path.dirname(__file__), *parts)
26--
272.7.4
28
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb b/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
index 36e24171..ba35c49c 100644
--- a/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
@@ -8,7 +8,11 @@ inherit pypi setuptools3
8SRC_URI[md5sum] = "275b32cffdad6b9816dc8b4c7e55600a" 8SRC_URI[md5sum] = "275b32cffdad6b9816dc8b4c7e55600a"
9SRC_URI[sha256sum] = "2c5fcbfd3ff445b6f3eebb549cb167ef1d8f70c5806aab8f309fc8fa74cd977e" 9SRC_URI[sha256sum] = "2c5fcbfd3ff445b6f3eebb549cb167ef1d8f70c5806aab8f309fc8fa74cd977e"
10 10
11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch" 11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch \
12 file://0001-setup.py-import-fastentrypoints.patch \
13 "
14
15DEPENDS += "${PYTHON_PN}-fastentrypoints-native"
12 16
13RDEPENDS_${PN} = "\ 17RDEPENDS_${PN} = "\
14 ${PYTHON_PN}-cached-property \ 18 ${PYTHON_PN}-cached-property \