summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch25
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb6
2 files changed, 18 insertions, 13 deletions
diff --git a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
index 0090a589..c855d7b5 100644
--- a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
+++ b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch
@@ -1,19 +1,21 @@
1From d2c47a973f354ffd505bb4e809c59e57b543726d Mon Sep 17 00:00:00 2001 1From 0fe50d2ca4517f5e3070585040f35ace413acd44 Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com> 2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 6 Aug 2019 19:01:45 +0800 3Date: Tue, 24 Aug 2021 11:38:23 -0400
4Subject: [PATCH] Makefile: respect GOBUILDFLAGS for runc and remove recvtty 4Subject: [PATCH] Makefile: respect GOBUILDFLAGS for runc and remove recvtty
5 from static 5 from static
6 6
7Signed-off-by: Chen Qi <Qi.Chen@windriver.com> 7Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
8[bva: refreshed for release 1.0.2]
9Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
8--- 10---
9 Makefile | 3 +-- 11 Makefile | 3 +--
10 1 file changed, 1 insertion(+), 2 deletions(-) 12 1 file changed, 1 insertion(+), 2 deletions(-)
11 13
12Index: git/src/import/Makefile 14diff --git a/src/import/Makefile b/src/import/Makefile
13=================================================================== 15index efbddf0d..4b174c80 100644
14--- git.orig/src/import/Makefile 16--- a/src/import/Makefile
15+++ git/src/import/Makefile 17+++ b/src/import/Makefile
16@@ -25,7 +25,7 @@ 18@@ -24,7 +24,7 @@ ifeq ($(shell $(GO) env GOOS),linux)
17 endif 19 endif
18 endif 20 endif
19 endif 21 endif
@@ -21,8 +23,8 @@ Index: git/src/import/Makefile
21+GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ 23+GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \
22 -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" 24 -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
23 GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ 25 GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \
24 -ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" 26 -ldflags "-extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)"
25@@ -42,7 +42,6 @@ 27@@ -41,7 +41,6 @@ recvtty:
26 28
27 static: 29 static:
28 $(GO_BUILD_STATIC) -o runc . 30 $(GO_BUILD_STATIC) -o runc .
@@ -30,3 +32,6 @@ Index: git/src/import/Makefile
30 32
31 release: 33 release:
32 script/release.sh -r release/$(VERSION) -v $(VERSION) 34 script/release.sh -r release/$(VERSION) -v $(VERSION)
35--
362.19.1
37
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
index a0602a2d..37955403 100644
--- a/recipes-containers/runc/runc-opencontainers_git.bb
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -1,10 +1,10 @@
1include runc.inc 1include runc.inc
2 2
3SRCREV = "bfcbc947d5d11327f2680047e2e6e94f4ee93d2a" 3SRCREV = "86d83333d765f4535e4898d6778388dab715eb7c"
4SRC_URI = " \ 4SRC_URI = " \
5 git://github.com/opencontainers/runc;branch=master \ 5 git://github.com/opencontainers/runc;branch=release-1.0 \
6 file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ 6 file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \
7 " 7 "
8RUNC_VERSION = "1.0.0-rc95" 8RUNC_VERSION = "1.0.2"
9 9
10CVE_PRODUCT = "runc" 10CVE_PRODUCT = "runc"