summaryrefslogtreecommitdiffstats
path: root/recipes-networking
diff options
context:
space:
mode:
authorDavid Nyström <david.nystrom@enea.com>2012-12-06 10:58:10 +0100
committerDavid Nyström <david.nystrom@enea.com>2012-12-07 15:32:31 +0100
commit9f60c7d88958a85ceeacaa4383daba92a9ea7848 (patch)
tree4a90f5ad35ef554c27661b479e7a60b1f9455204 /recipes-networking
parent02e4046656f5805751d654e8808500fb884f6fce (diff)
downloadmeta-virtualization-9f60c7d88958a85ceeacaa4383daba92a9ea7848.tar.gz
Added netcf recipe, libvirt dependency
Signed-off-by: David Nyström <david.nystrom@enea.com> Reviewed-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking')
-rw-r--r--recipes-networking/netcf/netcf_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-networking/netcf/netcf_git.bb b/recipes-networking/netcf/netcf_git.bb
new file mode 100644
index 00000000..60fc446d
--- /dev/null
+++ b/recipes-networking/netcf/netcf_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "netcf"
2DESCRIPTION = "netcf is a cross-platform network configuration library."
3HOMEPAGE = "https://fedorahosted.org/netcf/"
4SECTION = "console/tools"
5LICENSE = "LGPLv2.1"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff"
8
9SRCREV = "2b0d9ca226c13d7150382367f62b256bdb2db5ef"
10PR = "r0"
11PV = "0.2.2+git${SRCPV}"
12
13SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git"
14
15DEPENDS += "augeas libnl libxslt libxml2"
16
17S = "${WORKDIR}/git"
18
19inherit gettext autotools
20
21do_configure_prepend() {
22 cd ${S}
23 ./bootstrap
24}
25