diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-12-22 16:35:26 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-01-10 13:58:07 -0500 |
commit | 0874fa6570efababb6b9079acd6ff31721d0d37b (patch) | |
tree | f254512980bec85d18e9e4a4675dfdc36061c1e9 /recipes-networking/openvswitch | |
parent | a969b554a6143da614e401b3230dc55f3b084e23 (diff) | |
download | meta-virtualization-0874fa6570efababb6b9079acd6ff31721d0d37b.tar.gz |
ovs: update to 3.0.3
The linux datapath has been removed, so we drop our kernel_module
patch, as well as the install rules around modules_install.
We refresh one patch, but otherwise, the build is unchanged.
We also pick up the following commits:
7b5c4240c python: Fix datapath flow decoders.
57049862f Prepare for 3.0.4.
726c7b797 Set release date for 3.0.3.
953fa9c40 lldp: Fix bugs when parsing malformed AutoAttach.
982158827 dpif-netdev: Use unmasked key when adding datapath flows.
7aeb7f1ce odp-execute: Add check for L4 header size.
2410b9559 ovsdb-cs: Consider default conditions implicitly acked.
a984a22e5 odp-execute: Fix ipv4 missing clearing of connection tracking fields.
c272928c8 faq: Update some wording since kernel module is already removed.
52b85e54a rculist: Use rculist_back_protected to access prev.
192db0d03 Prepare for 3.0.3.
ea6c986ff Set release date for 3.0.2.
5898bba3d odp-util: Fix reporting unknown keys as keys with bad length.
c47b8fd5a ovs-dpctl-top: Fix ovs-dpctl-top via pipe.
ebf52fd37 rculist: Fix iteration macros.
998fc998f vswitchd: Publish per iface received multicast packets.
0d31e8573 learn: Fix parsing immediate value for a field match.
eccfce96b datapath-windows: Check the condition to reset pseudo header checksum on Rx side
c9c602b6f netdev-offload-dpdk: Enhance the support of tunnel pop action
e3963987a ci: Update meson requirement for DPDK.
4b6c748f8 ovsdb: transaction: Fix weak reference leak.
d78eef089 ovsdb: transaction: Refactor assess_weak_refs.
e17707fcd ovs-tcpdump: Cleanup mirror port on SIGHUP/SIGTERM.
6690ed80c netdev-linux: Fix inability to apply QoS on ports with custom qdiscs.
bfc572f58 tc: Fix misaligned writes while parsing pedit.
89f3dd0c2 odp-util: Add missing separator in format_odp_conntrack_action().
4cdf15787 vswitch.xml: Fix the name of rstp-path-cost option.
02ab8d169 mac-learning: Fix learned fdb entries not age out issue.
ef6da6a8f ofproto-dpif-xlate: Update tunnel neighbor when receive gratuitous ARP.
48f19bdfb bond: Fix crash while logging not yet enabled member.
b41427513 netdev-dpdk: Fix tx_dropped counters value.
c7d9ee706 tc: On last action use drop action attribute instead of pipe
4a2fe9f1e netdev-linux: Allow meter to work in tc software datapath when tc-policy is specified
d2ebceaff Revert "tc: Fix stats dump when using same meter table"
24c5414ec unaligned: Correct the stats of packet_count and byte_count on Windows.
892346cd2 tests: Fix filtering of whole-second durations.
958664218 netdev-offload: Set 'miss_api_supported' to be under netdev.
64b79581b cmap: Add thread fence for slot update.
ae188cf7b ofproto-dpif-xlate: Do not use zero-weight buckets in select groups.
7cbcf3e42 github: Update versions of action dependencies.
c0eb7f652 ovsdb: Fix race for datum JSON string reference counter.
3e2596f19 ovs-tcpdump: Fix bond port unable to capture jumbo frames.
a8e316aee json: Fix deep copy of objects and arrays.
c4bb0d8db Prepare for 3.0.2.
228600969 Set release date for 3.0.1.
50feac16f Add support for OpenSSL 3.0 functions.
61df71366 dhparams: Fix .c file generation with OpenSSL >= 3.0.
446018dfd daemon-unix: Fix file descriptor leak when monitor restarts child.
4cc16e7f9 vconn: Allow ECONNREFUSED in refuse connection test.
92d587a99 dpdk: Use DPDK 21.11.2 release.
d7e3bf2d8 m4: Test avx512 for x86 only.
e379e42d4 ovsdb-idl: Preserve references for rows deleted in same IDL run as their insertion.
a841d55e6 datapath-windows: Correct Geneve IPV6 header checksum parameter
6636fc9ff python: idl: Fix idl.Row.__str__ method.
3bcb21a88 bond: Avoid deadlock while updating post recirculation rules.
97cc13084 ofproto-dpif-upcall: Add debug commands to pause/resume revalidators.
f555cec36 test-list: Fix false-positive build failure with GCC 12.
fc5a49045 tests: Fix tests with GNU grep 3.8.
787648996 tc: Fix stats dump when using same meter table
dcbdadaa5 cirrus: Upgrade to FreeBSD 13.1 image.
02bfa84df netdev-linux: Skip some internal kernel stats gathering.
5737cdcc8 tests: Use _DAEMONIZE macro's to start tcpdump.
bb949d595 ofproto-dpif-xlate: Fix error messages for nonexistent ports/recirc_ids.
ee2254be2 ofproto-dpif-xlate: Optimize datapath action set by removing last clone action.
d5932c8d7 ofproto-dpif-xlate: Clear tunnel wc bits if original packet is non-tunnel.
887b12251 raft: Fix unnecessary periodic compactions.
dbbe4c55e netdev-offload-tc: Parse tunnel options only for geneve ports.
6e8da6fbb netdev-offload-tc: Add missing handling of the tunnel source port.
737d2cb5a netdev-offload-tc: Fix ignoring unknown tunnel keys.
b32bee91d netdev-offload-tc: Use masks instead of keys while parsing tunnel attributes.
417600e68 netdev-offload-tc: Explicitly handle mask for the tunnel destination port.
fafb386a3 netdev-offload-tc: Fix the mask for tunnel metadata length.
1123e5485 Prepare for 3.0.1.
99e0cad9e Set release date for 3.0.0.
2810ab2bf releases: Mark 2.17 as a new LTS release.
de9e4f649 docs: Remove remaining references to OVS kmod and XenServer.
746e11520 handlers: Fix handlers mapping.
a489eb3d2 handlers: Create additional handler threads when using CPU isolation.
aaaebdf2e xenserver: Remove xenserver.
686bdae1e acinclude: Improve vpopcntdq build check.
14d59d8ec packets: Fix misaligned access to ip6_hdr.
ddff8a7e3 python: Do not send non-zero flag for a SSL socket.
112e1c68e ovsdb: Fix copying weak references into transaction history.
2972c18d0 dpif-netdev: Simplify AVX512 build time checks to enhance readability.
16d0fcfa7 github: Move CI to ubuntu 20.04 base image.
50d13fb2b netdev-offload-tc: Disable offload of IPv6 fragments.
bd4a72d28 ovs-save: Use right OpenFlow version for add-tlv-map.
f77c14b63 system-traffic: Fix IPv4 fragmentation test sequence for check-kernel.
ae74f3ffe system-traffic: Fix incorrect neigh entry in ipv6 header modification test.
0c10b785a system-traffic: Don't run IPv6 header modification test on kernels < 5.19.
941c6bda0 python: Fix E275 missing whitespace after keyword.
9fbc79d51 tc: Use sparse hex dump while printing inconsistencies.
bb5a5bacb netdev-offload-tc: Print unused mask bits on failure.
2b53191e1 dynamic-string: Add function for a sparse hex dump.
a78680634 system-offloads-traffic: Fix waiting for netcat indefinitely.
9554bd068 dpif-netlink: Fix incorrect bit shift in compat mode.
33ac6983b python: Use setuptools instead of distutils.
e94b71578 packets: Re-calculate IPv6 checksum only for first frag upon modify.
5ce25c4b7 netdev-linux: set correct action for packets that passed policer
bfb07d6b1 test-ovsdb: Fix false-positive leaks from LeakSanitizer.
7e2a5f8ad m4: Update ax_func_posix_memalign to the latest version.
95ab03020 m4: Replace obsolete AC_HELP_STRING with AS_HELP_STRING.
9c8ea6aca debian: Fix incorrect linkage of the python C extension.
e0b417a03 python: Add ability to pass extra libs and cflags for C extension.
de1decb45 libopenvswitch.pc: Add missing libs for a static build.
13b9fcf7e rhel: Stop installing internal headers.
b4df85397 python-c-ext: Handle initialization failures.
55896a146 netdev-linux: Do not touch LAG members if master is not attached to OVS.
6d0fdae1f netdev: Clear auto_classified if netdev reopened with the type specified.
f8f2c1178 system-offloads-traffic: Avoid check_pkt_len action test random failures.
f62591653 system-traffic: Properly stop dangling ping after geneve test.
13de99ebd conntrack: Fix conntrack multiple new state.
6a75842cd python-c-ext: Fix a couple of build warnings.
e57e91422 python-c-ext: Remove Python 2 support.
b1524cb94 odp-execute: Avoid unnecessary logging for action implementations.
9ee6a71b3 system-dpdk: Add testpmd clean up in MTU unit tests.
384be3d4c netdev-offload-dpdk: Setting RSS hash types in RSS action.
9e83717ef lib: Print nw_frag in flow key.
75ca657b2 ovsdb: Remove extra make target dependency for local-config.5.
6e91000df ci: Prefer pip3 to install unit test dependencies.
e2e8d7cd3 Prepare for 3.0.0.
1b53826d6 ofproto/bond: Add knob 'all-members-active'.
73ba04fd7 python: Add unit tests for filtering engine.
686bb5e72 python: Add unit tests to datapath parsing.
7448cbb4e python: Add unit tests for openflow parsing.
3425d01a9 python: Add unit tests for ListParser.
445dceb88 python: Introduce unit tests.
6a71bc09b python: Add a json encoder to flow fields.
7e588e82f python: Add flow filtering syntax.
076663b31 python: Add ovs datapath flow parsing.
3923b9331 python: Introduce OpenFlow Flow parsing.
1215cf133 python: Add flow base class.
61e040fc2 build-aux: Generate ofp field decoders.
d542f0ea8 build-aux: Split extract-ofp-fields.
7803743a0 python: Add list parser.
dcd17a896 python: Add mask, ip and eth decoders.
12bc968e2 python: Add generic Key-Value parser.
02341a187 systemd-dpdk: Fix typo's and capitalize first word.
bf4782911 tests: Add OVS-DPDK MTU unit tests.
ddaf4fe0e tests: Add OVS-DPDK QoS unit tests
3476bd393 Documentation: Remove kernel module documentation.
dc433e25e acinclude.m4: Remove support for building the OVS kernel module.
422e90437 make: Remove the Linux datapath.
86642de3a tests: Remove support for check-kmod test.
c94ae8a75 rhel: Stop packaging OVS kernel module.
b6941ca7b ci: Stop building OVS kernel module.
16bec677a debian: Add option to build without DPDK.
c78e7efa7 docs: Update package references in debian/ubuntu related docs.
3e31a2daf debian: Fix generation of copyright file.
6ad3be974 debian: Fix build of python json C extension.
671f93fe4 python: Allow building json C extension with static OVS library.
ae262ddf2 ci: Separate job for debs, ensure built pkg is tested.
999032261 debian: Update packaging source from Debian/Ubuntu.
9f4f2bb7d checkpatch: Ignore line length and leading whitespace for debian/*.
02428f715 debian: Archive debian packaging source.
92eb03f7b odp-execute: Add ISA implementation of set_masked IPv4 action
bcfe58543 odp-execute: Add ISA implementation of set_masked ETH
277f2375c odp-execute: Add ISA implementation of push_vlan action.
398f80fff odp-execute: Add ISA implementation of pop_vlan action.
529af6714 odp-execute: Add ISA implementation of actions.
b52e0b396 acinclude: Add configure option to enable actions autovalidator at build time.
1713fc011 odp-execute: Add command to switch action implementation.
eec822761 odp-execute: Add auto validation function for actions.
70b559e97 odp-execute: Add function pointer for pop_vlan action.
95e4a35b0 odp-execute: Add function pointers to odp-execute for different action implementations.
d807a2bb4 AUTHORS: Add Jinjun Gao.
c5553ce2f ovsdb/TODO: Update the list of tasks.
2fc29c427 man: Fix various typos across manual pages.
0443c1557 Fix spelling error exposed in binaries.
70a9f9e96 system-dpdk: Add unit test for user configured mempools.
55ba0e81d system-dpdk: Split ovsdb creation and vswitchd start.
3757e9f8e netdev-dpdk: Add shared mempool config.
eacc544c4 tc: Fix misaligned access while creating pedit actions.
e5162ac42 tc: Fix misaligned access to struct tcf_t for police action.
0d153bffb netdev-linux: Fix leak of a tc police get/del reply.
4dd68ff85 ovsdb: Add missing ovs-thread include.
3cd2cbd68 ovsdb: Prepare snapshot JSON in a separate thread.
485ac63d1 ovsdb: Add lazy-copy support for ovsdb_datum objects.
02dabb21f tests: Add check_pkt_len action test to system-offload-traffic.
492061257 system-offloads-traffic: Properly initialize offload before testing.
e4daf88a4 netdev-offload-tc: Handle check_pkt_len datapath action.
dd03672f7 netdev-offload-tc: Move flower_to_match action handling to isolated function.
64365293a netdev-offload-tc: Move flow_put action handling to isolated function.
b15952590 conntrack: Check for expiration before comparing the keys during the lookup.
78387e88b conntrack: Use an atomic conn expiration value.
3d9c1b855 conntrack: Replace timeout based expiration lists with rculists.
4847baf4a conntrack-tp: Use a cmap to store timeout policies.
6edc278c8 conntrack: Use a cmap to store zone limits.
cfba95158 utilities/bashcomp: Fix incorrect file mode.
23d496ac5 acinclude: Fix double -Werror.
e773140ec ovsdb: Enable memory trimming after compaction by default.
fe7382db6 tests: Add test for later IPv6 fragments nw_proto=44.
5d875809a meta-flow: Document nw_proto limitation for IPv6 later frags.
f32bebc42 dpif-avx512: Add support for simple match lookup.
dfff8b67b dpif-netdev: Refactor simple match lookup functions.
eb8ebf8c4 doc: Add meter offload topic document
5660b89a3 dpif-netlink: Offloading meter to tc police action
218304df1 netdev-offload-tc: Offloading rules with police actions
f6ed09ef5 netdev-offload-tc: Cleanup police actions with reserved indexes on startup
4c226944f netdev-offload-tc: Implement meter offload API for tc
5c039ddc6 netdev-linux: Add functions to manipulate tc police action
ed2300cca netdev-linux: Refactor put police action netlink message
a9b8cdde6 tc: Add support parsing tc police action
922b850f0 netdev-offload: Add meter offload API
0dd409c2a netdev-dpdk: Delay vhost mempool creation.
b80f58cde dpif-netdev/mfex: Add ipv6 profile based hashing.
8cab30a9d dpif-netdev/mfex: Add AVX512 ipv6 traffic profiles.
3e6be8a0a mfex_avx512: Calculate miniflow_bits at compile time.
95be97a5a mfex_avx512: Calculate pkt offsets at compile time.
3a5d05c1e AUTHORS: Add Jeffrey Walton.
7d746f764 util: Update cache line size on PowerPC.
7045e91a9 Pmd.at: fix dpcls and dpif configuration test cases.
e72b05686 tests/mfex: Improve pcap script for mfex tests.
6f24c2bc7 ovsdb: Add Local_Config schema.
603bc853f dpif-netdev: Fix leak of AVX512 DPIF scratch pad.
c8bff848a ofproto-dpif-xlate: No clone when tunnel push is last action.
22ac9d6aa AUTHORS: Add Seamus Ryan.
09a2b8028 tests: Add ovs-dpdk rate limiting unit tests.
e4a2b0109 AUTHORS: Add Ales Musil.
fe171e4f1 dpif-netdev: Refactor AVX512 runtime checks.
6835d4b01 python: Add Python bindings TODO file.
a9ec4e3be ovsdb-server: Log database transactions for user requested tables.
c558f9f1e ovsdb-idl: Get per-database memory usage statistics.
23ed22594 dpif-netdev-extract-avx512: Protect GCC builtin usage.
8c1c447a1 ovs-tcpdump: Default to OVS_RUNDIR if present.
751d05b47 dpcls: Add unlisted alias for subtable lookup command.
cb9ae5f0f ovsdb: Fix memory leak on error path in ovsdb_file_read__().
299050c2d odp-util: Ignore unknown attributes in parse_key_and_mask_to_match().
29a2f1835 ofproto-dpif: Avoid unneccesary backer revalidation.
509c32765 lldp: Fix lldp memory leak.
f1c51be50 ipfix: Trigger revalidation if ipfix options changes.
4e1e1e189 conntrack: Fix incorrect bit shift while hashing nat range.
334d43bc0 packets: Fix misaligned write to MPLS lse.
a2d202bde tc: Fix misaligned access to stats and time values.
499b9d73c odp-util: Fix unaligned access to tunnel id.
888193cec ofpbuf: Fix offsetting a NULL pointer in ofpbuf_reserve.
1dbc3b9f3 drop-stats.at: Fix frequent failures of the recursion too deep test.
d632ad0aa odp_util: Fix parse_key_and_mask_to_match() vlan parsing.
70f81aa23 datapath-windows: Update layers for multiple tunnels processing
bca410283 datapath-windows: Fix GRE/VxLAN/STT Tunnel RX.
88e3ae5d6 ofproto-dpif-xlate: Fix internal CT state for non-recirc traffic.
ca4421851 classifier: Adjust segment boundary to execute prerequisite processing.
c0d7d630b ovs-tcpdump: Fix error when stopping ovs-tcpdump.
165f5fbb5 conntrack: Limit port clash resolution attempts.
c608ace71 conntrack: Remove the IP iterations in nat_get_unique_l4.
071b802c6 checkpatch.py: Add checks for easy-to-misuse APIs.
805e9340d ofproto-dpif: Fix meter use-after-free.
c67941e97 ovs-rcu: Add ovsrcu_barrier.
ba462b358 dpif-netdev: Fix ALB 'rebalance_intvl' max hard limit.
83c0a3647 dpif-netdev: Fix ALB parameters type mismatch.
31dfea34c AUTHORS: Add Michael Phelan.
87ef13b00 dpdk: Use DPDK 21.11.1 release.
cb1c64007 acinclude: Add seperate checks for AVX512 ISA.
fb85ae434 automake.mk: Remove -mavx512dq CFLAG from AVX512 library.
34a77ca70 dpif-netdev-extract: Remove unnecessary compiler targets.
66c85fae3 dpif-netdev-lookup: Fix GCC 5 warning.
90cadf170 dpif-netdev-private-extract: Fix typo VMBI -> VBMI.
2c24daa09 raft: Don't use HMAP_FOR_EACH_SAFE when logging commands.
3ecfaf136 dpif-netdev: Restructure rxq schedule logging.
37ccbd9c9 dpif-netdev: Split function to find lowest loaded PMD thread core.
04e5adfed ovsdb: raft: Fix transaction double commit due to lost leadership.
336d7dd7c dynamic-string: Fix undefined behavior due to offsetting null pointer.
e8f557df3 sha1: Use implementation from openssl if available.
7b3a4c2e8 Revert "odp-util: Always report ODP_FIT_TOO_LITTLE for IGMP."
482abeae5 ofproto-dpif-xlate: Fix netdev native tunnel neigh discovery spa.
c5bcbd58d ovs-router: Expose the ovs_router_get_netdev_source_address function.
743b53622 ofproto-dpif: Trigger revalidation if ct tp changes.
bb78070fc Carefully release NBL in Windows
738c76a50 dpcls: Change info-get function to fetch dpcls usage stats.
da9424ad0 tests: Properly kill ovsdb test processes.
e5d4f011a AUTHORS: Add Han Ding.
8ce7ead8c ovs-save: Get highest ofp version error.
5ec547330 dpif-netdev: Only hash port number when necessary.
d7c0b90fa ci: Add UB Sanitizer.
c8c49a9db netdev-linux: Properly access 32-bit aligned rtnl_link_stats64 structs.
a5cc859a4 ofp-actions: Use aligned structures when decoding ofp actions.
08c3e5e37 ofp-errors: Ensure parsed OFPT_ERROR messages are properly aligned.
933aaf944 ofp-actions: Ensure aligned accesses to masked fields.
471babb81 treewide: Avoid offsetting NULL pointers.
3764f5188 treewide: Fix invalid bit shift operations.
9dd3031d2 Documentation: Fix use of rst verbatim code chunk syntax.
6c5046209 vswitchd.xml: Fix whitespace.
b3bbfc172 utilities: Handle dumping packets in GDB TUI.
dd4d8e34b ofproto-dpif-xlate: Remove mirror assert.
b91025187 Documentation: Clarify QEMU version requirement.
6882c45d4 docs: Note ALLOW_EXPERIMENTAL_API for tunnel offloads.
7e7083cc4 dpif-netdev: Replace loop iterating over packet batch with macro.
8523ee2f8 netdev-dpdk: Fix tx drops statistic for a down netdev.
c896bffd8 netdev-dpdk: Remove a leftover lock annotation.
29b94e12d netdev-dpdk: Refactor the DPDK transmit path.
8c506d372 ofp-monitor: Fix abort on malformed flow update event.
e8515c8cc ovs-monitor-ipsec: Allow custom options per tunnel.
af864cedb dpif-netdev/mfex: Add ipv4 profile based hashing.
dc8082276 netdev-offload-dpdk: Fix ethernet type for VLANs.
9b7ed5f6f netdev-offload-dpdk: Use has_vlan match attribute.
7d3555442 python: idl: Raise AttributeError from uuid_to_row.
218dad97d windows: Fix NEWS and add OVS version in FAQ.
c3e64047d ofp-monitor: Support flow monitoring for OpenFlow 1.3, 1.4+.
d8ab75cd6 ofp-monitor: Extend Flow Monitoring support for OF 1.0-1.2 with Nicira Extensions.
d94cd0d3e ovsdb-idl: Support write-only-changed IDL monitor mode.
b7aaf41eb AUTHORS: Add Thilak Raj Surendra Babu.
c1c8cb8a1 ofproto-dpif-xlate: Clear out vlan flow fields while processing native tunnel.
2080979ae dpif-netdev-avx512: Fix overflow of UINT32_C(1).
5db8aa39d dpif-netdev-avx512: Fix ubsan shift error in bitmasks.
4e3966e64 python: Politely handle misuse of table.condition.
b21e2805d AUTHORS: Add Dincer Beken.
0e0eef533 ofproto-xlate: Fix crash when forwarding packet between legacy_l3 tunnels.
4ea1bb639 system-traffic: Fix fragment reassembly with L3 L4 protocol information.
53b75e91d datapath-windows: Add IPv6 conntrack support on Windows.
96dc66dda cirrus: Update FreeBSD versions.
edb233586 datapath-windows: Add IPv6 Geneve tunnel support in Windows
9d70f4a7c NEWS: Highlight libopenvswitch API change caused by UB fixes.
21b76c774 netdev-offload-tc: Check for ct_state flag combinations that are not offloadable.
d29491eeb python: idl: Set cond_changed to true if condition change requested.
9a67d883d dpif-netdev: Fix dp_netdev_get_pmd() function getting correct core_id.
853a89c4f AUTHORS: Update email for Rosemarie O'Riorden.
2f16123c1 json: Improve string parsing.
3b18b8656 alb.at: Add tests for cross-numa polling.
c591827ec dpif-netdev: Fix PMD auto load balance with pmd-rxq-isolate.
cdc9a196b pmd.at: Add tests for multi non-local numa pmds.
da6ce41d8 dpif-netdev: Fix non-local numa selection for more than two numas.
4b5c3b66a dpif-netdev: Fix typo in function name.
8ff9dec46 AUTHORS: Add Abhiram R N.
7539b4e45 netdev-vport: Register IFINDEX for ERSPAN device.
3a3a76334 signals: Add support for sigdescr_np.
e3de0bd82 python: idl: Set cond_changed to false if last id is zero.
0027b3b46 ofproto-dpif-xlate: Fix NULL pointer dereference in xlate_normal().
efa6f1f2e ofproto/ofproto-dpif: Fix dpif_type for userspace tunnels.
b16270e69 sset: add SHORT version of SAFE loop macros.
7aff8a511 sparse: bump recommended version and include headers.
b54067b24 idlc: support short version of SAFE macros.
d293965d7 rculist: use multi-variable helpers for loop macros.
745c80f52 hindex: remove the next variable in safe loops.
2d4027738 hindex: use multi-variable iterators.
ef3961648 cmap: use multi-variable iterators.
9e56549c2 hmap: use short version of safe loops if possible.
860e69a8c hmap: implement UB-safe hmap pop iterator.
9e8d960a6 hmap: use multi-variable helpers for hmap loops.
e9bf5bffb list: use short version of safe loops if possible.
d4566085e list: use multi-variable helpers for list loops.
5a2940978 util: add helpers to overload SAFE macro.
882689711 util: add safe multi-variable iterators.
187a602fa util: add multi-variable loop iterator macros.
08e9e5337 ovsdb: raft: Fix inability to read the database with DNS host names.
d96d14b14 openvswitch.h: Align uAPI definition with the kernel.
9d8645951 system-traffic.at: Fix flaky DNAT load balancing test.
5f76d0ded Set release date for 2.17.0.
635cb95e0 dpif-netdev: Keep orig_in_port as a field of the flow.
2e2217c12 tests: Fix incorrect usage of OVS_WAIT_UNTIL.
31b467a75 odp-util: Fix output for tc to be equal to kernel.
6d76cfc44 netdev-offload-tc: Fix IP and port ranges in flower returns.
38298a877 netdev-offload-tc: Fix use of ICMP values instead of masks defines.
a03963695 netdev-offload-tc: Always include conntrack information to tc.
db40eb79e netdev-offload-tc: Check for valid netdev ifindex in flow_put.
b4868ee16 netdev-offload-tc: Set the correct VLAN_VID and VLAN_PCP masks.
2bdf5b288 netdev-offload-tc: Add debug logs on tc rule verify failures.
920ec5761 tc: Keep header rewrite actions order.
be93ce40e faq: Update OVS/DPDK version table for OVS 2.15/2.16
c44876b9e system-dpdk: Fix mfex autovalidator tests.
3bd593917 ofp-prop: Silence the 'may be uninitialized' warning.
b1e783dde tests: Ignore log about failing to set NETLINK_EXT_ACK.
8d480c5ce ovsdb-cluster.at: Avoid test failures due to different hashing.
c356f6c0b dpif-netdev: Simplify atomic function pointer stores.
f77dbc1eb ofproto: Use xlate map for uuid lookups.
ba4ec2914 AUTHORS: Add Hongzhi Guo.
b46fd37ab ofproto: Add refcount to ofproto to fix ofproto use-after-free.
7baed8fe6 ovs-monitor-ipsec: Add list-commands command.
a9f5ee119 ofproto-dpif: Trigger revalidation when ipfix config set.
545b64415 conntrack: Prefer dst port range during unique tuple search.
ec85f5325 conntrack: Select correct sport range for well-known origin sport.
10b55282a ipsec: StrongSwan report connection update failures to ovs logs.
7bd08b6c1 AUTHORS: Add Mohammad Heib.
02cff6b2d ipsec: Libreswan report connection failures to ovs logs.
9016592ca netdev-dpdk: Add mempool count in cmd get-mempool-info.
7ed60839d system-tso: Skip encap tests when userspace TSO is enabled.
f34a7626c tc: Fix stats byte count on fragmented packets.
de634e422 compat: Add gen_stats include to define tc hw stats.
015994d37 ovsdb: row: Optimize row updates by applying diffs in-place.
a3e97b1af ovsdb: relay: Add transaction history support.
999ba294f ovsdb: raft: Fix inability to join the cluster after interrupted attempt.
6de8868d1 reconnect: Fix broken inactivity probe if there is no other reason to wake up.
7aaa5b813 datapath-windows: Fix NXM_OF_IP_TOS issue
4f933301f Documentation: Update USDT documentation to include systemtap dependency.
4628be9ff ovsdb-idl: Fix use-after-free when destroying an IDL loop.
31dc72c64 dpif-netdev: Use dp_netdev reference in offload threads.
7d8b6ab64 dpif-netdev: Fix a race condition in deletion of offloaded flows.
a81bb674e dpif-netdev: Move port flush after datapath reconfiguration.
f92e6946d dpif-netdev-dpcls: Make subtable reprobe thread-safe.
5f4dfcccb ci: Fix typo in variable name.
3ffeb03fe dp-packet: Ensure packet base is always non-NULL.
172d8bfed bfd: lldp: stp: Fix misaligned packet field access.
b9e8354d0 ovsdb-idlc: Avoid accessing member within NULL idl index cursors.
b07c2e92e stopwatch: Fix buffer underflow when computing percentiles.
5a9bb85ca dpif-netdev: Fix misaligned access.
8ed26a8be treewide: Don't pass NULL to library functions that expect non-NULL.
989895501 system-traffic.at: Avoid sporadic failures during conntrack IPv6 HTTP/FTP tests.
e969370d3 system-traffic.at: Do not use ranges with broadcast address.
78ff3961c daemon-unix: Close log file in monitor process while waiting on child.
b9cf52070 system-dpdk.at: Add warning log in mfex fuzzy test.
f0a9000ca ofproto: Fix ipfix not always sampling on egress.
96ad83bc7 tc: Fix incorrect TC rule for decap+encap datapath flow.
ab4d3bfbe netdev-dpdk: Update to use RTE_ETH namespace defines.
4f810deab dpif-netdev: fix vlan and ipv4 parsing in avx512
d5453008c ci: Install wheel before installing any other python packages.
f81483ad5 odp-util: Fix tunnel key attr for GTP-U.
28f36edd1 ovsdb-idl: Only process successful txn in ovsdb_idl_loop_run.
97772a9b2 AUTHORS: Add Wan Junjie.
cbcd9ca42 ofproto-dpif-upcall: Fix n_revalidators on upcall show.
33027afd2 acinclude: Detect avx512 vpopcntdq compiler support.
0bca7fa1a Documentation: Fix userspace Tx steering section.
a7f52b7eb vswitchd.xml: Add missing tx-steering PMD option.
53a540e53 ovsdb-idl: ovsdb_idl_loop_destroy must also destroy the committing txn.
712202ff7 ofproto-dpif-xlate: Fix packet drops with decap action on MPLS Multicast.
3ae3e8605 tests: Fix cosmetic errors in system-traffic.at.
5202710a7 python: idl: Clear last_id on reconnect if condition changes in-flight.
c1691ccea ovsdb-cs: Clear last_id on reconnect if condition changes in-flight.
718dc8fca python: idl: Resend requested but not acked conditions when reconnecting.
9632f5551 tests: Add de-serialization check to the json string benchmark.
4056ae487 ofp-flow: Skip flow reply if it exceeds the maximum message size.
77967b53f conntrack: Check TCP state while testing established connections pick up.
6e13565dd ovsdb: transaction: Keep one entry in the transaction history.
3a05c6370 ovsdb-cs: Fix ignoring of the last id from the initial monitor reply.
dadd8357f ofproto-dpif: Fix issue with non-reversible actions on a patch ports.
0a395a52d NEWS: Fix some typo.
5b3bb16b8 ovs-monitor-ipsec: Fix generated strongSwan ipsec.conf for IPv6.
8723063c3 system-dpdk: Fix MFEX logs check.
0506efbd0 datapath-windows: Pickup Ct tuple as CT lookup key in function OvsCtSetupLookupCtx
c6f0b623e Prepare for post-2.17.0 (2.17.90).
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-networking/openvswitch')
4 files changed, 9 insertions, 43 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch index 711a1487..ce1f6501 100644 --- a/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch +++ b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch | |||
@@ -9,11 +9,11 @@ Signed-off-by: Amy Fong <amy.fong@windriver.com> | |||
9 | Makefile.am | 2 +- | 9 | Makefile.am | 2 +- |
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | 10 | 1 file changed, 1 insertion(+), 1 deletion(-) |
11 | 11 | ||
12 | diff --git a/Makefile.am b/Makefile.am | 12 | Index: git/Makefile.am |
13 | index ff7d70a..2fc1f13 100644 | 13 | =================================================================== |
14 | --- a/Makefile.am | 14 | --- git.orig/Makefile.am |
15 | +++ b/Makefile.am | 15 | +++ git/Makefile.am |
16 | @@ -187,7 +187,7 @@ CLEAN_LOCAL += clean-pycov | 16 | @@ -194,7 +194,7 @@ |
17 | 17 | ||
18 | # If we're checked out from a Git repository, make sure that every | 18 | # If we're checked out from a Git repository, make sure that every |
19 | # file that is in Git is distributed. | 19 | # file that is in Git is distributed. |
@@ -21,4 +21,4 @@ index ff7d70a..2fc1f13 100644 | |||
21 | +# ALL_LOCAL += dist-hook-git | 21 | +# ALL_LOCAL += dist-hook-git |
22 | dist-hook-git: distfiles | 22 | dist-hook-git: distfiles |
23 | @if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \ | 23 | @if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \ |
24 | (cd datapath && $(MAKE) distfiles); \ | 24 | (cd $(srcdir) && git ls-files) | grep -v '\.gitignore$$' | \ |
diff --git a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch b/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch deleted file mode 100644 index 5e5a38d9..00000000 --- a/recipes-networking/openvswitch/openvswitch-git/kernel_module.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 9b7fb1346702d59af67435487254ef35940bc16a Mon Sep 17 00:00:00 2001 | ||
2 | From: "Hongzhi.Song" <hongzhi.song@windriver.com> | ||
3 | Date: Wed, 23 Jan 2019 03:41:30 -0500 | ||
4 | Subject: [PATCH] datapatch/linux: Specify install path for kernel module | ||
5 | |||
6 | Signed-off-by: Amy Fong <amy.fong@windriver.com> | ||
7 | Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> | ||
8 | --- | ||
9 | datapath/linux/Makefile.main.in | 4 ++-- | ||
10 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
11 | |||
12 | diff --git a/datapath/linux/Makefile.main.in b/datapath/linux/Makefile.main.in | ||
13 | index 328bbfb..6dcc8d0 100644 | ||
14 | --- a/datapath/linux/Makefile.main.in | ||
15 | +++ b/datapath/linux/Makefile.main.in | ||
16 | @@ -71,8 +71,8 @@ default: | ||
17 | $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules | ||
18 | |||
19 | modules_install: | ||
20 | - $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install | ||
21 | - /sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` | ||
22 | + $(MAKE) -C $(KSRC) $(if @KARCH@,ARCH=@KARCH@) M=$(builddir) modules_install INSTALL_MOD_PATH=${INSTALL_MOD_PATH} | ||
23 | + #/sbin/depmod `sed -n 's/#define UTS_RELEASE "\([^"]*\)"/\1/p' $(KSRC)/include/generated/utsrelease.h` | ||
24 | endif | ||
25 | |||
26 | # Much of the kernel build system in this file is derived from Intel's | ||
27 | -- | ||
28 | 2.8.1 | ||
29 | |||
diff --git a/recipes-networking/openvswitch/openvswitch.inc b/recipes-networking/openvswitch/openvswitch.inc index e6c9091a..767a41e6 100644 --- a/recipes-networking/openvswitch/openvswitch.inc +++ b/recipes-networking/openvswitch/openvswitch.inc | |||
@@ -132,7 +132,6 @@ do_install:append() { | |||
132 | install -d ${D}/usr/share/openvswitch/scripts/ | 132 | install -d ${D}/usr/share/openvswitch/scripts/ |
133 | install -m 755 ${S}/rhel/usr_share_openvswitch_scripts_ovs-systemd-reload ${D}/usr/share/openvswitch/scripts/ovs-systemd-reload | 133 | install -m 755 ${S}/rhel/usr_share_openvswitch_scripts_ovs-systemd-reload ${D}/usr/share/openvswitch/scripts/ovs-systemd-reload |
134 | 134 | ||
135 | oe_runmake modules_install INSTALL_MOD_PATH=${D}${root_prefix} | ||
136 | install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages | 135 | install -d ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages |
137 | cp -r ${S}/python/ovstest/ ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages/ | 136 | cp -r ${S}/python/ovstest/ ${D}${libdir}/python${PYTHON_BASEVERSION}/site-packages/ |
138 | } | 137 | } |
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb index f5d85f3f..925444e0 100644 --- a/recipes-networking/openvswitch/openvswitch_git.bb +++ b/recipes-networking/openvswitch/openvswitch_git.bb | |||
@@ -14,17 +14,16 @@ RDEPENDS:${PN}-ptest += "\ | |||
14 | " | 14 | " |
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | PV = "2.17.1+${SRCPV}" | 17 | PV = "3.0.3+${SRCPV}" |
18 | CVE_VERSION = "2.17.1" | 18 | CVE_VERSION = "2.17.1" |
19 | 19 | ||
20 | FILESEXTRAPATHS:append := "${THISDIR}/${PN}-git:" | 20 | FILESEXTRAPATHS:append := "${THISDIR}/${PN}-git:" |
21 | 21 | ||
22 | SRCREV = "41bb202fb37f184b0a8820a029c62d03c118614e" | 22 | SRCREV = "7b5c4240c1ed5f38e476cf08819869dc14f55e8a" |
23 | SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-2.17 \ | 23 | SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-3.0 \ |
24 | file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \ | 24 | file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \ |
25 | file://run-ptest \ | 25 | file://run-ptest \ |
26 | file://disable_m4_check.patch \ | 26 | file://disable_m4_check.patch \ |
27 | file://kernel_module.patch \ | ||
28 | file://systemd-update-tool-paths.patch \ | 27 | file://systemd-update-tool-paths.patch \ |
29 | file://systemd-create-runtime-dirs.patch \ | 28 | file://systemd-create-runtime-dirs.patch \ |
30 | " | 29 | " |
@@ -52,6 +51,3 @@ do_install_ptest() { | |||
52 | oe_runmake test-install | 51 | oe_runmake test-install |
53 | } | 52 | } |
54 | 53 | ||
55 | do_install:append() { | ||
56 | oe_runmake modules_install INSTALL_MOD_PATH=${D}${root_prefix} | ||
57 | } | ||