diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2013-06-26 11:21:54 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-06-27 13:40:41 -0400 |
commit | b6dc9613cda67df165e6d0a058e82ccb33282a1d (patch) | |
tree | ef77b96b1efd74a8fe31e29ef3b5bb7761113d25 /recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch | |
parent | 1fd6f2aa87c743f74e2eca24ad23101586a0103c (diff) | |
download | meta-virtualization-b6dc9613cda67df165e6d0a058e82ccb33282a1d.tar.gz |
openvswitch: add split between host and target python and perl paths
Openvswitch is built with the assumption that the PYTHON and PERL
variables are common between the host and target. This can result in
improper paths used for script substitutions which in turn causes
scripts which will fail to run on the target and the generated
packages to have improper REQUIRES, making them impossible to
install. These are usually not an issue since python and perl are
found in the same location on the host and target, but there is no
guarantee of this so the possibility of failure exists. By explicitly
defining the location of the python and perl on the target we can
avoid these assumptions and possibility of failure.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch')
-rw-r--r-- | recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch new file mode 100644 index 00000000..35a3d5b3 --- /dev/null +++ b/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch | |||
@@ -0,0 +1,61 @@ | |||
1 | From 569ac1066cd3046b8ac899153df9f07908d45145 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Fri, 21 Jun 2013 11:16:00 -0400 | ||
4 | Subject: [PATCH] openvswitch: add target perl handling | ||
5 | |||
6 | Allow the build to specify a path for the perl instead of reusing | ||
7 | the PERL variable which can lead to inconsistencies if we are cross | ||
8 | compiling. The TARGET_PERL variable will be used for script | ||
9 | substitutions to ensure the scripts will be able to properly execute | ||
10 | if the target system has a different path for the perl. | ||
11 | |||
12 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
13 | --- | ||
14 | Makefile.am | 1 + | ||
15 | configure.ac | 7 +++++++ | ||
16 | utilities/ovs-parse-leaks.in | 2 +- | ||
17 | 3 files changed, 9 insertions(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/Makefile.am b/Makefile.am | ||
20 | index c4f8341..45488f2 100644 | ||
21 | --- a/Makefile.am | ||
22 | +++ b/Makefile.am | ||
23 | @@ -111,6 +111,7 @@ SUFFIXES += .in | ||
24 | -e 's,[@]LOGDIR[@],$(LOGDIR),g' \ | ||
25 | -e 's,[@]DBDIR[@],$(DBDIR),g' \ | ||
26 | -e 's,[@]PERL[@],$(PERL),g' \ | ||
27 | + -e 's,[@]TARGET_PERL[@],$(TARGET_PERL),g' \ | ||
28 | -e 's,[@]PYTHON[@],$(PYTHON),g' \ | ||
29 | -e 's,[@]TARGET_PYTHON[@],$(TARGET_PYTHON),g' \ | ||
30 | -e 's,[@]RUNDIR[@],$(RUNDIR),g' \ | ||
31 | diff --git a/configure.ac b/configure.ac | ||
32 | index 74cb691..5e39893 100644 | ||
33 | --- a/configure.ac | ||
34 | +++ b/configure.ac | ||
35 | @@ -101,6 +101,13 @@ AC_ARG_VAR(KARCH, [Kernel Architecture String]) | ||
36 | AC_SUBST(KARCH) | ||
37 | OVS_CHECK_LINUX | ||
38 | |||
39 | +if test "$TARGET_PERL"; then | ||
40 | + TARGET_PERL=$TARGET_PERL | ||
41 | +else | ||
42 | + TARGET_PERL=$PERL | ||
43 | +fi | ||
44 | +AC_SUBST(TARGET_PERL) | ||
45 | + | ||
46 | if test "$TARGET_PYTHON"; then | ||
47 | TARGET_PYTHON=$TARGET_PYTHON | ||
48 | else | ||
49 | diff --git a/utilities/ovs-parse-leaks.in b/utilities/ovs-parse-leaks.in | ||
50 | index 72417e5..7c9436c 100755 | ||
51 | --- a/utilities/ovs-parse-leaks.in | ||
52 | +++ b/utilities/ovs-parse-leaks.in | ||
53 | @@ -1,4 +1,4 @@ | ||
54 | -#! @PERL@ | ||
55 | +#! @TARGET_PERL@ | ||
56 | |||
57 | # Copyright (c) 2009, 2010 Nicira, Inc. | ||
58 | # | ||
59 | -- | ||
60 | 1.8.1.2 | ||
61 | |||