summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2022-07-18 16:15:47 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-07-20 16:04:53 -0400
commitfb52b8d574b07c85d629b3b637d8fdadf0079c45 (patch)
treeb27d211a92c75425395b29f5f750387126859b3d /recipes-extended
parent7ec4b4746d9d76062a868ea77818a150ddd53c54 (diff)
downloadmeta-virtualization-fb52b8d574b07c85d629b3b637d8fdadf0079c45.tar.gz
xen-image-minimal: reduce the x86 wic build dependencies
The Xen image recipe provides a default WKS_FILE for x86 builds to enable booting the image either in qemu or directly on hardware. Add settings for WKS_FILE_DEFAULT_DEPENDS that specify the wic image build dependencies, which are lower than the defaults used without it. This change reduces the amount of build resources required for CI of this image and images that are derived from it. Since WKS_FILE is specified separately for x86-64 and qemux86-64 overrides, do the same for WKS_FILE_DEFAULT_DEPENDS, even though the dependencies for the two separate WKS_FILEs are currently the same. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/images/xen-image-minimal.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index 9fd05d2a..7f1acbfe 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -83,7 +83,9 @@ build_syslinux_cfg () {
83 83
84# Enable runqemu. eg: runqemu xen-image-minimal nographic slirp 84# Enable runqemu. eg: runqemu xen-image-minimal nographic slirp
85WKS_FILE:x86-64 = "directdisk-xen.wks" 85WKS_FILE:x86-64 = "directdisk-xen.wks"
86WKS_FILE_DEPENDS_DEFAULT:x86-64 = "syslinux-native"
86WKS_FILE:qemux86-64 = "qemuboot-xen-x86-64.wks" 87WKS_FILE:qemux86-64 = "qemuboot-xen-x86-64.wks"
88WKS_FILE_DEPENDS_DEFAULT:qemux86-64 = "syslinux-native"
87QB_MEM ?= "-m 400" 89QB_MEM ?= "-m 400"
88QB_DEFAULT_KERNEL ?= "none" 90QB_DEFAULT_KERNEL ?= "none"
89QB_DEFAULT_FSTYPE ?= "wic" 91QB_DEFAULT_FSTYPE ?= "wic"