diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-03-29 09:50:52 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-03-29 10:04:49 -0400 |
commit | c77f64d10075cba0cd01ed3e1f4ed32be1f17e2b (patch) | |
tree | edd1ba07e1690f37b75d2146a20770c22b396bc0 /recipes-extended | |
parent | cd8f8873a0d6fbdc0886b3dd6a24fd4ae46c470d (diff) | |
download | meta-virtualization-c77f64d10075cba0cd01ed3e1f4ed32be1f17e2b.tar.gz |
kvmtool: update to -tip
Bumping kvmtool to latest, which comprises the following commits:
faae833 Revert "kvm tools: Filter out CPU vendor string"
1b76b6e Add --no-pvtime command line argument
7d4671e aarch64: Add stolen time support
ff69582 aarch64: Populate the vCPU struct before target->init()
95f4796 arm: pci: Generate "msi-parent" property only with a MSI controller
c334a68 arm: Use pr_debug() to print memory layout when loading a firmware image
9b681b0 Remove initrd magic check
2108c86 virtio/pci: Signal INTx interrupts as level instead of edge
20b93be x86: Set the correct APIC ID
d4d6f15 x86: Fix initialization of irq mptable
cdd7d8c riscv: Generate PCI host DT node
721da16 riscv: Handle SBI calls forwarded to user space
7c9aac0 riscv: Generate FDT at runtime for Guest/VM
762224e riscv: Add PLIC device emulation
42bfe44 riscv: Implement Guest/VM VCPU arch functions
867159a riscv: Implement Guest/VM arch functions
2e99678 riscv: Initial skeletal support
5968b5f update_headers: Sync-up ABI headers with Linux-5.16-rc1
642f35b Makefile: Calculate the correct kvmtool version
7a60af0 arm/pci: update interrupt-map only for legacy interrupts
39181fc vfio/pci: Align MSIX Table and PBA size to guest maximum page size
b20d6e3 vfio/pci: Print an error when offset is outside of the MSIX table or PBA
f93acc0 vfio/pci: Rework MSIX table and PBA physical size allocation
5f44d5d vfio/pci: Rename PBA offset in device descriptor to fd_offset
34bfe5f pci: Fix pci_dev_* print macros
3d3dca0 vfio/pci.c: Remove double include for assert.h
e3b0ade arm/gicv2m: Set errno when gicv2_update_routing() fails
dc66461 arm64: Be more permissive when parsing the kernel header
5303f09 arm64: Use the default offset when the kernel image magic is not found
5613ae2 Add --nodefaults command line argument
a5253f7 builtin-run: Move kernel command line generation to a separate function
39ab3a0 Use kvm->nr_disks instead of kvm->cfg.image_count
cce9616 builtin-run: Abstract argument validation into a separate function
638630c builtin-run: Do not attempt to find vmlinux if --firmware
6cbec43 builtin-run: Warn when ignoring initrd because --firmware was specified
6810e75 builtin-run: Treat specifying both --kernel and --firmware as an error
2e7380d virtio/pci: Size the MSI-X bar according to the number of MSI-X
bdb86d0 kvmtool: arm64: Configure VM with the minimal required IPA space
066b5c0 kvmtool: arm64: Use the maximum supported IPA size when creating the VM
4250819 kvmtool: Abstract KVM_VM_TYPE into a weak function
25c1dc6 arm/arm64: vfio: Add PCI Express Capability Structure
e69b766 arm/arm64: Add PCI Express 1.1 support
6b74f68 arm/fdt.c: Don't generate the node if generator function is NULL
070fb91 Move fdt_irq_fn typedef to fdt.h
415f92c arm: Fail early if KVM_CAP_ARM_PMU_V3 is not supported
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
5 files changed, 11 insertions, 11 deletions
diff --git a/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch b/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch index 4582285b..bad83b2a 100644 --- a/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch +++ b/recipes-extended/kvmtool/files/0001-kvmtool-9p-fixed-compilation-error.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 6b864b05b7aea74f375502250e99f54564cfe829 Mon Sep 17 00:00:00 2001 | 1 | From e04b44c12402494ef5619205bfff03dab3e3d9cb Mon Sep 17 00:00:00 2001 |
2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> | 2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> |
3 | Date: Sun, 5 Nov 2017 12:39:52 +0100 | 3 | Date: Sun, 5 Nov 2017 12:39:52 +0100 |
4 | Subject: [PATCH] kvmtool: 9p: fixed compilation error | 4 | Subject: [PATCH] kvmtool: 9p: fixed compilation error |
diff --git a/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch b/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch index dbb2bebe..dde452d9 100644 --- a/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch +++ b/recipes-extended/kvmtool/files/0002-kvmtool-add-EXTRA_CFLAGS-variable.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 80eb205fd165072724a6e6db1dff8ab0bf2aa667 Mon Sep 17 00:00:00 2001 | 1 | From a1c255983169e094c18d82131939b2b66e581000 Mon Sep 17 00:00:00 2001 |
2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> | 2 | From: Dariusz Pelowski <dariusz.pelowski@gmail.com> |
3 | Date: Sun, 5 Nov 2017 12:39:21 +0100 | 3 | Date: Sun, 5 Nov 2017 12:39:21 +0100 |
4 | Subject: [PATCH] kvmtool: add EXTRA_CFLAGS variable | 4 | Subject: [PATCH] kvmtool: add EXTRA_CFLAGS variable |
@@ -13,7 +13,7 @@ Signed-off-by: Dariusz Pelowski <dariusz.pelowski@gmail.com> | |||
13 | 1 file changed, 2 insertions(+) | 13 | 1 file changed, 2 insertions(+) |
14 | 14 | ||
15 | diff --git a/Makefile b/Makefile | 15 | diff --git a/Makefile b/Makefile |
16 | index 3787df2..ece3d2a 100644 | 16 | index c05b2c0..2ce753f 100644 |
17 | --- a/Makefile | 17 | --- a/Makefile |
18 | +++ b/Makefile | 18 | +++ b/Makefile |
19 | @@ -2,6 +2,8 @@ | 19 | @@ -2,6 +2,8 @@ |
diff --git a/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch b/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch index 7b1b7f6f..1695ac49 100644 --- a/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch +++ b/recipes-extended/kvmtool/files/0003-kvmtool-Werror-disabled.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 532043e6937b78b12d89d0c6001f0e1853143247 Mon Sep 17 00:00:00 2001 | 1 | From 459ebaebf368869ae26eb8031ff44a789e238988 Mon Sep 17 00:00:00 2001 |
2 | From: Cevat Bostancioglu <bostancioglucevat@gmail.com> | 2 | From: Cevat Bostancioglu <bostancioglucevat@gmail.com> |
3 | Date: Wed, 19 Jun 2019 20:36:56 +0300 | 3 | Date: Wed, 19 Jun 2019 20:36:56 +0300 |
4 | Subject: [PATCH] WERROR override disabled. | 4 | Subject: [PATCH] WERROR override disabled. |
@@ -10,7 +10,7 @@ WERROR override causes gcc sizeof-pointer-memaccess, format-truncation errors. | |||
10 | 1 file changed, 1 insertion(+) | 10 | 1 file changed, 1 insertion(+) |
11 | 11 | ||
12 | diff --git a/Makefile b/Makefile | 12 | diff --git a/Makefile b/Makefile |
13 | index ece3d2a..da6c1f0 100644 | 13 | index 2ce753f..fe2e3cb 100644 |
14 | --- a/Makefile | 14 | --- a/Makefile |
15 | +++ b/Makefile | 15 | +++ b/Makefile |
16 | @@ -4,6 +4,7 @@ | 16 | @@ -4,6 +4,7 @@ |
diff --git a/recipes-extended/kvmtool/files/external-crosscompiler.patch b/recipes-extended/kvmtool/files/external-crosscompiler.patch index ab030c73..b8780245 100644 --- a/recipes-extended/kvmtool/files/external-crosscompiler.patch +++ b/recipes-extended/kvmtool/files/external-crosscompiler.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b89ba4256cb6074aee74ea5386bc5ca8e75d4653 Mon Sep 17 00:00:00 2001 | 1 | From 91b7123682c67ec8b0c50147c9ebd59efa563f26 Mon Sep 17 00:00:00 2001 |
2 | From: Stefan Agner <stefan@agner.ch> | 2 | From: Stefan Agner <stefan@agner.ch> |
3 | Date: Tue, 6 Sep 2016 11:51:40 -0700 | 3 | Date: Tue, 6 Sep 2016 11:51:40 -0700 |
4 | Subject: [PATCH] kvmtool: add lightweight hypervisor native Linux KVM tool | 4 | Subject: [PATCH] kvmtool: add lightweight hypervisor native Linux KVM tool |
@@ -14,12 +14,12 @@ be linked against the cross-compiled libfdt library. | |||
14 | 1 file changed, 1 insertion(+), 7 deletions(-) | 14 | 1 file changed, 1 insertion(+), 7 deletions(-) |
15 | 15 | ||
16 | diff --git a/Makefile b/Makefile | 16 | diff --git a/Makefile b/Makefile |
17 | index 35bb118..3787df2 100644 | 17 | index e9121dc..c05b2c0 100644 |
18 | --- a/Makefile | 18 | --- a/Makefile |
19 | +++ b/Makefile | 19 | +++ b/Makefile |
20 | @@ -18,12 +18,6 @@ export E Q | 20 | @@ -19,12 +19,6 @@ include config/utilities.mak |
21 | include config/utilities.mak | ||
22 | include config/feature-tests.mak | 21 | include config/feature-tests.mak |
22 | -include $(OUTPUT)KVMTOOLS-VERSION-FILE | ||
23 | 23 | ||
24 | -CC := $(CROSS_COMPILE)gcc | 24 | -CC := $(CROSS_COMPILE)gcc |
25 | -CFLAGS := | 25 | -CFLAGS := |
@@ -30,7 +30,7 @@ index 35bb118..3787df2 100644 | |||
30 | FIND := find | 30 | FIND := find |
31 | CSCOPE := cscope | 31 | CSCOPE := cscope |
32 | TAGS := ctags | 32 | TAGS := ctags |
33 | @@ -319,7 +313,7 @@ $(warning No static libc found. Skipping guest init) | 33 | @@ -343,7 +337,7 @@ $(warning No static libc found. Skipping guest init) |
34 | endif | 34 | endif |
35 | 35 | ||
36 | ifeq (y,$(ARCH_WANT_LIBFDT)) | 36 | ifeq (y,$(ARCH_WANT_LIBFDT)) |
diff --git a/recipes-extended/kvmtool/kvmtool.bb b/recipes-extended/kvmtool/kvmtool.bb index 33d156a6..b125b645 100644 --- a/recipes-extended/kvmtool/kvmtool.bb +++ b/recipes-extended/kvmtool/kvmtool.bb | |||
@@ -16,7 +16,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/will/kvmtool.git;branch | |||
16 | file://0003-kvmtool-Werror-disabled.patch \ | 16 | file://0003-kvmtool-Werror-disabled.patch \ |
17 | " | 17 | " |
18 | 18 | ||
19 | SRCREV = "415f92c33a227c02f6719d4594af6fad10f07abf" | 19 | SRCREV = "faae833a746f1c59f64fb05e9c08e62b5b0002eb" |
20 | PV = "5.10.0+git${SRCPV}" | 20 | PV = "5.10.0+git${SRCPV}" |
21 | 21 | ||
22 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |