diff options
author | Ross Burton <ross.burton@arm.com> | 2022-04-29 13:11:35 +0100 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-05-02 14:07:30 -0400 |
commit | 8386caefb7449f9b53e646c2e2cb1ba8bef6faa6 (patch) | |
tree | 89df9ea08bdc8aaf5edc92d62acc65f83d7fa4cb /recipes-extended | |
parent | 36433bfef3b690ee1211f04a38022b1f3dc2b383 (diff) | |
download | meta-virtualization-8386caefb7449f9b53e646c2e2cb1ba8bef6faa6.tar.gz |
vgabios: upgrade to 0.8a and cleanup recipe
Upgrade to 0.8a.
License checksum updated as the FSF street address changed.
Apply a patch to use the correct host compiler when building biossums,
removing the need for a separate biossums-native recipe.
Don't hardcode /usr/share, use ${datadir}.
Install all found firmware (including the new Banshee BIOS in 0.8a) and
the debug files which were not installed but intended to be packaged.
Remove redundant PR and S assignments, as these are the default values.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/vgabios/biossums_0.7a.bb | 37 | ||||
-rw-r--r-- | recipes-extended/vgabios/files/build-cc.patch | 30 | ||||
-rw-r--r-- | recipes-extended/vgabios/vgabios_0.7a.bb | 33 | ||||
-rw-r--r-- | recipes-extended/vgabios/vgabios_0.8a.bb | 25 |
4 files changed, 55 insertions, 70 deletions
diff --git a/recipes-extended/vgabios/biossums_0.7a.bb b/recipes-extended/vgabios/biossums_0.7a.bb deleted file mode 100644 index 95483fff..00000000 --- a/recipes-extended/vgabios/biossums_0.7a.bb +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | DESCRIPTION = "biossums tool for building Plex86/Bochs LGPL VGABios" | ||
2 | HOMEPAGE = "http://www.nongnu.org/vgabios/" | ||
3 | LICENSE = "LGPL-2.1-only" | ||
4 | SECTION = "firmware" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589" | ||
7 | |||
8 | SRC_URI = "http://savannah.gnu.org/download/vgabios/vgabios-${PV}.tgz" | ||
9 | |||
10 | SRC_URI[md5sum] = "2c0fe5c0ca08082a9293e3a7b23dc900" | ||
11 | SRC_URI[sha256sum] = "9d24c33d4bfb7831e2069cf3644936a53ef3de21d467872b54ce2ea30881b865" | ||
12 | |||
13 | BBCLASSEXTEND = "native" | ||
14 | |||
15 | FILES:${PN} = "${bindir}/biossums" | ||
16 | |||
17 | S = "${WORKDIR}/vgabios-${PV}" | ||
18 | |||
19 | do_configure() { | ||
20 | # Don't override the compiler or its flags: | ||
21 | sed 's,^CC,DISABLED_CC,' -i Makefile | ||
22 | sed 's,^CFLAGS,DISABLED_CFLAGS,' -i Makefile | ||
23 | sed 's,^LDFLAGS,DISABLED_LDFLAGS,' -i Makefile | ||
24 | # Supply the C flags to the compiler: | ||
25 | sed 's,-o biossums,$(CFLAGS) -o biossums,' -i Makefile | ||
26 | } | ||
27 | |||
28 | do_compile() { | ||
29 | # clean removes binaries distributed with source | ||
30 | oe_runmake clean | ||
31 | oe_runmake biossums | ||
32 | } | ||
33 | |||
34 | do_install() { | ||
35 | mkdir -p "${D}${bindir}" | ||
36 | install -m 0755 biossums "${D}${bindir}" | ||
37 | } | ||
diff --git a/recipes-extended/vgabios/files/build-cc.patch b/recipes-extended/vgabios/files/build-cc.patch new file mode 100644 index 00000000..b64e5efd --- /dev/null +++ b/recipes-extended/vgabios/files/build-cc.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | Use the host compiler to build the tools we need at runtime. | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
5 | |||
6 | Index: Makefile | ||
7 | =================================================================== | ||
8 | --- a/Makefile (revision 298) | ||
9 | +++ b/Makefile (working copy) | ||
10 | @@ -5,6 +5,7 @@ | ||
11 | SHELL = /bin/sh | ||
12 | |||
13 | CC = gcc | ||
14 | +HOSTCC = gcc | ||
15 | CFLAGS = -g -O2 -Wall -Wstrict-prototypes | ||
16 | LDFLAGS = | ||
17 | |||
18 | @@ -79,10 +80,10 @@ | ||
19 | tar czvf ../$(RELEASE).tgz --exclude .svn -C .. $(RELEASE)/ | ||
20 | |||
21 | biossums: biossums.c | ||
22 | - $(CC) -o biossums biossums.c | ||
23 | + $(HOSTCC) -o biossums biossums.c | ||
24 | |||
25 | vbetables-gen: vbetables-gen.c | ||
26 | - $(CC) -o vbetables-gen vbetables-gen.c | ||
27 | + $(HOSTCC) -o vbetables-gen vbetables-gen.c | ||
28 | |||
29 | vbetables.h: vbetables-gen | ||
30 | ./vbetables-gen > $@ | ||
diff --git a/recipes-extended/vgabios/vgabios_0.7a.bb b/recipes-extended/vgabios/vgabios_0.7a.bb deleted file mode 100644 index f443aed8..00000000 --- a/recipes-extended/vgabios/vgabios_0.7a.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | DESCRIPTION = "Plex86/Bochs LGPL VGABios" | ||
2 | HOMEPAGE = "http://www.nongnu.org/vgabios/" | ||
3 | LICENSE = "LGPL-2.1-only" | ||
4 | SECTION = "firmware" | ||
5 | |||
6 | DEPENDS = "dev86-native biossums-native" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=dcf3c825659e82539645da41a7908589" | ||
9 | |||
10 | SRC_URI = "http://savannah.gnu.org/download/vgabios/${BPN}-${PV}.tgz" | ||
11 | |||
12 | SRC_URI[md5sum] = "2c0fe5c0ca08082a9293e3a7b23dc900" | ||
13 | SRC_URI[sha256sum] = "9d24c33d4bfb7831e2069cf3644936a53ef3de21d467872b54ce2ea30881b865" | ||
14 | |||
15 | PR = "r0" | ||
16 | |||
17 | FILES:${PN} = "/usr/share/firmware/${PN}-${PV}*.bin" | ||
18 | FILES:${PN}-dbg = "/usr/share/firmware/${PN}-${PV}*.debug.bin" | ||
19 | |||
20 | S = "${WORKDIR}/${PN}-${PV}" | ||
21 | |||
22 | do_configure() { | ||
23 | # Override to use the native-built biossums tool: | ||
24 | sed 's,./biossums,biossums,' -i Makefile | ||
25 | sed 's,$(CC) -o biossums biossums.c,touch biossums,' -i Makefile | ||
26 | } | ||
27 | |||
28 | do_install() { | ||
29 | install -d ${D}/usr/share/firmware | ||
30 | install -m 0644 VGABIOS-lgpl-latest.bin ${D}/usr/share/firmware/${PN}-${PV}.bin | ||
31 | install -m 0644 VGABIOS-lgpl-latest.cirrus.bin ${D}/usr/share/firmware/${PN}-${PV}.cirrus.bin | ||
32 | } | ||
33 | |||
diff --git a/recipes-extended/vgabios/vgabios_0.8a.bb b/recipes-extended/vgabios/vgabios_0.8a.bb new file mode 100644 index 00000000..044bb4ec --- /dev/null +++ b/recipes-extended/vgabios/vgabios_0.8a.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | DESCRIPTION = "Plex86/Bochs LGPL VGABios" | ||
2 | HOMEPAGE = "http://www.nongnu.org/vgabios/" | ||
3 | LICENSE = "LGPL-2.1-only" | ||
4 | SECTION = "firmware" | ||
5 | |||
6 | DEPENDS = "dev86-native" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=fae731a3adbc92fd8bb1730d1f2455bc" | ||
9 | |||
10 | SRC_URI = "http://savannah.gnu.org/download/vgabios/${BP}.tgz \ | ||
11 | file://build-cc.patch" | ||
12 | SRC_URI[sha256sum] = "481042240ef0f1c918780c92a6bb42ad4d3f5d989b29502fa7ee7faf13a041b9" | ||
13 | |||
14 | EXTRA_OEMAKE = "HOSTCC="${BUILD_CC}"" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}${datadir}/firmware | ||
18 | for file in VGABIOS*.bin; do | ||
19 | target=$(echo $file | sed s/VGABIOS-lgpl-latest/${BP}/) | ||
20 | install -m0644 $file ${D}${datadir}/firmware/$target | ||
21 | done | ||
22 | } | ||
23 | |||
24 | FILES:${PN} = "${datadir}/firmware/${BP}*.bin" | ||
25 | FILES:${PN}-dbg = "${datadir}/firmware/${BP}*.debug.bin" | ||