diff options
author | Doug Goldstein <cardoe@cardoe.com> | 2016-01-26 13:09:21 -0600 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2016-02-01 00:11:35 -0500 |
commit | 5817c4a29b361812b87eddb2bbb623344dccbdc2 (patch) | |
tree | fa4d75d4f59cc985d31638b64890e756588d3c07 /recipes-extended/xen | |
parent | a19e5567dc9f34d0c52fdb40544f82bba41bf0d0 (diff) | |
download | meta-virtualization-5817c4a29b361812b87eddb2bbb623344dccbdc2.tar.gz |
xen: move bits common to all Xen versions to xen.inc
These items are common for all Xen versions since at least 4.5 and newer
so these should just go in the common include file.
Signed-off-by: Doug Goldstein <cardoe@cardoe.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/xen')
-rw-r--r-- | recipes-extended/xen/xen.inc | 14 | ||||
-rw-r--r-- | recipes-extended/xen/xen_4.6.0.bb | 17 |
2 files changed, 14 insertions, 17 deletions
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc index 86508ff4..a46421b8 100644 --- a/recipes-extended/xen/xen.inc +++ b/recipes-extended/xen/xen.inc | |||
@@ -693,6 +693,11 @@ python () { | |||
693 | raise bb.parse.SkipPackage('Cannot map `%s` to a xen architecture' % d.getVar('TARGET_ARCH', True)) | 693 | raise bb.parse.SkipPackage('Cannot map `%s` to a xen architecture' % d.getVar('TARGET_ARCH', True)) |
694 | } | 694 | } |
695 | 695 | ||
696 | # Yocto appends ${PN} to libexecdir by default and Xen appends 'xen' as well | ||
697 | # the result is a nested xen/xen/ so let's avoid that by shunning Yocto's | ||
698 | # extra ${PN} appended. | ||
699 | libexecdir = "${libdir}" | ||
700 | |||
696 | # hardcoded as Linux, as the only compatible hosts are Linux. | 701 | # hardcoded as Linux, as the only compatible hosts are Linux. |
697 | export XEN_OS = "Linux" | 702 | export XEN_OS = "Linux" |
698 | 703 | ||
@@ -720,8 +725,17 @@ EXTRA_OECONF += " \ | |||
720 | --disable-xenstore-stubdom \ | 725 | --disable-xenstore-stubdom \ |
721 | --disable-rombios \ | 726 | --disable-rombios \ |
722 | --disable-ocamltools \ | 727 | --disable-ocamltools \ |
728 | --with-initddir=${INIT_D_DIR} \ | ||
729 | --with-sysconfig-leaf-dir=default \ | ||
730 | --with-system-qemu=/usr/bin/qemu-system-i386 \ | ||
731 | --disable-qemu-traditional \ | ||
723 | " | 732 | " |
724 | 733 | ||
734 | EXTRA_OEMAKE += "STDVGA_ROM=${STAGING_DIR_HOST}/usr/share/firmware/vgabios-0.7a.bin" | ||
735 | EXTRA_OEMAKE += "CIRRUSVGA_ROM=${STAGING_DIR_HOST}/usr/share/firmware/vgabios-0.7a.cirrus.bin" | ||
736 | EXTRA_OEMAKE += "SEABIOS_ROM=${STAGING_DIR_HOST}/usr/share/firmware/bios.bin" | ||
737 | EXTRA_OEMAKE += "ETHERBOOT_ROMS=${STAGING_DIR_HOST}/usr/share/firmware/rtl8139.rom" | ||
738 | |||
725 | # check for XSM in package config to allow XSM_ENABLE to be set | 739 | # check for XSM in package config to allow XSM_ENABLE to be set |
726 | python () { | 740 | python () { |
727 | pkgconfig = d.getVar('PACKAGECONFIG', True) | 741 | pkgconfig = d.getVar('PACKAGECONFIG', True) |
diff --git a/recipes-extended/xen/xen_4.6.0.bb b/recipes-extended/xen/xen_4.6.0.bb index 95570a75..93c6d2ef 100644 --- a/recipes-extended/xen/xen_4.6.0.bb +++ b/recipes-extended/xen/xen_4.6.0.bb | |||
@@ -10,23 +10,6 @@ SRC_URI[sha256sum] = "6fa1c2431df55aa5950d248e6093b8c8c0f11c357a0adbd348a2186478 | |||
10 | 10 | ||
11 | S = "${WORKDIR}/xen-${PV}" | 11 | S = "${WORKDIR}/xen-${PV}" |
12 | 12 | ||
13 | # Xen suffixes the libexecdir within its configure scripts, prevent the nested xen/xen/ | ||
14 | libexecdir = "${libdir}" | ||
15 | |||
16 | # These options override detected values from the build. | ||
17 | EXTRA_OECONF_append += " \ | ||
18 | --with-initddir=${INIT_D_DIR} \ | ||
19 | --with-sysconfig-leaf-dir=default \ | ||
20 | --with-system-qemu=/usr/bin/qemu-system-i386 \ | ||
21 | --disable-qemu-traditional \ | ||
22 | " | ||
23 | |||
24 | EXTRA_OEMAKE += "STDVGA_ROM=${STAGING_DIR_HOST}/usr/share/firmware/vgabios-0.7a.bin" | ||
25 | EXTRA_OEMAKE += "CIRRUSVGA_ROM=${STAGING_DIR_HOST}/usr/share/firmware/vgabios-0.7a.cirrus.bin" | ||
26 | EXTRA_OEMAKE += "SEABIOS_ROM=${STAGING_DIR_HOST}/usr/share/firmware/bios.bin" | ||
27 | EXTRA_OEMAKE += "ETHERBOOT_ROMS=${STAGING_DIR_HOST}/usr/share/firmware/rtl8139.rom" | ||
28 | #EXTRA_OEMAKE += "XENGFX_ROM=${STAGING_DIR_HOST}/usr/share/firmware/vgabios.bin" | ||
29 | |||
30 | do_install_append() { | 13 | do_install_append() { |
31 | # fixup default path to qemu-system-i386 | 14 | # fixup default path to qemu-system-i386 |
32 | sed -i 's#\(test -z "$QEMU_XEN" && QEMU_XEN=\).*$#\1"/usr/bin/qemu-system-i386"#' ${D}/etc/init.d/xencommons | 15 | sed -i 's#\(test -z "$QEMU_XEN" && QEMU_XEN=\).*$#\1"/usr/bin/qemu-system-i386"#' ${D}/etc/init.d/xencommons |