summaryrefslogtreecommitdiffstats
path: root/recipes-extended/xen/files
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-06-22 09:34:13 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-06-22 09:34:13 -0400
commit13b554261e5aa40d1f1ad06bafd82eedce00ceb9 (patch)
treeee0e4e2c0cdadf4e43c1595aa909a0e9d8d2a9af /recipes-extended/xen/files
parent73fff505780467b7bd3d58ccbd39a22332849e41 (diff)
downloadmeta-virtualization-13b554261e5aa40d1f1ad06bafd82eedce00ceb9.tar.gz
xen: temporarily inhibit werror
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/xen/files')
-rw-r--r--recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch b/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch
new file mode 100644
index 00000000..0f075553
--- /dev/null
+++ b/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch
@@ -0,0 +1,40 @@
1From 9cff3bf8425ccc593825fcde8ca5eaa32a43d04d Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Thu, 18 Jun 2020 09:05:22 -0400
4Subject: [PATCH] xen/build: temporarily inhibit Werror
5
6Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
7---
8 tools/libxl/Makefile | 2 +-
9 xen/Rules.mk | 2 +-
10 2 files changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/tools/libxl/Makefile b/tools/libxl/Makefile
13index 6da342ed61..c67560e269 100644
14--- a/tools/libxl/Makefile
15+++ b/tools/libxl/Makefile
16@@ -11,7 +11,7 @@ MINOR = 0
17 XLUMAJOR = 4.12
18 XLUMINOR = 0
19
20-CFLAGS += -Werror -Wno-format-zero-length -Wmissing-declarations \
21+CFLAGS += -Wno-format-zero-length -Wmissing-declarations \
22 -Wno-declaration-after-statement -Wformat-nonliteral
23 CFLAGS += -I. -fPIC
24
25diff --git a/xen/Rules.mk b/xen/Rules.mk
26index a151b3f625..a05ceec1e5 100644
27--- a/xen/Rules.mk
28+++ b/xen/Rules.mk
29@@ -54,7 +54,7 @@ CFLAGS += -fomit-frame-pointer
30 endif
31
32 CFLAGS += -nostdinc -fno-builtin -fno-common
33-CFLAGS += -Werror -Wredundant-decls -Wno-pointer-arith
34+CFLAGS += -Wredundant-decls -Wno-pointer-arith
35 $(call cc-option-add,CFLAGS,CC,-Wvla)
36 CFLAGS += -pipe -D__XEN__ -include $(BASEDIR)/include/xen/config.h
37 CFLAGS-$(CONFIG_DEBUG_INFO) += -g
38--
392.19.1
40