summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vhost-device/vhost-device-i2c_0.1.0.bb
diff options
context:
space:
mode:
authorErik Schilling <erik.schilling@linaro.org>2023-08-14 10:04:06 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-08-15 18:48:32 +0000
commit28205358690f79e13c1970ea7d61bce0131da027 (patch)
tree8713cd4490d588827011d9d925ff0411c0d47e07 /recipes-extended/vhost-device/vhost-device-i2c_0.1.0.bb
parent81bd76bd1880ad589c41cd90726921dd52989a92 (diff)
downloadmeta-virtualization-28205358690f79e13c1970ea7d61bce0131da027.tar.gz
vhost-device: add recipes for vhost-device daemons
This adds recipes for the first tagged release of the vhost-device daemons of the rust-vmm project. While the initial release was done for all daemons at the same time, the daemons all have indepentend version numbers and will be released on their own schedules in the future. Therefore, I splitted them into independent recipes. Signed-off-by: Erik Schilling <erik.schilling@linaro.org> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/vhost-device/vhost-device-i2c_0.1.0.bb')
-rw-r--r--recipes-extended/vhost-device/vhost-device-i2c_0.1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-extended/vhost-device/vhost-device-i2c_0.1.0.bb b/recipes-extended/vhost-device/vhost-device-i2c_0.1.0.bb
new file mode 100644
index 00000000..c9179da3
--- /dev/null
+++ b/recipes-extended/vhost-device/vhost-device-i2c_0.1.0.bb
@@ -0,0 +1,16 @@
1SUMMARY = "vhost i2c backend device"
2DESCRIPTION = "A vhost-user backend that emulates a VirtIO I2C device"
3HOMEPAGE = "https://github.com/rust-vmm/vhost-device"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = " \
6 file://LICENSE-APACHE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
7 file://LICENSE-BSD-3-Clause;md5=2489db1359f496fff34bd393df63947e \
8"
9
10SRC_URI += "crate://crates.io/vhost-device-i2c/0.1.0"
11SRC_URI[vhost-device-i2c-0.1.0.sha256sum] = "a77923a4f161887ca2a19ead2d2f2271d62d1268e774265c42c277367f019a3f"
12
13inherit cargo
14inherit cargo-update-recipe-crates
15
16include vhost-device-i2c-crates.inc