summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vgabios/vgabios_0.8a.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-04-29 13:11:35 +0100
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-05-02 14:07:30 -0400
commit8386caefb7449f9b53e646c2e2cb1ba8bef6faa6 (patch)
tree89df9ea08bdc8aaf5edc92d62acc65f83d7fa4cb /recipes-extended/vgabios/vgabios_0.8a.bb
parent36433bfef3b690ee1211f04a38022b1f3dc2b383 (diff)
downloadmeta-virtualization-8386caefb7449f9b53e646c2e2cb1ba8bef6faa6.tar.gz
vgabios: upgrade to 0.8a and cleanup recipe
Upgrade to 0.8a. License checksum updated as the FSF street address changed. Apply a patch to use the correct host compiler when building biossums, removing the need for a separate biossums-native recipe. Don't hardcode /usr/share, use ${datadir}. Install all found firmware (including the new Banshee BIOS in 0.8a) and the debug files which were not installed but intended to be packaged. Remove redundant PR and S assignments, as these are the default values. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/vgabios/vgabios_0.8a.bb')
-rw-r--r--recipes-extended/vgabios/vgabios_0.8a.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-extended/vgabios/vgabios_0.8a.bb b/recipes-extended/vgabios/vgabios_0.8a.bb
new file mode 100644
index 00000000..044bb4ec
--- /dev/null
+++ b/recipes-extended/vgabios/vgabios_0.8a.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Plex86/Bochs LGPL VGABios"
2HOMEPAGE = "http://www.nongnu.org/vgabios/"
3LICENSE = "LGPL-2.1-only"
4SECTION = "firmware"
5
6DEPENDS = "dev86-native"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=fae731a3adbc92fd8bb1730d1f2455bc"
9
10SRC_URI = "http://savannah.gnu.org/download/vgabios/${BP}.tgz \
11 file://build-cc.patch"
12SRC_URI[sha256sum] = "481042240ef0f1c918780c92a6bb42ad4d3f5d989b29502fa7ee7faf13a041b9"
13
14EXTRA_OEMAKE = "HOSTCC="${BUILD_CC}""
15
16do_install() {
17 install -d ${D}${datadir}/firmware
18 for file in VGABIOS*.bin; do
19 target=$(echo $file | sed s/VGABIOS-lgpl-latest/${BP}/)
20 install -m0644 $file ${D}${datadir}/firmware/$target
21 done
22}
23
24FILES:${PN} = "${datadir}/firmware/${BP}*.bin"
25FILES:${PN}-dbg = "${datadir}/firmware/${BP}*.debug.bin"