diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2023-05-03 11:05:44 +0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-05-08 18:41:38 -0400 |
commit | 7de3e4e51a23b016c12e1e542e253fa0c9d9a1de (patch) | |
tree | bdd2a04bf92fc8e2031a235364f7b7931935d8c8 /recipes-extended/libvmi | |
parent | f6d4c34ac9dcd726cd01aac7525a1ca92eaa4f96 (diff) | |
download | meta-virtualization-7de3e4e51a23b016c12e1e542e253fa0c9d9a1de.tar.gz |
libvmi: add dependency on flex-native and bison-native instead of byacc-native
* fails to build with byacc-native 20230219 from:
https://git.openembedded.org/meta-openembedded/commit/?id=3462709d651f44f3d067b3ce0bcfba876be9ff1d
* https://invisible-island.net/byacc/CHANGES.html#index-t20230219 says:
provide for a named union, e.g., "%union foo" by detecting the name and
deferring the typedef in that case until the end of copying the union
definition (report by Dag-Erling Smørgrav).
which in this case leads to this diff (compared to byacc 20230201):
--- 0.14.0+gitAUTOINC+41600b6028-r0-byacc_20230201/git/libvmi/config/grammar.c 2023-05-03 07:44:51.694234317 +0000
+++ 0.14.0+gitAUTOINC+41600b6028-r0-byacc_20230219/git/libvmi/config/grammar.c 2023-05-03 07:37:14.177205785 +0000
@@ -5,7 +5,7 @@
#define YYBYACC 1
#define YYMAJOR 2
#define YYMINOR 0
-#define YYPATCH 20230201
+#define YYPATCH 20230219
#define YYEMPTY (-1)
#define yyclearin (yychar = YYEMPTY)
@@ -273,7 +273,7 @@
#ifndef YYSTYPE_IS_DECLARED
#define YYSTYPE_IS_DECLARED 1
#line 249 "libvmi/config/grammar.y"
-typedef union YYSTYPE{
+typedef union YYSTYPE�(�o&V{
char *str;
} YYSTYPE;
#endif /* !YYSTYPE_IS_DECLARED */
* and the unicode chars after YYSTYPE lead to:
http://errors.yoctoproject.org/Errors/Details/702745/
libvmi/config/grammar.y:249:22: error: stray '\370' in program
249 | %union{
| ^
libvmi/config/grammar.y:249:25: error: expected ')' before '+' token
249 | %union{
| ^
| )
libvmi/config/grammar.y:249:26: error: stray '\3' in program
249 | %union{
| ^
make[1]: *** [Makefile:1997: libvmi/config/libconfig_la-grammar.lo] Error 1
* bison-native works fine, so use that for now
* I've reported this issue to byacc author over e-mail
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/libvmi')
-rw-r--r-- | recipes-extended/libvmi/libvmi_git.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-extended/libvmi/libvmi_git.bb b/recipes-extended/libvmi/libvmi_git.bb index 72069c68..6338b801 100644 --- a/recipes-extended/libvmi/libvmi_git.bb +++ b/recipes-extended/libvmi/libvmi_git.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02" | |||
6 | SECTION = "console/tools" | 6 | SECTION = "console/tools" |
7 | PV = "0.14.0+git${SRCPV}" | 7 | PV = "0.14.0+git${SRCPV}" |
8 | 8 | ||
9 | DEPENDS = "libvirt libcheck bison fuse byacc-native" | 9 | DEPENDS = "libvirt libcheck bison fuse bison-native flex-native" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/libvmi/libvmi.git;branch=master;protocol=https \ | 11 | SRC_URI = "git://github.com/libvmi/libvmi.git;branch=master;protocol=https \ |
12 | file://0001-Build-vbd-only-when-xen-is-enabled.patch \ | 12 | file://0001-Build-vbd-only-when-xen-is-enabled.patch \ |